summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-21 07:27:05 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-21 09:07:58 +0200
commit4b5775e57a097a3589dd4b02e8202c51ff134ea5 (patch)
tree5cff97910ef989cf9190dd63cf1fafaa2c0ac882
parentx11-drivers/nvidia-drivers: Old (diff)
downloadgentoo-4b5775e57a097a3589dd4b02e8202c51ff134ea5.tar.gz
gentoo-4b5775e57a097a3589dd4b02e8202c51ff134ea5.tar.bz2
gentoo-4b5775e57a097a3589dd4b02e8202c51ff134ea5.zip
dev-python/virtualenv: Bump to 20.0.21
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/virtualenv/Manifest1
-rw-r--r--dev-python/virtualenv/virtualenv-20.0.21.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/virtualenv/Manifest b/dev-python/virtualenv/Manifest
index e9fb322bc9f1..3ecc7f8bc5b3 100644
--- a/dev-python/virtualenv/Manifest
+++ b/dev-python/virtualenv/Manifest
@@ -2,3 +2,4 @@ DIST virtualenv-16.0.0.tar.gz 1968312 BLAKE2B efc25f7c12335bb8619c3de125af3693d7
DIST virtualenv-16.7.10.tar.gz 5116776 BLAKE2B 42f0a4b4330850b504f8febd991ef6ecdcbb0821efdd94ca324a8cc34a68a760a8a98de97f0cb2384d8e6cbb0ce8f261995c6433886444e29b75ba0ce09ca12c SHA512 f06d7c354ce1910f04dbcbe1a77e60392653bbe4f638bafbe9284454db2c0e5d63cf9159201d0916fc01aaba91d45fb733b63096c38517fcd83fd00ed8b26d28
DIST virtualenv-16.7.9.tar.gz 5116740 BLAKE2B 10b77c4d74d3b1be60d567caf60b48274893777313d7151350df1d8a7d86d7cbd299c6c04734cbad134512e2ea05f5bc694648b6e9307019ffd9b91f7d0cdaf5 SHA512 d7379941e299c44beba30eaab68d5f1a6650f767b24f95d5e8abd05c1529dca4c1423113a41ff42690bb2b2bd4fe05c3e47a8fed4f9df0972188f6c77034436b
DIST virtualenv-20.0.18.tar.gz 7982748 BLAKE2B f759ff1c42aaf9229e3f8dedd7b50df12e3a7616f979e18a5a91d58afd190beea86c67e0f7c530ba327427f3a4967ab27d7b922723c9ce92cba844946f8eb8ff SHA512 9295acb4d21da13c93fcf2a73244137a6fd8384313cf2685b67295f3be8cf33aaf6d22fc9ba4fa93dbfd81429eeaf4eb46d752fb717f0f74c172a754b92d41e6
+DIST virtualenv-20.0.21.tar.gz 8036935 BLAKE2B 63519368c951989a4112abd77bc8dbdb3548872ccd2da8c8fb8ed0d8dd2b99271df4b666dc5618eb4ccb650ecefff07d57e47ba6ce56c770de432e79f5eb1931 SHA512 168bd977bfecf98b76a20c6059fa372a3a9681e778539d962c7062a19ffdf3387c89eca50e03a4fe83ff2ae8affaf8ec3f87141d0c94240ea205df329a113651
diff --git a/dev-python/virtualenv/virtualenv-20.0.21.ebuild b/dev-python/virtualenv/virtualenv-20.0.21.ebuild
new file mode 100644
index 000000000000..a2cafd2f7921
--- /dev/null
+++ b/dev-python/virtualenv/virtualenv-20.0.21.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Virtual Python Environment builder"
+HOMEPAGE="
+ https://virtualenv.pypa.io/en/stable/
+ https://pypi.org/project/virtualenv/
+ https://github.com/pypa/virtualenv/
+"
+SRC_URI="https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/appdirs-1.4.3[${PYTHON_USEDEP}]
+ >=dev-python/distlib-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-41[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/contextlib2-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pathlib2-2.3.3[${PYTHON_USEDEP}]
+ ' -2)
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-0.12[${PYTHON_USEDEP}]
+ ' -2 python3_{6,7} pypy3)
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-1.0[${PYTHON_USEDEP}]
+ ' -2 python3_6 pypy3)"
+# coverage is used somehow magically in virtualenv, maybe it actually
+# tests something useful
+BDEPEND="${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ >=dev-python/pip-20.0.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-1.3.4[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ ' -3)
+ )"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/towncrier
+distutils_enable_tests pytest
+
+src_prepare() {
+ # we don't have xonsh
+ rm tests/unit/activation/test_xonsh.py || die
+ # require internet
+ sed -e 's:test_seed_link_via_app_data:_&:' \
+ -i tests/unit/seed/test_boostrap_link_via_app_data.py || die
+ # TODO: investigate
+ sed -e 's:test_cross_major:_&:' \
+ -i tests/unit/create/test_creator.py || die
+ sed -e 's:test_py_info_to_system_raises:_&:' \
+ -i tests/unit/discovery/py_info/test_py_info.py || die
+
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ # TODO: fix/skip with more granularity tests on pypy3
+ if has "${EPYTHON}" pypy3 python2.7; then
+ einfo "Skipping broken tests on pypy3"
+ continue
+ fi
+
+ distutils_install_for_testing
+
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}