summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-06-13 19:41:10 +0200
committerPacho Ramos <pacho@gentoo.org>2020-06-13 19:41:48 +0200
commit4b72e59ed9b1fcdb1ab88ede59c9a863549c5295 (patch)
tree8fb7c03aea6f7951bcab5570fb34222cc0213d0c
parentmultilib.eclass: export PKG_CONFIG in multilib_toolchain_setup (diff)
downloadgentoo-4b72e59ed9b1fcdb1ab88ede59c9a863549c5295.tar.gz
gentoo-4b72e59ed9b1fcdb1ab88ede59c9a863549c5295.tar.bz2
gentoo-4b72e59ed9b1fcdb1ab88ede59c9a863549c5295.zip
sci-chemistry/mdtraj: Bump to 1.9.4
Closes: https://bugs.gentoo.org/711696 Closes: https://bugs.gentoo.org/718478 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--sci-chemistry/mdtraj/Manifest1
-rw-r--r--sci-chemistry/mdtraj/mdtraj-1.9.4.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sci-chemistry/mdtraj/Manifest b/sci-chemistry/mdtraj/Manifest
index 982cdea3569f..8e63d1026da5 100644
--- a/sci-chemistry/mdtraj/Manifest
+++ b/sci-chemistry/mdtraj/Manifest
@@ -1 +1,2 @@
DIST mdtraj-1.9.1.tar.gz 1985711 BLAKE2B 625b7c1da998bd46732604dcc93c76f970f3c79f10e81aa9f4b3051ee45101efea8afd803d539ba1831dac3e7ed208d7c3773f74189a3887063cbff2b4d79df6 SHA512 015d9d1e258a7a207ac3b7e7a81b87c308e8684ee0a173ae9b722a90910e95e7f2ee18158c163212fae39d093b0cf397293d6e713538acb1fd20a7b70f2adc76
+DIST mdtraj-1.9.4.tar.gz 2133297 BLAKE2B c1507246bf0c8d7f6753f3d505f940e6f2f001361e42f10c9775647a7e6b58edf2d3953a8e48932f6bf9ad90b27e1baf30df6a7c1a590e49a860175822a25360 SHA512 55f67546db20ce63da3af2231df459e9983e15a65da960784613f746dcce820fe6b0deffbb21b528e93fc6cf674dc7a25ee11110894d2a89e5504e20d200ca38
diff --git a/sci-chemistry/mdtraj/mdtraj-1.9.4.ebuild b/sci-chemistry/mdtraj/mdtraj-1.9.4.ebuild
new file mode 100644
index 000000000000..5537daa6a536
--- /dev/null
+++ b/sci-chemistry/mdtraj/mdtraj-1.9.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Read, write and analyze MD trajectories with only a few lines of Python code"
+HOMEPAGE="http://mdtraj.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/astor[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+# Tests fail (in previous ebuild versions they weren't even run
+RESTRICT="test"
+
+python_prepare() {
+ sed -e "s:re.match('build.*(mdtraj.*)', output_dir).group(1):'.':g" \
+ -i basesetup.py || die
+ distutils-r1_python_prepare_all
+}