summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-01-31 20:16:48 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-31 20:17:07 +0100
commit4b8e9ca20e6f300b2d0e18d2311690d0415699d0 (patch)
tree2c6969370b5ea054c102ba79e3abe1b36dd644b7
parentskel.metadata.xml: update for GLEP 67 (diff)
downloadgentoo-4b8e9ca2.tar.gz
gentoo-4b8e9ca2.tar.bz2
gentoo-4b8e9ca2.zip
media-libs/sdif: Version bump to 3.11.4
Gentoo-Bug: 572686 * EAPI=6 * Remove USE="doc" Package-Manager: portage-2.2.27
-rw-r--r--media-libs/sdif/Manifest1
-rw-r--r--media-libs/sdif/files/sdif-3.11.4-fix-buildsystem.patch60
-rw-r--r--media-libs/sdif/sdif-3.11.4.ebuild39
3 files changed, 100 insertions, 0 deletions
diff --git a/media-libs/sdif/Manifest b/media-libs/sdif/Manifest
index 2f69df2e9ae6..5f11cabb91b6 100644
--- a/media-libs/sdif/Manifest
+++ b/media-libs/sdif/Manifest
@@ -1,2 +1,3 @@
+DIST SDIF-3.11.4-src.zip 1230479 SHA256 b1719b93babf13c6461f3db960cf383803dce274682bc284d9b6ac12405be531 SHA512 3730fdb527909403e43ea793ab97e0a3175bb63dee3d0183db831bb6be85837823c42ae2a3559b6ec94218b4338d04017353282fdc7bb79bbee467e09685d3e9 WHIRLPOOL bc639fc8c51eb9e69d8ba18de393830f3f3bfabc266a47fff1c19c847ec81ef7b857882a0968ed79c4b0220b86cbe1df70f7374d5ba0c538ba7f156d4ecc17c7
DIST SDIF-3.8.6-src.tar.gz 786261 SHA256 857484135cfd5f0623ff3179c60540d06c2351a21e4101f59bebfca032e8655b SHA512 5b9603bed121afe4e4bd524372332c48a226711c029271ce0a26ae644990f060104b03983a3b49afe141897bdf6e878dbfd31a853c38ab14b8d4eb98f868f9e7 WHIRLPOOL b0f5a3730d8ff324bb0e2e3fe230d4880ddbc10b0999ffd80b18e09516b89bb8103c5eea4e322bd3d2d3c94534b732aca1e33b742c5a0687c74550d462239658
DIST SDIF-doc.tar.gz 534161 SHA256 0ff5598019b92a4068b92175285ba03abfdfa4587f5dc1abd980bd17da73f13d SHA512 df03d8dcb69603a5ad96dbee77789b0422e39b5dfbe1f944dff1d3763a59d9dce779ef714fa041a44d9fe30ab4714c0f2343502004c1e9b03286ae701fb14e22 WHIRLPOOL c05c64eb1d290dfbd98fc5356141740851de94bd3cf0af27c114fb0713f229662f1a1e2ce1b415d1790ae5f596d2acf961a7c85fd19284f36edbdcaa7787441c
diff --git a/media-libs/sdif/files/sdif-3.11.4-fix-buildsystem.patch b/media-libs/sdif/files/sdif-3.11.4-fix-buildsystem.patch
new file mode 100644
index 000000000000..162976c6ab45
--- /dev/null
+++ b/media-libs/sdif/files/sdif-3.11.4-fix-buildsystem.patch
@@ -0,0 +1,60 @@
+Remove hardcoded CFLAGS, fix broken example generation.
+
+--- SDIF-3.11.4-src/configure.ac
++++ SDIF-3.11.4-src/configure.ac
+@@ -518,15 +518,15 @@
+ [--enable-debug support additional library/programs with debug enabled],
+ [echo FEATURE enable-debug... $enableval;
+ if test "$enableval" = "yes"; then
+- SELLIB=libsdif-debug.la; CFLAGS="$EXTERNAL_CFLAGS -g2 -Wall";
++ SELLIB=libsdif-debug.la;
+ PROGLIST="querysdif-debug\$(EXEEXT) sdifextract-debug\$(EXEEXT) sdiftotext-debug\$(EXEEXT) tosdif-debug\$(EXEEXT)";
+
+ else
+- SELLIB=libsdif.la; CFLAGS="$EXTERNAL_CFLAGS -O3";
++ SELLIB=libsdif.la;
+ PROGLIST="querysdif\$(EXEEXT) sdifextract\$(EXEEXT) sdiftotext\$(EXEEXT) tosdif\$(EXEEXT)";
+ fi ],
+ [
+-SELLIB=libsdif.la; CFLAGS="$EXTERNAL_CFLAGS -O3";
++SELLIB=libsdif.la;
+ PROGLIST="querysdif\$(EXEEXT) sdifextract\$(EXEEXT) sdiftotext\$(EXEEXT) tosdif\$(EXEEXT)";
+ ])
+
+@@ -538,7 +538,7 @@
+ [--enable-profile generate additional library/programs with profiling output enabled],
+ [echo FEATURE enable-profile... $enableval;
+ if test "$enableval" = "yes"; then
+- SELLIB=libsdif-profile.la; CFLAGS="$CFLAGS -g -pg -fprofile-arcs";
++ SELLIB=libsdif-profile.la;
+ PROGLIST="querysdif-profile\$(EXEEXT) sdifextract-profile\$(EXEEXT) sdiftotext-profile\$(EXEEXT) tosdif-profile\$(EXEEXT)";
+ dnl else use the one selected above
+ fi ],
+--- SDIF-3.11.4-src/examples/Makefile.am
++++ SDIF-3.11.4-src/examples/Makefile.am
+@@ -18,18 +18,14 @@
+ # trying to add source code to dist, not working yet
+ #
+
+-INCLUDES = -I../include -I$(top_srcdir)/include -I$(top_srcdir)/sdif
+-CFLAGS = @CFLAGS@ '-DVERSION="$(VERSION)"'
++AM_CPPFLAGS = -I../include -I$(top_srcdir)/include -I$(top_srcdir)/sdif
++AM_CFLAGS = '-DVERSION="$(VERSION)"' @PTHREAD_CFLAGS@
+
+-libsdif = $(top_srcdir)/sdif/.libs/libsdif.a
++bin_PROGRAMS = list-types list-nvt
+
+-# this is for automake
+-EXTRA_DIST = list-types.c list-nvt.c
++list_types_SOURCES = list-types.c
++list_types_LDADD = $(top_srcdir)/sdif/.libs/libsdif.a @PTHREAD_CFLAGS@ @PTHREAD_LIBS@
+
+-all: list-types list-nvt
++list_nvt_SOURCES = list-nvt.c
++list_nvt_LDADD = $(top_srcdir)/sdif/.libs/libsdif.a @PTHREAD_CFLAGS@ @PTHREAD_LIBS@
+
+-list-types: list-types.c $(libsdif)
+- gcc -I../include -g -o $@ $^
+-
+-list-nvt: list-nvt.c $(libsdif)
+- gcc $(LDFLAGS) -I../include -g -o $@ $^
diff --git a/media-libs/sdif/sdif-3.11.4.ebuild b/media-libs/sdif/sdif-3.11.4.ebuild
new file mode 100644
index 000000000000..48265bfe1c15
--- /dev/null
+++ b/media-libs/sdif/sdif-3.11.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="Sound Description Interchange Format Library for audio and wave processing"
+HOMEPAGE="http://sourceforge.net/projects/sdif/"
+SRC_URI="http://sourceforge.net/projects/sdif/files/sdif/SDIF-${PV}/SDIF-${PV}-src.zip"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug ftruncate threads"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-buildsystem.patch"
+)
+S="${WORKDIR}/SDIF-${PV}-src"
+
+src_prepare() {
+ mv configure.{in,ac} || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable ftruncate) \
+ $(use_enable threads pthreads)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}