summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-16 15:26:53 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-03-17 10:49:27 +0200
commit4d1bf8f28fc0c649b5fcb559ea86afc99dd018e3 (patch)
treeb2a19324a1f8fdb2022d4b1c95ad7f7b5b82ee49
parentapp-text/iso-codes: remove old (diff)
downloadgentoo-4d1bf8f28fc0c649b5fcb559ea86afc99dd018e3.tar.gz
gentoo-4d1bf8f28fc0c649b5fcb559ea86afc99dd018e3.tar.bz2
gentoo-4d1bf8f28fc0c649b5fcb559ea86afc99dd018e3.zip
dev-python/zconfig: new package
A configuration library supporting a hierarchical schema-driven configuration model, and allowing a schema to specify data conversion routines written in Python. Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14981 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-python/zconfig/Manifest1
-rw-r--r--dev-python/zconfig/metadata.xml16
-rw-r--r--dev-python/zconfig/zconfig-3.5.0.ebuild39
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/zconfig/Manifest b/dev-python/zconfig/Manifest
new file mode 100644
index 000000000000..e81812888061
--- /dev/null
+++ b/dev-python/zconfig/Manifest
@@ -0,0 +1 @@
+DIST ZConfig-3.5.0.tar.gz 127317 BLAKE2B 735d554072d4be4ee0552151a6bd0401e66bc0a7a091d97656a2c95efb13580d264a39e28c11e096ee77f57bc96d684720c22c981f5dbd82ce012d40c94d33ea SHA512 14af4de2adcb7e5404a4fd8e1a1903758c584898fda7c4d2a660616c37023f0e0b5d4acac789a930c2900eb501528899d51c4ea4c4050535cfbaa629e9159558
diff --git a/dev-python/zconfig/metadata.xml b/dev-python/zconfig/metadata.xml
new file mode 100644
index 000000000000..56e6e550fd6e
--- /dev/null
+++ b/dev-python/zconfig/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">zopefoundation/ZConfig</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ZConfig is a configuration library intended for general use. It supports a hierarchical schema-driven configuration model that allows a schema to specify data conversion routines written in Python. ZConfig’s model is very different from the model supported by the ConfigParser module found in Python’s standard library, and is more suitable to configuration-intensive applications.
+
+ZConfig schema are written in an XML-based language and are able to “import” schema components provided by Python packages. Since components are able to bind to conversion functions provided by Python code in the package (or elsewhere), configuration objects can be arbitrarily complex, with values that have been verified against arbitrary constraints. This makes it easy for applications to separate configuration support from configuration loading even with configuration data being defined and consumed by a wide range of separate packages.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/zconfig/zconfig-3.5.0.ebuild b/dev-python/zconfig/zconfig-3.5.0.ebuild
new file mode 100644
index 000000000000..8e47fe2dcdc1
--- /dev/null
+++ b/dev-python/zconfig/zconfig-3.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+MY_PN="ZConfig"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A configuration library supporting a hierarchical schema-driven configuration model"
+HOMEPAGE="https://pypi.python.org/pypi/ZConfig"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/manuel[${PYTHON_USEDEP}]
+ dev-python/zope-exceptions[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/zope-testrunner[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CHANGES.rst README.rst )
+
+distutils_enable_tests nose
+distutils_enable_sphinx doc dev-python/sphinxcontrib-programoutput