summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Lothian <mike@fireburn.co.uk>2022-04-17 10:31:45 +0100
committerMatt Turner <mattst88@gentoo.org>2022-04-17 20:18:43 -0700
commit4d558066263f70508f0b8acc2e5f35c226d71568 (patch)
tree9b7e3746b9d701f4134d622c57b8c3050f8e4f8f
parentx11-drivers/xf86-video-vmware: Remove dependency on libdrm[libkms] (diff)
downloadgentoo-4d558066263f70508f0b8acc2e5f35c226d71568.tar.gz
gentoo-4d558066263f70508f0b8acc2e5f35c226d71568.tar.bz2
gentoo-4d558066263f70508f0b8acc2e5f35c226d71568.zip
sys-boot/plymouth: Remove dependency on libdrm[libkms]
Libkms has been removed and it does not appear to be a hard requirement to build plymouth. Signed-off-by: Mike Lothian <mike@fireburn.co.uk> Closes: https://github.com/gentoo/gentoo/pull/25058 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--sys-boot/plymouth/metadata.xml2
-rw-r--r--sys-boot/plymouth/plymouth-0.9.5-r2.ebuild (renamed from sys-boot/plymouth/plymouth-0.9.5-r1.ebuild)10
-rw-r--r--sys-boot/plymouth/plymouth-0.9.6_pre20211225-r1.ebuild (renamed from sys-boot/plymouth/plymouth-0.9.6_pre20211225.ebuild)8
-rw-r--r--sys-boot/plymouth/plymouth-22.02.122-r1.ebuild (renamed from sys-boot/plymouth/plymouth-22.02.122.ebuild)8
-rw-r--r--sys-boot/plymouth/plymouth-9999.ebuild10
5 files changed, 19 insertions, 19 deletions
diff --git a/sys-boot/plymouth/metadata.xml b/sys-boot/plymouth/metadata.xml
index 3c5e3d8bbaf5..5900b9002bfe 100644
--- a/sys-boot/plymouth/metadata.xml
+++ b/sys-boot/plymouth/metadata.xml
@@ -6,7 +6,7 @@
<name>Matthew Thode</name>
</maintainer>
<use>
- <flag name="libkms">Provides abstraction to the DRM drivers (intel,
+ <flag name="drm">Provides abstraction to the DRM drivers (intel,
nouveau and vmwgfx at this moment)</flag>
<flag name="pango">Adds support for printing text on splash screen and
text prompts, e.g. for password</flag>
diff --git a/sys-boot/plymouth/plymouth-0.9.5-r1.ebuild b/sys-boot/plymouth/plymouth-0.9.5-r2.ebuild
index 62560bb5edb7..5dd00723beda 100644
--- a/sys-boot/plymouth/plymouth-0.9.5-r1.ebuild
+++ b/sys-boot/plymouth/plymouth-0.9.5-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,16 +21,16 @@ HOMEPAGE="https://cgit.freedesktop.org/plymouth/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="debug +gtk +libkms +pango +split-usr static-libs +udev"
+IUSE="debug +drm +gtk +pango +split-usr static-libs +udev"
CDEPEND="
>=media-libs/libpng-1.2.16:=
+ drm? ( x11-libs/libdrm )
gtk? (
dev-libs/glib:2
>=x11-libs/gtk+-3.14:3
x11-libs/cairo
)
- libkms? ( x11-libs/libdrm[libkms] )
pango? ( >=x11-libs/pango-1.21 )
"
DEPEND="${CDEPEND}
@@ -71,8 +71,8 @@ src_configure() {
$(use_enable !static-libs shared)
$(use_enable static-libs static)
$(use_enable debug tracing)
- $(use_enable gtk gtk)
- $(use_enable libkms drm)
+ $(use_enable drm)
+ $(use_enable gtk)
$(use_enable pango)
$(use_with udev)
)
diff --git a/sys-boot/plymouth/plymouth-0.9.6_pre20211225.ebuild b/sys-boot/plymouth/plymouth-0.9.6_pre20211225-r1.ebuild
index 0c17e6c5bc8b..7ee910f6b422 100644
--- a/sys-boot/plymouth/plymouth-0.9.6_pre20211225.ebuild
+++ b/sys-boot/plymouth/plymouth-0.9.6_pre20211225-r1.ebuild
@@ -23,16 +23,16 @@ HOMEPAGE="https://cgit.freedesktop.org/plymouth/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="debug +gtk +libkms +pango +split-usr static-libs +udev"
+IUSE="debug +drm +gtk +pango +split-usr static-libs +udev"
CDEPEND="
>=media-libs/libpng-1.2.16:=
+ drm? ( x11-libs/libdrm )
gtk? (
dev-libs/glib:2
>=x11-libs/gtk+-3.14:3
x11-libs/cairo
)
- libkms? ( x11-libs/libdrm[libkms] )
pango? ( >=x11-libs/pango-1.21 )
"
DEPEND="${CDEPEND}
@@ -73,8 +73,8 @@ src_configure() {
$(use_enable !static-libs shared)
$(use_enable static-libs static)
$(use_enable debug tracing)
- $(use_enable gtk gtk)
- $(use_enable libkms drm)
+ $(use_enable drm)
+ $(use_enable gtk)
$(use_enable pango)
$(use_with udev)
)
diff --git a/sys-boot/plymouth/plymouth-22.02.122.ebuild b/sys-boot/plymouth/plymouth-22.02.122-r1.ebuild
index 98bb6eb92ea2..e3ad01aa6372 100644
--- a/sys-boot/plymouth/plymouth-22.02.122.ebuild
+++ b/sys-boot/plymouth/plymouth-22.02.122-r1.ebuild
@@ -21,16 +21,16 @@ HOMEPAGE="https://cgit.freedesktop.org/plymouth/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="debug +gtk +libkms +pango +split-usr static-libs +udev"
+IUSE="debug +drm +gtk +pango +split-usr static-libs +udev"
CDEPEND="
>=media-libs/libpng-1.2.16:=
+ drm? ( x11-libs/libdrm )
gtk? (
dev-libs/glib:2
>=x11-libs/gtk+-3.14:3
x11-libs/cairo
)
- libkms? ( x11-libs/libdrm[libkms] )
pango? ( >=x11-libs/pango-1.21 )
"
DEPEND="${CDEPEND}
@@ -71,8 +71,8 @@ src_configure() {
$(use_enable !static-libs shared)
$(use_enable static-libs static)
$(use_enable debug tracing)
- $(use_enable gtk gtk)
- $(use_enable libkms drm)
+ $(use_enable drm)
+ $(use_enable gtk)
$(use_enable pango)
$(use_with udev)
)
diff --git a/sys-boot/plymouth/plymouth-9999.ebuild b/sys-boot/plymouth/plymouth-9999.ebuild
index 3f303786005d..e3ad01aa6372 100644
--- a/sys-boot/plymouth/plymouth-9999.ebuild
+++ b/sys-boot/plymouth/plymouth-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,16 +21,16 @@ HOMEPAGE="https://cgit.freedesktop.org/plymouth/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="debug +gtk +libkms +pango +split-usr static-libs +udev"
+IUSE="debug +drm +gtk +pango +split-usr static-libs +udev"
CDEPEND="
>=media-libs/libpng-1.2.16:=
+ drm? ( x11-libs/libdrm )
gtk? (
dev-libs/glib:2
>=x11-libs/gtk+-3.14:3
x11-libs/cairo
)
- libkms? ( x11-libs/libdrm[libkms] )
pango? ( >=x11-libs/pango-1.21 )
"
DEPEND="${CDEPEND}
@@ -71,8 +71,8 @@ src_configure() {
$(use_enable !static-libs shared)
$(use_enable static-libs static)
$(use_enable debug tracing)
- $(use_enable gtk gtk)
- $(use_enable libkms drm)
+ $(use_enable drm)
+ $(use_enable gtk)
$(use_enable pango)
$(use_with udev)
)