summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-24 06:06:43 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-24 06:06:43 +0100
commit4d9a95ebcaf3e3ad45cc5264171ff2ec3b977568 (patch)
tree9bcfa168329e9b1f0801039a6c64dd2115d366a5
parentdev-python/botocore: Bump to 1.29.78 (diff)
downloadgentoo-4d9a95ebcaf3e3ad45cc5264171ff2ec3b977568.tar.gz
gentoo-4d9a95ebcaf3e3ad45cc5264171ff2ec3b977568.tar.bz2
gentoo-4d9a95ebcaf3e3ad45cc5264171ff2ec3b977568.zip
dev-python/boto3: Bump to 1.26.78
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.78.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index cf6825dbf473..d8f2ea9b4b35 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.26.74.gh.tar.gz 602525 BLAKE2B 6d9b397864649ecd9b3f46bcee832c57cdce
DIST boto3-1.26.75.gh.tar.gz 602878 BLAKE2B 8bce90fd5b6474316922a6da571dfe27a0d5c15743f05c184314d74ae2323635a71d0b7adf02ff7c8ebdea1cfbcb8e730c1d97de96b29fcaa4d178645c760748 SHA512 5d5cbb5e9606aae1a90c5766315c120f799a1cae528b1cc5d052c18b70c276524d9ffb077a662273d30ffa3fff86405c00ec35718bc510505c3fa6f7edc01ad0
DIST boto3-1.26.76.gh.tar.gz 603285 BLAKE2B 1235c9fd21073b9291e581aaf4c298dc498deb1ea51cb66f58a631964c26eb064a4e8ec7b3b0c47f3be166d478101e8edec1f6e77cd162dcc0762bdda19da7b8 SHA512 2fcd0dfca17d86bddde0c752fef1135b8451d1949d4303ffa30f922b389274ca8adf0033dc5459a4964498bf48f15df6b0f58bb90be3351764fd549dbfad9a6d
DIST boto3-1.26.77.gh.tar.gz 603958 BLAKE2B 70944ec50e026e0b78dea8294264034882166293d04e78c18d4429429ea2391b61c791776aa0dbadfb181757afffc33c8db11dc07163d201fe7b95ee02bfda85 SHA512 c33bd44a74da211e6019b6bf64bacb00f979e2470366ede0e283146b1be713519f80d3cce4ad80ba1fc74a3dc3fe568a7237ea2ed897a85b45dc2a21e371ef16
+DIST boto3-1.26.78.gh.tar.gz 604792 BLAKE2B d8abfe3d06c30ce9cc26575aeaabfe4f693477ca40a5ee89faf336ef76e4948cec04f4b9aff15ee33f0e75e156483f80a0d437347317350002293ee8f176f56c SHA512 9a11b7c50ec38b36726ee8f286885cb5b8b8239fa2503255bb1ade8dc76b7b7ce5db731ed99db3dcf6e0062adb7903d48fc2aeee02978e5a60b5279a57a29a43
diff --git a/dev-python/boto3/boto3-1.26.78.ebuild b/dev-python/boto3/boto3-1.26.78.ebuild
new file mode 100644
index 000000000000..9523f65d5fb9
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.78.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}