summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-03-02 13:04:20 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-02 13:37:53 +0100
commit4de6aef3c0de619e53aa8a2d7b7160f3c26ef7d8 (patch)
tree5b0a55e05e5a13c0eca62d954fd53e3df7ce2bb3
parentapp-i18n/ibus: restrict >=dev-lang/vala-0.44 (diff)
downloadgentoo-4de6aef3c0de619e53aa8a2d7b7160f3c26ef7d8.tar.gz
gentoo-4de6aef3c0de619e53aa8a2d7b7160f3c26ef7d8.tar.bz2
gentoo-4de6aef3c0de619e53aa8a2d7b7160f3c26ef7d8.zip
sci-libs/lmfit: remove unused patch
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11218 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--sci-libs/lmfit/files/lmfit-8.0-cmake.patch59
1 files changed, 0 insertions, 59 deletions
diff --git a/sci-libs/lmfit/files/lmfit-8.0-cmake.patch b/sci-libs/lmfit/files/lmfit-8.0-cmake.patch
deleted file mode 100644
index 367aa2147ae4..000000000000
--- a/sci-libs/lmfit/files/lmfit-8.0-cmake.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-from: christoph junghans <junghans@votca.org>
-date: mon, 22 oct 2018 21:00:00 -0600
-subject: [patch] cmake: minor distribution tweaks
-
-- use gnuinstalldirs to allow to configure install dirs
-- allow to disable injecting c flags
-
-signed-off-by: christoph junghans <junghans@votca.org>
----
- cmakelists.txt | 7 +++++--
- lib/cmakelists.txt | 4 ++--
- man/cmakelists.txt | 2 +-
- 3 files changed, 8 insertions(+), 5 deletions(-)
-
-diff -Naur lmfit-8.0.orig/CMakeLists.txt lmfit-8.0/CMakeLists.txt
---- lmfit-8.0.orig/CMakeLists.txt 2018-10-22 20:54:43.452888191 -0600
-+++ lmfit-8.0/CMakeLists.txt 2018-10-22 20:56:00.573905982 -0600
-@@ -13,9 +13,12 @@
- # --- Declare project-wide user flags, and set default values ---
- option(FITTEST "Build with FitTest" OFF)
-
--set(destination ${CMAKE_INSTALL_PREFIX})
-+include(GNUInstallDirs)
-
--set(CMAKE_C_FLAGS "${CMAKE_CXX_FLAGS} -g -O2 -pedantic -Wall -Wno-sign-compare -Wno-unused-result -Wno-parentheses -Wno-unknown-pragmas")
-+option(INJECT_C_FLAGS "Inject a bunch of useful c flags" ON)
-+if (INJECT_C_FLAGS)
-+ set(CMAKE_C_FLAGS "${CMAKE_CXX_FLAGS} -g -O2 -pedantic -Wall -Wno-sign-compare -Wno-unused-result -Wno-parentheses -Wno-unknown-pragmas")
-+endif()
-
- add_subdirectory(lib)
- add_subdirectory(demo)
-diff -Naur lmfit-8.0.orig/lib/CMakeLists.txt lmfit-8.0/lib/CMakeLists.txt
---- lmfit-8.0.orig/lib/CMakeLists.txt 2018-10-22 20:54:43.452888191 -0600
-+++ lmfit-8.0/lib/CMakeLists.txt 2018-10-22 20:55:08.073213116 -0600
-@@ -17,9 +17,9 @@
-
- install(
- TARGETS ${library_name} LIBRARY
-- DESTINATION ${destination}/lib
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
- COMPONENT Libraries)
- install(
- FILES ${inc_files}
-- DESTINATION ${destination}/include
-+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
- COMPONENT Headers)
-diff -Naur lmfit-8.0.orig/man/CMakeLists.txt lmfit-8.0/man/CMakeLists.txt
---- lmfit-8.0.orig/man/CMakeLists.txt 2018-10-22 20:54:43.452888191 -0600
-+++ lmfit-8.0/man/CMakeLists.txt 2018-10-22 20:55:08.073213116 -0600
-@@ -15,7 +15,7 @@
- )
- install(
- FILES ${CMAKE_CURRENT_BINARY_DIR}/${pname}.${section}
-- DESTINATION "${CMAKE_INSTALL_PREFIX}/man/man${section}"
-+ DESTINATION "${CMAKE_INSTALL_MANDIR}/man${section}"
- )
- endfunction()
-