summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-01-15 14:10:23 +0100
committerSam James <sam@gentoo.org>2022-01-28 05:16:44 +0000
commit4e8c857abe0389613cc28766ea3fbb7b15cafdd6 (patch)
tree67eeb2f56c5cf7b7ea5c64739a7f1af78c54df8e
parentdev-util/unicorn: new ebuild (diff)
downloadgentoo-4e8c857abe0389613cc28766ea3fbb7b15cafdd6.tar.gz
gentoo-4e8c857abe0389613cc28766ea3fbb7b15cafdd6.tar.bz2
gentoo-4e8c857abe0389613cc28766ea3fbb7b15cafdd6.zip
dev-util/ropper: new ebuild
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/ropper/Manifest1
-rw-r--r--dev-util/ropper/metadata.xml23
-rw-r--r--dev-util/ropper/ropper-1.13.6.ebuild39
-rw-r--r--dev-util/ropper/ropper-9999.ebuild39
4 files changed, 102 insertions, 0 deletions
diff --git a/dev-util/ropper/Manifest b/dev-util/ropper/Manifest
new file mode 100644
index 000000000000..1e30c7f56dee
--- /dev/null
+++ b/dev-util/ropper/Manifest
@@ -0,0 +1 @@
+DIST ropper-1.13.6.tar.gz 1491005 BLAKE2B aa82c9791eec2362c79f3cd96995cb505b73c8131b0b6fe6a7d0932e3551dd15ea401383e12ab79901ea05e749cb2ca8244fa3c909e0e8955910d321c8436ea9 SHA512 c3e20bc7182a94984f50c42334a7af1e64bd564615a3aaaa08f432b0641a9557d27fd19bdb6c33a276d66c4b512534c625751e20531c324bde96a58d9c89b6d4
diff --git a/dev-util/ropper/metadata.xml b/dev-util/ropper/metadata.xml
new file mode 100644
index 000000000000..55a2e0eba0c7
--- /dev/null
+++ b/dev-util/ropper/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <longdescription>
+ You can use ropper to display information about binary files in
+ different file formats and you can search for gadgets to build rop
+ chains for different architectures.
+ </longdescription>
+ <use>
+ <flag name="z3">Enable Z3 contraint solver support</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">sashs/Ropper</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/ropper/ropper-1.13.6.ebuild b/dev-util/ropper/ropper-1.13.6.ebuild
new file mode 100644
index 000000000000..edf020a8ceb0
--- /dev/null
+++ b/dev-util/ropper/ropper-1.13.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Use to display information about binary files in different file formats"
+HOMEPAGE="https://scoding.de/ropper https://github.com/sashs/Ropper"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sashs/Ropper"
+else
+ SRC_URI="https://github.com/sashs/Ropper/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/Ropper-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="z3"
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/capstone[python,${PYTHON_USEDEP}]
+ dev-libs/keystone[python,${PYTHON_USEDEP}]
+ dev-python/filebytes[${PYTHON_USEDEP}]
+ ')
+ z3? ( sci-mathematics/z3[python,${PYTHON_SINGLE_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests setup.py
diff --git a/dev-util/ropper/ropper-9999.ebuild b/dev-util/ropper/ropper-9999.ebuild
new file mode 100644
index 000000000000..edf020a8ceb0
--- /dev/null
+++ b/dev-util/ropper/ropper-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Use to display information about binary files in different file formats"
+HOMEPAGE="https://scoding.de/ropper https://github.com/sashs/Ropper"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sashs/Ropper"
+else
+ SRC_URI="https://github.com/sashs/Ropper/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/Ropper-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="z3"
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/capstone[python,${PYTHON_USEDEP}]
+ dev-libs/keystone[python,${PYTHON_USEDEP}]
+ dev-python/filebytes[${PYTHON_USEDEP}]
+ ')
+ z3? ( sci-mathematics/z3[python,${PYTHON_SINGLE_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests setup.py