summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-22 07:46:18 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-22 07:53:31 +0200
commit4e9ea94c0fcb3dd929c97edd0fa6674fb1f637fc (patch)
tree336ad3b9fde097eefe8ccef818f7d0eb8b543343
parentdev-python/python-lsp-black: Bump to 1.3.0 (diff)
downloadgentoo-4e9ea94c0fcb3dd929c97edd0fa6674fb1f637fc.tar.gz
gentoo-4e9ea94c0fcb3dd929c97edd0fa6674fb1f637fc.tar.bz2
gentoo-4e9ea94c0fcb3dd929c97edd0fa6674fb1f637fc.zip
app-portage/gpyutils: Bump to 0.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-portage/gpyutils/Manifest1
-rw-r--r--app-portage/gpyutils/gpyutils-0.10.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-portage/gpyutils/Manifest b/app-portage/gpyutils/Manifest
index 87c417390048..f66dbf108702 100644
--- a/app-portage/gpyutils/Manifest
+++ b/app-portage/gpyutils/Manifest
@@ -1,2 +1,3 @@
+DIST gpyutils-0.10.gh.tar.gz 24963 BLAKE2B ef6bd54195e1bfbb0734ef8aedbd13dd27b52d2f62d95b741459ecf4f5e93b80085a4cebfbe184fb8ac7e7cf97f4fbb422c5b5e36d0bb9dbc27896a4ad72d86e SHA512 baf6d44db447774ffc976698874f87dbc858ef146aa46ccb0a7e15a1f3d4d1263f75b2f46f319e45fa5994620c71e37ccc42b42b5f05dbde8f3cbacfbd45cbee
DIST gpyutils-0.8.4.gh.tar.gz 20477 BLAKE2B 661ec8c9ae595daa112de2171331a5791fa4a10b50f9ebf76589c4c6ff4d6b8e618657dd9f3dd6cf573871ab6e0a9d017d87e03066fa60ba8b9d4e4617f68306 SHA512 f87a087464ca8e1118232227d2e6ad66aa021caabf0307c153b442fc4467bd124eb918c16104bdd1b42866acde16fdde4b99312a8c047ecf379ed10a74d27541
DIST gpyutils-0.9.gh.tar.gz 24680 BLAKE2B 75f2ebf3a4ed3883aa3c28773edb903ef2063ad0b6c55316578b2fbf725317ec84a1e0017637d36f28903043ff9d82c2b298bbc8424576b1e23c76f5d3107b59 SHA512 306e2e0a9abe95b6dc526b7b04ec7451a7a33e59542c6a0ac12860eadee8501f0e9ff42586dd3df2c5d43e44a43c458665456ba65c435075d3fbbde31b0314b0
diff --git a/app-portage/gpyutils/gpyutils-0.10.ebuild b/app-portage/gpyutils/gpyutils-0.10.ebuild
new file mode 100644
index 000000000000..44a4363e1962
--- /dev/null
+++ b/app-portage/gpyutils/gpyutils-0.10.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utitilies for maintaining Python packages"
+HOMEPAGE="
+ https://github.com/projg2/gpyutils/
+ https://pypi.org/project/gpyutils/
+"
+SRC_URI="
+ https://github.com/projg2/gpyutils/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-portage/gentoopm-0.3.2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest