summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-04 08:56:59 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-04 10:06:16 +0200
commit4f32f3bd67158b457da3344495f8a15f2013d853 (patch)
tree7312d48187ff98b847f15db82f55776db3b491fd
parentdev-python/css-parser: Bump to 1.0.9 (diff)
downloadgentoo-4f32f3bd67158b457da3344495f8a15f2013d853.tar.gz
gentoo-4f32f3bd67158b457da3344495f8a15f2013d853.tar.bz2
gentoo-4f32f3bd67158b457da3344495f8a15f2013d853.zip
dev-python/dulwich: Bump to 0.21.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dulwich/Manifest1
-rw-r--r--dev-python/dulwich/dulwich-0.21.5.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index 00979deaa8e8..8583bb064aeb 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1 +1,2 @@
DIST dulwich-0.21.3.tar.gz 437815 BLAKE2B 889bb20800bbf45da6ddd688ed1e8ff2ca76fc3671409bb4bee4ed7604f008610adcd68feda9bf50bdd6432d3ad400e381506369d6411905a8388884093d5540 SHA512 ffe89535bd48709e68bff6b299034ab6ccd28960cc32b3717d9779c84c87548d8366dfadfb0699c99b99f8e599d91284e05dcc3c1f9ae4d7b208500856eb33ac
+DIST dulwich-0.21.5.tar.gz 441948 BLAKE2B a65aaa3611de6b18a3f63bd195d3831733bea726f634964c14bb817954147e45753868982fb0c3dcf57dec5a2ed8c985229d110234fd6cae8c783367a06bc20c SHA512 5966a4df8ef94d4c61c4e0a2aebbf11b7f9072139f11357e5194e58dc4edfbe83eb76f7b7aa3a52f96f97c5b7908850fcef5de2aa4bccb212126bb21fdc53934
diff --git a/dev-python/dulwich/dulwich-0.21.5.ebuild b/dev-python/dulwich/dulwich-0.21.5.ebuild
new file mode 100644
index 000000000000..2404f4ccf5cd
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.21.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="
+ https://github.com/jelmer/dulwich/
+ https://pypi.org/project/dulwich/
+"
+
+LICENSE="GPL-2+ Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ app-crypt/gpgme[python,${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/fastimport[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ # remove interference from the tests that do stuff like user.name
+ unset GIT_AUTHOR_NAME GIT_AUTHOR_EMAIL GIT_AUTHOR_DATE
+ unset GIT_COMMITTER_NAME GIT_COMMITTER_EMAIL GIT_COMMITTER_DATE
+ unset EMAIL
+ # Do not use make check which rebuilds the extension and uses -Werror,
+ # causing unexpected failures.
+ "${EPYTHON}" -m unittest -v dulwich.tests.test_suite ||
+ die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}