summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-15 06:44:10 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-15 06:44:10 +0100
commit4fa1c478c9b9c0fb90f5ebf8fd13dfb9f96ab17d (patch)
treef56905603a494e191aab6ffd99672e094f4d14ca
parentx11-libs/libva-intel-driver: Remove old (diff)
downloadgentoo-4fa1c478c9b9c0fb90f5ebf8fd13dfb9f96ab17d.tar.gz
gentoo-4fa1c478c9b9c0fb90f5ebf8fd13dfb9f96ab17d.tar.bz2
gentoo-4fa1c478c9b9c0fb90f5ebf8fd13dfb9f96ab17d.zip
x11-libs/libva-intel-driver: bump to 2.1.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--x11-libs/libva-intel-driver/Manifest1
-rw-r--r--x11-libs/libva-intel-driver/libva-intel-driver-2.1.0.ebuild56
-rw-r--r--x11-libs/libva-intel-driver/libva-intel-driver-9999.ebuild8
3 files changed, 61 insertions, 4 deletions
diff --git a/x11-libs/libva-intel-driver/Manifest b/x11-libs/libva-intel-driver/Manifest
index 4102908741e8..25e46eebf2bb 100644
--- a/x11-libs/libva-intel-driver/Manifest
+++ b/x11-libs/libva-intel-driver/Manifest
@@ -1,3 +1,4 @@
DIST libva-intel-driver-1.7.3.tar.gz 1648659 BLAKE2B 5d5bf82d02c6e887f4afd332fa395e3044ac9b9bbf8e1682aeaf80d6c61c1db537b27ed22b25e932ec71d9011af07d9008f64df2e7c77a2c6f9dd0e10860d41f SHA512 57ae4fbf1bd5799e8a311fcd67eda1a8a6d5b5267df502b83f63f8bd0cdd510a4f78b4d09088833bfa2e98447d841c3d4e7229f4e75a9d9f4b8096fb14027878
DIST libva-intel-driver-1.8.3.tar.gz 2591242 BLAKE2B 954ad024ea93073f23045530506c6988cd55bc4bce565856071b30cfc0c10b673a225d4cfdd50cd360a3f828bf236386ba2937e59c260f72717dbdf72a29152c SHA512 0457147aa998014df82ef6180c873fd087b03573adac7ba84c79516a16bd73eb43ff5f07cf3f40c7f590f4e04981ae3010877a468fb20fe4606843932aaa0990
DIST libva-intel-driver-2.0.0.tar.gz 2831508 BLAKE2B 3f777303099cac2df3d3d2394af28e086bb4f9b6d595585cedf0d3a4aed79c8ab9d0a132b828d9b56c9bf09526cd6d0a7b9354832464a9ffec7a66aeb939a528 SHA512 2f538d97ae2ea5cbbaa2660c1498a2288b8828ecae914c500f250c25a433a8ee289a9a5beb001b557dd0d84fa3f4bcd8bbe2f23c705caad527080ecca29b933b
+DIST libva-intel-driver-2.1.0.tar.gz 3954965 BLAKE2B 6ff759860477896df6ee433d7b1ff8f3fda498e98210bfcbec33dc663a65bc07b8304ae219885225985fc65a785d7510aacb785a17d9fd66fb1c16a0ca7ffd57 SHA512 2df0d617a4a64ee37641fd9134f8455f59160d003c252b0e82f7be47adaad7d531f9f2f3ab16d75457b2852e8893887d5be6da5f8128e64ffe8311853baf6453
diff --git a/x11-libs/libva-intel-driver/libva-intel-driver-2.1.0.ebuild b/x11-libs/libva-intel-driver/libva-intel-driver-2.1.0.ebuild
new file mode 100644
index 000000000000..a440f5228714
--- /dev/null
+++ b/x11-libs/libva-intel-driver/libva-intel-driver-2.1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SCM=git-r3
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="https://github.com/intel/intel-vaapi-driver"
+fi
+
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="HW video decode support for Intel integrated graphics"
+HOMEPAGE="https://github.com/intel/intel-vaapi-driver"
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/intel/intel-vaapi-driver/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/intel-vaapi-driver-${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+else
+ KEYWORDS=""
+fi
+IUSE="+drm wayland X"
+
+RDEPEND=">=x11-libs/libva-2.0.0:=[X?,wayland?,drm?,${MULTILIB_USEDEP}]
+ >=x11-libs/libdrm-2.4.52[video_cards_intel,${MULTILIB_USEDEP}]
+ wayland? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] >=dev-libs/wayland-1.11[${MULTILIB_USEDEP}] )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README )
+AUTOTOOLS_PRUNE_LIBTOOL_FILES="all"
+
+src_prepare() {
+ sed -e 's/intel-gen4asm/\0diSaBlEd/g' -i configure.ac || die
+ autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable drm)
+ $(use_enable wayland)
+ $(use_enable X x11)
+ )
+ autotools-utils_src_configure
+}
diff --git a/x11-libs/libva-intel-driver/libva-intel-driver-9999.ebuild b/x11-libs/libva-intel-driver/libva-intel-driver-9999.ebuild
index bcc260be80d3..a440f5228714 100644
--- a/x11-libs/libva-intel-driver/libva-intel-driver-9999.ebuild
+++ b/x11-libs/libva-intel-driver/libva-intel-driver-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -7,18 +7,18 @@ SCM=""
if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
SCM=git-r3
EGIT_BRANCH=master
- EGIT_REPO_URI="https://github.com/01org/intel-vaapi-driver.git"
+ EGIT_REPO_URI="https://github.com/intel/intel-vaapi-driver"
fi
AUTOTOOLS_AUTORECONF="yes"
inherit autotools-multilib ${SCM}
DESCRIPTION="HW video decode support for Intel integrated graphics"
-HOMEPAGE="https://github.com/01org/intel-vaapi-driver"
+HOMEPAGE="https://github.com/intel/intel-vaapi-driver"
if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
SRC_URI=""
else
- SRC_URI="https://github.com/01org/intel-vaapi-driver/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/intel/intel-vaapi-driver/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/intel-vaapi-driver-${PV}"
fi