summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-06-27 02:24:35 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-06-27 02:48:48 +0000
commit5000ff1a971f78384d5fd03a1d529d6d1ac3db98 (patch)
tree5d578dd15c32fd4734ebb1023230009adee8d335
parentdev-python/wcsaxes: added python-3.6, and matplotlib environment to avoid imp... (diff)
downloadgentoo-5000ff1a971f78384d5fd03a1d529d6d1ac3db98.tar.gz
gentoo-5000ff1a971f78384d5fd03a1d529d6d1ac3db98.tar.bz2
gentoo-5000ff1a971f78384d5fd03a1d529d6d1ac3db98.zip
sci-astronomy/erfa: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--sci-astronomy/erfa/Manifest1
-rw-r--r--sci-astronomy/erfa/erfa-1.4.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/sci-astronomy/erfa/Manifest b/sci-astronomy/erfa/Manifest
index e430542c73ca..1c8324c02770 100644
--- a/sci-astronomy/erfa/Manifest
+++ b/sci-astronomy/erfa/Manifest
@@ -1,2 +1,3 @@
DIST erfa-1.2.0.tar.gz 305668 SHA256 efa60520bdad4c9df246d0bc4df8bf6bd9d01be1c5742540940996cf98ff783f SHA512 ead7a44b69048242cba34b0ab419eb97a1bcce6930d5834f5f00c8cae4cb331ee068cece08e51f918f7bd8eaaeada054006377876db01f7b7b4e86c26f17d311 WHIRLPOOL d360ec5d8f7d5db9c2706e82a04f62bba4fb120e0addb0b1522db30772572ebe3109ae62d12b869e323808ffeb176accab79c81fd27c94b3ec227cf2aa1b759d
DIST erfa-1.3.0.tar.gz 640176 SHA256 b3e709206fbd65aa32de06fd690c5a886b97274eecc84ba9711a5a50efba7c92 SHA512 c8dc110e2d581d7de79d0406fb5873201a795e1d7ce8dcf642125082d78d1cb00dd3fe44b76e1b7249014314abd840ad24615ad9d13cd447505af2271c1f31bd WHIRLPOOL 7bd98cfb7ee9de832976b4571c50f40354198899a95546034f494a1cc510e4893239cc47bc968e6c7248a3ee353c2c7698d41614c0432df0c6e2ffe9af7f9f7d
+DIST erfa-1.4.0.tar.gz 641051 SHA256 035b7f0ad05c1191b8588191ba4b19ba0f31afa57ad561d33bd5417d9f23e460 SHA512 2befe5a45486dbbd2ee88229cce7a6101462254bd346d3a2859e294f31119eb5cf5e4113e4061fa3e371216ed793a79ea1ba98fc6fd8aa53d2ba4170e1e135e2 WHIRLPOOL 48bf7f252c6d4b8697d4676b1581edf8aac40d0ae799302df3502971c9d2567bddd177a0a25d1cbf346b52345d16f4938511298f971ac90f178692c0d89c0f7f
diff --git a/sci-astronomy/erfa/erfa-1.4.0.ebuild b/sci-astronomy/erfa/erfa-1.4.0.ebuild
new file mode 100644
index 000000000000..6a721cbc58f4
--- /dev/null
+++ b/sci-astronomy/erfa/erfa-1.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="Essential Routines for Fundamental Astronomy"
+HOMEPAGE="https://github.com/liberfa/erfa"
+SRC_URI="https://github.com/liberfa/erfa/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}