summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2020-04-26 18:44:07 +0200
committerJoerg Bornkessel <hd_brummy@gentoo.org>2020-04-26 18:44:07 +0200
commit511ac15bcb7ea3b8035b66096c783c870c6bd019 (patch)
tree735aa0954ff60cace4b491014dc3530d5e58c1bb
parentmedia-gfx/iscan-plugin-network-nt: Version bump to 1.1.3 (diff)
downloadgentoo-511ac15bcb7ea3b8035b66096c783c870c6bd019.tar.gz
gentoo-511ac15bcb7ea3b8035b66096c783c870c6bd019.tar.bz2
gentoo-511ac15bcb7ea3b8035b66096c783c870c6bd019.zip
dev-libs/tntnet: moved to eapi-7
this commit fix also bug 426262 autotools rename configure.in to configure.ac Package-Manager: Portage-2.3.90, Repoman-2.3.20 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
-rw-r--r--dev-libs/tntnet/tntnet-2.2.1-r1.ebuild2
-rw-r--r--dev-libs/tntnet/tntnet-2.2.1-r2.ebuild94
2 files changed, 96 insertions, 0 deletions
diff --git a/dev-libs/tntnet/tntnet-2.2.1-r1.ebuild b/dev-libs/tntnet/tntnet-2.2.1-r1.ebuild
index 50046a85221a..617f01ca9a91 100644
--- a/dev-libs/tntnet/tntnet-2.2.1-r1.ebuild
+++ b/dev-libs/tntnet/tntnet-2.2.1-r1.ebuild
@@ -88,3 +88,5 @@ src_install() {
newinitd "${FILESDIR}/tntnet.initd" tntnet
fi
}
+
+# @stable ~26may2020 \ No newline at end of file
diff --git a/dev-libs/tntnet/tntnet-2.2.1-r2.ebuild b/dev-libs/tntnet/tntnet-2.2.1-r2.ebuild
new file mode 100644
index 000000000000..2a1e7bb6230c
--- /dev/null
+++ b/dev-libs/tntnet/tntnet-2.2.1-r2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools eutils
+
+DESCRIPTION="Modular, multithreaded web application server extensible with C++"
+HOMEPAGE="http://www.tntnet.org/"
+SRC_URI="http://www.tntnet.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="gnutls libressl server ssl examples"
+
+RDEPEND=">=dev-libs/cxxtools-2.2.1
+ sys-libs/zlib[minizip]
+ ssl? (
+ gnutls? (
+ >=net-libs/gnutls-1.2.0
+ dev-libs/libgcrypt:0
+ )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ app-arch/zip"
+
+src_prepare() {
+ # Both fixed in the next release
+ eapply "${FILESDIR}"/${PN}-2.0-zlib-minizip.patch
+ rm framework/common/{ioapi,unzip}.[ch] || die
+
+ # bug 426262
+ if has_version ">sys-devel/autoconf-2.13"; then
+ mv configure.in configure.ac
+ fi
+
+ # bug 423697
+ sed -e "s:unzip.h:minizip/unzip.h:" -i framework/defcomp/unzipcomp.cpp || die
+
+ eautoreconf
+
+ sed -i -e 's:@localstatedir@:/var:' etc/tntnet/tntnet.xml.in || die
+
+ default
+}
+
+src_configure() {
+ local myconf=""
+
+ # Prefer gnutls above SSL
+ if use gnutls; then
+ einfo "Using gnutls for ssl support."
+ myconf="${myconf} --with-ssl=gnutls"
+ elif use ssl; then
+ einfo "Using openssl for ssl support."
+ myconf="${myconf} --with-ssl=openssl"
+ else
+ myconf="${myconf} --with-ssl=no"
+ fi
+
+ # default enabled, will not compile without sdk
+ myconf="${myconf} --with-sdk"
+
+ econf \
+ $(use_with server) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog README TODO doc/tntnet.pdf
+
+ if use examples; then
+ cd "${S}/sdk/demos"
+ emake clean
+ rm -rf .deps */.deps .libs */.libs
+ cd "${S}"
+
+ docinto examples
+ dodoc -r sdk/demos/*
+ fi
+
+ if use server; then
+ rm -f "${D}/etc/init.d/tntnet"
+ newinitd "${FILESDIR}/tntnet.initd" tntnet
+ fi
+}