summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-10-14 12:00:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-10-14 12:29:17 +0200
commit5162566091b37c0319525698d63cc28be2170b9e (patch)
treeaf6380eece180810de7d9d9c67a3ca88a29e8e4b
parentkde-plasma/ksystemstats: 5.23.0 version bump (diff)
downloadgentoo-5162566091b37c0319525698d63cc28be2170b9e.tar.gz
gentoo-5162566091b37c0319525698d63cc28be2170b9e.tar.bz2
gentoo-5162566091b37c0319525698d63cc28be2170b9e.zip
kde-plasma/kwallet-pam: 5.23.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.23.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 25f214549918..2fbececf3074 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.22.5.tar.xz 19960 BLAKE2B 978860fc113e2a02bd2543aa5147832050fb3b53a1916939cc21772e98a7a2e4d47892d514427f15a3fbff70a6eadcb98fdd934fb8d731992ff3fc8252c32f6b SHA512 230135ee7aadbbc9f08695afa87fd7d8f0e3dca5da40f94bea92ad83a8a2ccc86efb7d593730079a0affc91f28383d089a08fd2b4db57961ba7c5b3a009a6038
DIST kwallet-pam-5.22.90.tar.xz 20116 BLAKE2B 9ad8a89f9ed9adbdb93532bf555d22789c67905dd8c8b985c03a1472d0343be9cc26a73eee3dba140a609b50ce1fac85debe8c8bc6a8faed34fd85024ff0ad0d SHA512 c773af7ac2ecfe3e78c6ca185684ef0f91de85b94d808e1c683600cecfa9385275472673daa82c5e8fcd8648f72e14f60491581d0025df834d60da6b24e4a95d
+DIST kwallet-pam-5.23.0.tar.xz 20124 BLAKE2B 372d973650a18c433bd04cfe085149f298f19b65c0ad3eb81e895e9224df3e8894fc0a06fbd83111f25a2a20ddd6a25f620465a54bf31974923cfffd225214da SHA512 377592c2cce24140b06f7540b14ae870b9080ffd9a458bc72a5ed5d70d4a8a782494af3acad3bee148377f7f369526e8293342d4de388975011f7026f6c22c97
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.23.0.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.23.0.ebuild
new file mode 100644
index 000000000000..bc2a2dd88454
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.23.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.86.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}