summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-09-17 12:42:24 -0400
committerMike Gilbert <floppym@gentoo.org>2021-09-17 12:42:24 -0400
commit51b057f1aacabdb1fcfaf0f09b7ee8c6733a2689 (patch)
tree032e6cf3d48dc27abec23e29a89f2d7f93974667
parentsys-fs/cryptsetup: stop applying cryptsetup-2.0.4-fix-static-pwquality-build.... (diff)
downloadgentoo-51b057f1aacabdb1fcfaf0f09b7ee8c6733a2689.tar.gz
gentoo-51b057f1aacabdb1fcfaf0f09b7ee8c6733a2689.tar.bz2
gentoo-51b057f1aacabdb1fcfaf0f09b7ee8c6733a2689.zip
sys-fs/cryptsetup: move libgpg-error behind USE=gcrypt
Closes: https://bugs.gentoo.org/782541 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-fs/cryptsetup/cryptsetup-2.4.1-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-fs/cryptsetup/cryptsetup-2.4.1-r1.ebuild b/sys-fs/cryptsetup/cryptsetup-2.4.1-r1.ebuild
index c503aa0807b..cd60372120e 100644
--- a/sys-fs/cryptsetup/cryptsetup-2.4.1-r1.ebuild
+++ b/sys-fs/cryptsetup/cryptsetup-2.4.1-r1.ebuild
@@ -22,11 +22,13 @@ REQUIRED_USE="^^ ( ${CRYPTO_BACKENDS//+/} )
LIB_DEPEND="
dev-libs/json-c:=[static-libs(+)]
- dev-libs/libgpg-error[static-libs(+)]
dev-libs/popt[static-libs(+)]
>=sys-apps/util-linux-2.31-r1[static-libs(+)]
argon2? ( app-crypt/argon2:=[static-libs(+)] )
- gcrypt? ( dev-libs/libgcrypt:0=[static-libs(+)] )
+ gcrypt? (
+ dev-libs/libgcrypt:0=[static-libs(+)]
+ dev-libs/libgpg-error[static-libs(+)]
+ )
nettle? ( >=dev-libs/nettle-2.4[static-libs(+)] )
openssl? ( dev-libs/openssl:0=[static-libs(+)] )
pwquality? ( dev-libs/libpwquality[static-libs(+)] )