summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-04-18 10:48:49 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-04-18 10:49:18 -0500
commit51cc15c7d8b75a99c337e47e3f5919a791936f5d (patch)
tree368354060d5b58f841818dc6f4d929c58725732c
parentdev-ruby/dependor: initial import, dependency of dev-ruby/bogus (diff)
downloadgentoo-51cc15c7d8b75a99c337e47e3f5919a791936f5d.tar.gz
gentoo-51cc15c7d8b75a99c337e47e3f5919a791936f5d.tar.bz2
gentoo-51cc15c7d8b75a99c337e47e3f5919a791936f5d.zip
gnome-extra/gnome-integration-spotify: fix for bug 615940 in 20140907-r1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--gnome-extra/gnome-integration-spotify/Manifest1
-rw-r--r--gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r1.ebuild (renamed from gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20131013.ebuild)18
2 files changed, 11 insertions, 8 deletions
diff --git a/gnome-extra/gnome-integration-spotify/Manifest b/gnome-extra/gnome-integration-spotify/Manifest
index dc5157f48654..cb912770a5ce 100644
--- a/gnome-extra/gnome-integration-spotify/Manifest
+++ b/gnome-extra/gnome-integration-spotify/Manifest
@@ -1,2 +1 @@
DIST gnome-integration-spotify-20140907.tar.gz 6709 SHA256 f1906851329461d3e1a2a7171fd8c6be5082505b04415f2879b1f634b554bbfe SHA512 51e0e7fdb0912e230b0965ca05740b01633b3bc0219dd6e8c31ad5a9378b15c1b44ce1f99098900af7a478f0d6180c3ee015c1717603b6c2fb4c54769dddb874 WHIRLPOOL 4f0867fd2aa0d62d9e71c933541896092991ee4389a79845c2ceff2c2712935405134291024817e9039afa0b62da9538cc329e110b739db28e40c1df2a28070e
-DIST gnome-integration-spotify-git-20131013.tgz 6703 SHA256 bb55df923ddf4024f041ccb64753e394083e0c2eac7265f2c875e3432f99f5c8 SHA512 de4033c8bb955732eeb573a9328d068716584b85f4fa62d8090ea9f35c43a032389dd7cbf3d4f3380bb2e46ebc37737c8cf93d67b4f381939742001762da267c WHIRLPOOL 0c5684350fff53b5cb3aa67593c0d12fec69904bca6b55cd70d95a933589be4486e158f4d2cb04e294321ca10c05f2bc062cba0aa3503e6198048743b6d5ec47
diff --git a/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20131013.ebuild b/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r1.ebuild
index a2522a7fc525..6a5839f03b41 100644
--- a/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20131013.ebuild
+++ b/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r1.ebuild
@@ -1,14 +1,17 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
-inherit gnome2-utils
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit gnome2-utils python-r1
DESCRIPTION="GNOME integration for Spotify"
HOMEPAGE="https://github.com/mrpdaemon/gnome-integration-spotify"
-SRC_URI="https://github.com/mrpdaemon/${PN}/tarball/${PV} -> ${PN}-git-${PV}.tgz"
-S="${WORKDIR}/mrpdaemon-${PN}-df9124d"
+#SRC_URI="https://github.com/mrpdaemon/${PN}/tarball/${PV} -> ${PN}-git-${PV}.tgz"
+SRC_URI="https://github.com/mrpdaemon/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+#S="${WORKDIR}/mrpdaemon-${PN}-df9124d"
LICENSE="GPL-3"
SLOT="0"
@@ -17,8 +20,8 @@ IUSE=""
DEPEND=""
RDEPEND="${DEPEND}
- dev-lang/python
- dev-python/dbus-python
+ ${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
media-gfx/imagemagick
x11-misc/wmctrl
x11-misc/xautomation
@@ -27,6 +30,7 @@ RDEPEND="${DEPEND}
src_install() {
dobin spotify-dbus.py
+ python_replicate_script "${ED}"/usr/bin/spotify-dbus.py
mkdir -p "${D}/etc/gconf/schemas"
cp spotify.schemas "${D}/etc/gconf/schemas"
}