summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-11-13 11:45:40 +0000
committerMatthew Smith <matthew@gentoo.org>2022-11-13 11:45:40 +0000
commit51d70dea44f3adc722aa1a5f776dd0144a6fb544 (patch)
tree891b1f85e42b2e2cb8e88e7681ba935e01130303
parentmedia-libs/tremor: Stabilize 0_pre20130223-r3 arm64, #881167 (diff)
downloadgentoo-51d70dea44f3adc722aa1a5f776dd0144a6fb544.tar.gz
gentoo-51d70dea44f3adc722aa1a5f776dd0144a6fb544.tar.bz2
gentoo-51d70dea44f3adc722aa1a5f776dd0144a6fb544.zip
dev-lisp/sbcl: append -D_GNU_SOURCE
Fixes build issue due to O_LARGEFILE hiding behind feature test macro. Closes: https://bugs.gentoo.org/869434 Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--dev-lisp/sbcl/sbcl-2.2.0.ebuild3
-rw-r--r--dev-lisp/sbcl/sbcl-2.2.10.ebuild3
-rw-r--r--dev-lisp/sbcl/sbcl-2.2.9.ebuild3
3 files changed, 9 insertions, 0 deletions
diff --git a/dev-lisp/sbcl/sbcl-2.2.0.ebuild b/dev-lisp/sbcl/sbcl-2.2.0.ebuild
index 39e5a7ef3dba..db275dcfbcc2 100644
--- a/dev-lisp/sbcl/sbcl-2.2.0.ebuild
+++ b/dev-lisp/sbcl/sbcl-2.2.0.ebuild
@@ -156,6 +156,9 @@ src_configure() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
+ # Bug #869434
+ append-cppflags -D_GNU_SOURCE
+
# clear the environment to get rid of non-ASCII strings, see bug #174702
# set HOME for paludis
env - HOME="${T}" PATH="${PATH}" \
diff --git a/dev-lisp/sbcl/sbcl-2.2.10.ebuild b/dev-lisp/sbcl/sbcl-2.2.10.ebuild
index cf2899eb05bc..aa13ed1d98b9 100644
--- a/dev-lisp/sbcl/sbcl-2.2.10.ebuild
+++ b/dev-lisp/sbcl/sbcl-2.2.10.ebuild
@@ -158,6 +158,9 @@ src_configure() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
+ # Bug #869434
+ append-cppflags -D_GNU_SOURCE
+
# clear the environment to get rid of non-ASCII strings, see bug #174702
# set HOME for paludis
env - HOME="${T}" PATH="${PATH}" \
diff --git a/dev-lisp/sbcl/sbcl-2.2.9.ebuild b/dev-lisp/sbcl/sbcl-2.2.9.ebuild
index 0342f59644d1..82e289d11953 100644
--- a/dev-lisp/sbcl/sbcl-2.2.9.ebuild
+++ b/dev-lisp/sbcl/sbcl-2.2.9.ebuild
@@ -161,6 +161,9 @@ src_configure() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
+ # Bug #869434
+ append-cppflags -D_GNU_SOURCE
+
# clear the environment to get rid of non-ASCII strings, see bug #174702
# set HOME for paludis
env - HOME="${T}" PATH="${PATH}" \