summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2023-03-09 10:30:21 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-03-09 10:38:05 +0200
commit521161ea83e847512fa92197a24f8efec0246af8 (patch)
tree4b510b769d485c457b670c0fe416815b70335457
parentdev-vcs/git-tools: add 2022.12 (diff)
downloadgentoo-521161ea83e847512fa92197a24f8efec0246af8.tar.gz
gentoo-521161ea83e847512fa92197a24f8efec0246af8.tar.bz2
gentoo-521161ea83e847512fa92197a24f8efec0246af8.zip
sys-kernel/pf-sources: add 6.2-pf3
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-6.2_p3.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index b274d8968a64..6f27d1958618 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -27,5 +27,6 @@ DIST linux-6.1-pf5.tar.gz 220804202 BLAKE2B 5fadef6d3fa1ef6bf295fe75680ae1be0129
DIST linux-6.1-pf6.tar.gz 220761768 BLAKE2B 8b0f3d16be65f245978a823bc4c3130f76017dcb4e51c0e5c77815ffe61d3122eabec28001571badc8eceed490cb14f27540bbf574fbb0feffba59804e1169ed SHA512 66b2a4d221bc9caf4c22353d39a9a13e990b8e50ef47d1882d9f950b4cf42f6d240d787979a5272eeb8ffba142fb07fcadf438827d3410e220b20e41ac079ea0
DIST linux-6.2-pf1.tar.gz 222840475 BLAKE2B ee66cdfba8b08cbc5ac70f97b87826dc9d04ee8de2fb57f52e1688c1cdc5b0fecfe3bc673fa30849a7417120c1393ebae7c24ca9a2b00b55eb6719de0246160a SHA512 461d2775491675f351ca56787257a4c7fcda9d2a50538a26639448d86ab79fccff895f0385af78bf2e1113aa650383e77f3d114f6cb84c98c4b407690b0d3e63
DIST linux-6.2-pf2.tar.gz 222861169 BLAKE2B b3e6bddc8639475313cb3203b99e068c109c1f2b71a6475ac8c8c0be21ab57c8d6ab2291db38c0b05e2d875a613df531acdfb7bc0d98acaf7efdd6032b6ea7be SHA512 ad038f5ea05da6006f4436c2345cbe259a3cf89be4424be12a96495875d40abf95eeb18afb550be8ef2b00b5013d1001dc5de688e0ebe85f30b655be9acd6840
+DIST linux-6.2-pf3.tar.gz 222849935 BLAKE2B d0c00d16dd92a0a1617442cea2bba0aa64fbba16ae7632609efbb3c107bd27c9e5920b4292497dfbbcc02c8e05d9c726dd0b39a6c31bd834edb976268f6537ba SHA512 f0e24f4a69befbdf14124d8f82f1387a7e8dad7c997e63850d04f81658baf9d9bb7c827fabbe5163695eee8dd4c7bdc3c010674471fe8a3f3b57d2680b0593d7
DIST prjc-519-r1-vd-test.patch 274504 BLAKE2B 87950689ffe97134100aa91d0ff89acd6f4e93b626ad7ab08af464a49457f16526cae7b863d53213dd129d47b6f97b3407ae7027b02656d9eba85942241e8d3f SHA512 d652b6060400329d051257fedee5d9f37a70554ab722e93a15f294d1c6229bfa227941461147e0128178b02875cdf838e0d71e89884d8c01e7549ee482213b71
DIST prjc_v5.18-r2.patch 270353 BLAKE2B 15d7ed7a0eb6f7ad37feaf52ab7c383e1c7c3e72fb41a767c8d1151a0ad41255c216ede1e4938a041f3b628874ed61398c61dd7b0e0b62090730f2fd0f6a70db SHA512 25c558bd6281a09bb611c6cca68084b27d0f2e290d2c0575e88b6a94322fad86de6dbeda30eb77919edd5adff921ad445593d9478f115ec93fa2e4c7ed6b5c1e
diff --git a/sys-kernel/pf-sources/pf-sources-6.2_p3.ebuild b/sys-kernel/pf-sources/pf-sources-6.2_p3.ebuild
new file mode 100644
index 000000000000..3c9b67ed85ac
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-6.2_p3.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Define what default functions to run.
+ETYPE="sources"
+
+# Use genpatches but don't include the 'experimental' use flag.
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Genpatches version to use. -pf patch set already includes vanilla linux updates. Regularly "1"
+# is the wanted value here, but the genpatches patch set can be bumped if it includes some
+# important fixes. src_prepare() will handle deleting the updated vanilla linux patches.
+K_GENPATCHES_VER="1"
+
+# -pf patch set already sets EXTRAVERSION to kernel Makefile.
+K_NOSETEXTRAVERSION="1"
+
+# pf-sources is not officially supported/covered by the Gentoo security team.
+K_SECURITY_UNSUPPORTED="1"
+
+# Define which parts to use from genpatches - experimental is already included in the -pf patch
+# set.
+K_WANT_GENPATCHES="base extras"
+
+# Major kernel version, e.g. 5.14.
+SHPV="${PV/_p*/}"
+
+# Replace "_p" with "-pf", since using "-pf" is not allowed for an ebuild name by PMS.
+PFPV="${PV/_p/-pf}"
+
+inherit kernel-2 optfeature
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://pfkernel.natalenko.name/
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="https://codeberg.org/pf-kernel/linux/archive/v${PFPV}.tar.gz -> linux-${PFPV}.tar.gz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${SHPV}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${SHPV}-${K_GENPATCHES_VER}.extras.tar.xz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PFPV}"
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_unpack() {
+ # Since the Codeberg-hosted pf-sources include full kernel sources, we need to manually override
+ # the src_unpack phase because kernel-2_src_unpack() does a lot of unwanted magic here.
+ unpack ${A}
+
+ mv linux linux-${PFPV} || die "Failed to move source directory"
+}
+
+src_prepare() {
+ # When genpatches basic version is bumped, it also includes vanilla linux updates. Those are
+ # already in the -pf patch set, so need to remove the vanilla linux patches to avoid conflicts.
+ if [[ ${K_GENPATCHES_VER} -ne 1 ]]; then
+ find "${WORKDIR}"/ -type f -name '10*linux*patch' -delete ||
+ die "Failed to delete vanilla linux patches in src_prepare."
+ fi
+
+ # kernel-2_src_prepare doesn't apply PATCHES(). Chosen genpatches are also applied here.
+ eapply "${WORKDIR}"/*.patch
+ default
+}
+
+pkg_postinst() {
+ # Fixes "wrongly" detected directory name, bgo#862534.
+ local KV_FULL="${PFPV}"
+ kernel-2_pkg_postinst
+
+ optfeature "userspace KSM helper" sys-process/uksmd
+}
+
+pkg_postrm() {
+ # Same here, bgo#862534.
+ local KV_FULL="${PFPV}"
+ kernel-2_pkg_postrm
+}