summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2020-02-21 21:49:56 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2020-02-21 21:51:33 +0100
commit52134ff8a716a497337a1c4ea6903a977f771fc1 (patch)
tree3b21b8f9adcdc02dc08354aa10a8d336a75686c1
parentpackage.mask: Last rite dev-python/sphinxcontrib-issuetracker (diff)
downloadgentoo-52134ff8a716a497337a1c4ea6903a977f771fc1.tar.gz
gentoo-52134ff8a716a497337a1c4ea6903a977f771fc1.tar.bz2
gentoo-52134ff8a716a497337a1c4ea6903a977f771fc1.zip
net-misc/axel: 2.17.7 bump; EAPI bump; added myself to maintainers.
Closes: https://bugs.gentoo.org/674840 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
-rw-r--r--net-misc/axel/Manifest1
-rw-r--r--net-misc/axel/axel-2.17.7.ebuild49
-rw-r--r--net-misc/axel/axel-9999.ebuild4
-rw-r--r--net-misc/axel/metadata.xml4
4 files changed, 56 insertions, 2 deletions
diff --git a/net-misc/axel/Manifest b/net-misc/axel/Manifest
index 6fbd238d98e1..a76a15664a93 100644
--- a/net-misc/axel/Manifest
+++ b/net-misc/axel/Manifest
@@ -1,4 +1,5 @@
DIST axel-2.12.tar.gz 82995 BLAKE2B da6e00cb577ffd9ab55c3b5b4362f0bdbc08ae89572a7cc224c092710da7911d2c974f52240fd4d2e16ce1d7657a68b5917d866120fb092b85736f181887adac SHA512 5e163c319366f7efd16f8b35dbcf901300c884ab303696dabe87ad47511f56cc3f1e399af738dc79ca717ca70fd529b6dd1adf30f5162cfb530105ce34e2eaf2
DIST axel-2.14.1.tar.gz 89356 BLAKE2B 43e278f09304ed9f872c9348fb2113758a046819c6c8667bd6bff65824a8a55c3d0ac647027947f76b9c4f334495284f30066fa3bd60bc0eaab4f4b5b5059620 SHA512 72c37fc6def0c765ed8220c27efe22255073b1e3cf1c8f6bda5ee2ce9cd36ac46263ac602a185efd40ca8f197a268612f2dcda69bcb49891c2538b910d971e8b
DIST axel-2.15.tar.gz 96474 BLAKE2B 73b35b0c234bf2c21b5c6038979061c908de7520d923ecf6d84d7d6cee348c3e17b8f8d3771909ed74cf20899e3d8ece2cba44764ce625755e0ff44563c0fc43 SHA512 b0a516850b56b74fe763df3320b98e47f9977dda208cff9a98a87bdc63e37f5e0fd31d30c240a375f9d992320674983ced8201ee631187149e62b42804c48eb6
+DIST axel-2.17.7.tar.xz 202632 BLAKE2B 2d799ad39c0742e2edfa09dd19f9d941c54c6136f4d5ec5a95f85d338bdebcc79545205cd1dde6ef25d28c89f494ae3cc278c73e375c9f4a96dabff73b139257 SHA512 ed1815199a7cc78897a820e1938a80dba72b83e1b40e6c1e81c6d3457aaa17faf20148a82383768524d61bbabda5b00cdcb2c15ff8ae5ed74e415da0b53be3aa
DIST axel-2.4.tar.bz2 44995 BLAKE2B 03218c6243029695deae1a2d96b4e0cce719cf23602faf2d2fb4422f06ae313f5a1ed6759e7bc59a1ce756a732873ca5faed636742b608b6a66240b694b7189a SHA512 34d73cea19f2bf393aa8d3e4b6c24296f8b1d4e6177da6f4728763e013d5d9d073aa5dae31d0ff175126e8fcbd973daf94674a70f100afc9e7d00b92b78b8ec9
diff --git a/net-misc/axel/axel-2.17.7.ebuild b/net-misc/axel/axel-2.17.7.ebuild
new file mode 100644
index 000000000000..40d3c5aa103b
--- /dev/null
+++ b/net-misc/axel/axel-2.17.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Light Unix download accelerator"
+HOMEPAGE="https://github.com/axel-download-accelerator/axel"
+SRC_URI="https://github.com/axel-download-accelerator/axel/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris"
+IUSE="debug libressl nls ssl"
+
+CDEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+DEPEND="${CDEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${CDEPEND}
+ nls? ( virtual/libintl virtual/libiconv )"
+
+DOCS=( doc/. )
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with ssl)
+}
+
+pkg_postinst() {
+ einfo 'To use axel with portage, create a script in'
+ einfo '/usr/local/bin/fetchwrapper.sh with the following content:'
+ einfo
+ einfo ' #!/bin/bash'
+ einfo ' set -e'
+ einfo ' /usr/bin/axel -o "$1.axel" "$2"'
+ einfo ' mv "$1.axel" "$1"'
+ einfo
+ einfo 'and then add the following to your make.conf:'
+ einfo ' FETCHCOMMAND='\''/usr/local/bin/fetchwrapper.sh "\${DISTDIR}/\${FILE}" "\${URI}"'\'
+ einfo ' RESUMECOMMAND="${FETCHCOMMAND}"'
+}
+
diff --git a/net-misc/axel/axel-9999.ebuild b/net-misc/axel/axel-9999.ebuild
index 2788479a5801..aeeaf251d69f 100644
--- a/net-misc/axel/axel-9999.ebuild
+++ b/net-misc/axel/axel-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools git-r3
diff --git a/net-misc/axel/metadata.xml b/net-misc/axel/metadata.xml
index 2a0e2be810bd..0b08d51dbfed 100644
--- a/net-misc/axel/metadata.xml
+++ b/net-misc/axel/metadata.xml
@@ -2,6 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
+ <email>slashbeast@gentoo.org</email>
+ <name>Piotr Karbowski</name>
+ </maintainer>
+ <maintainer type="person">
<email>jlec@gentoo.org</email>
</maintainer>
<upstream>