summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-02-04 11:17:10 -0800
committerMatt Turner <mattst88@gentoo.org>2019-02-04 11:18:28 -0800
commit5256ebb8e047b1afbfb6e7e5646f6bd753d1ff1e (patch)
tree0ab2a7c05aa619cdb9c2ce92370aab14a9d15c50
parentmedia-libs/mesa: Require libdrm-2.4.97 (diff)
downloadgentoo-5256ebb8e047b1afbfb6e7e5646f6bd753d1ff1e.tar.gz
gentoo-5256ebb8e047b1afbfb6e7e5646f6bd753d1ff1e.tar.bz2
gentoo-5256ebb8e047b1afbfb6e7e5646f6bd753d1ff1e.zip
media-libs/mesa: Drop support for llvm < 7
radv and radeonsi require llvm-7 and are the main consumers. Allowing older versions would complicate the DEPEND for very little gain. Closes: https://bugs.gentoo.org/677096 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/mesa/mesa-19.0.0_rc1.ebuild4
-rw-r--r--media-libs/mesa/mesa-9999.ebuild4
2 files changed, 0 insertions, 8 deletions
diff --git a/media-libs/mesa/mesa-19.0.0_rc1.ebuild b/media-libs/mesa/mesa-19.0.0_rc1.ebuild
index b1742f927cd..dd35b9d8a13 100644
--- a/media-libs/mesa/mesa-19.0.0_rc1.ebuild
+++ b/media-libs/mesa/mesa-19.0.0_rc1.ebuild
@@ -138,10 +138,6 @@ LLVM_MAX_SLOT="7"
LLVM_DEPSTR="
|| (
sys-devel/llvm:7[${MULTILIB_USEDEP}]
- sys-devel/llvm:6[${MULTILIB_USEDEP}]
- sys-devel/llvm:5[${MULTILIB_USEDEP}]
- sys-devel/llvm:4[${MULTILIB_USEDEP}]
- >=sys-devel/llvm-3.9.0:0[${MULTILIB_USEDEP}]
)
sys-devel/llvm:=[${MULTILIB_USEDEP}]
"
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 9f2e8be0d2e..919f2e68bb2 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -138,10 +138,6 @@ LLVM_DEPSTR="
|| (
sys-devel/llvm:8[${MULTILIB_USEDEP}]
sys-devel/llvm:7[${MULTILIB_USEDEP}]
- sys-devel/llvm:6[${MULTILIB_USEDEP}]
- sys-devel/llvm:5[${MULTILIB_USEDEP}]
- sys-devel/llvm:4[${MULTILIB_USEDEP}]
- >=sys-devel/llvm-3.9.0:0[${MULTILIB_USEDEP}]
)
sys-devel/llvm:=[${MULTILIB_USEDEP}]
"