summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2022-01-16 10:33:37 +0100
committerFabian Groffen <grobian@gentoo.org>2022-01-16 10:33:37 +0100
commit538e155ff09754d737e20142b6519fb7b25c22d4 (patch)
tree5335f9ebb79bd6fab7e9075465d272a7fd911bfe
parentdev-util/colm-0.14.7-r1: re-add Prefix keywords (diff)
downloadgentoo-538e155ff09754d737e20142b6519fb7b25c22d4.tar.gz
gentoo-538e155ff09754d737e20142b6519fb7b25c22d4.tar.bz2
gentoo-538e155ff09754d737e20142b6519fb7b25c22d4.zip
dev-vcs/git: fix osxkeychain conditional, thanks Arfrever
Closes: https://bugs.gentoo.org/831276 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--dev-vcs/git/git-2.32.0-r1.ebuild4
-rw-r--r--dev-vcs/git/git-2.33.1.ebuild4
-rw-r--r--dev-vcs/git/git-2.34.1-r1.ebuild4
-rw-r--r--dev-vcs/git/git-2.34.1.ebuild4
-rw-r--r--dev-vcs/git/git-2.35.0_rc1.ebuild4
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild4
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild4
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild4
-rw-r--r--dev-vcs/git/git-9999.ebuild4
9 files changed, 18 insertions, 18 deletions
diff --git a/dev-vcs/git/git-2.32.0-r1.ebuild b/dev-vcs/git/git-2.32.0-r1.ebuild
index 6c3d422fd38b..c2d24bdf91ed 100644
--- a/dev-vcs/git/git-2.32.0-r1.ebuild
+++ b/dev-vcs/git/git-2.32.0-r1.ebuild
@@ -315,7 +315,7 @@ src_compile() {
git_emake gitweb || die "emake gitweb (cgi) failed"
fi
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
pushd contrib/credential/osxkeychain &>/dev/null || die
git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
|| die "emake credential-osxkeychain"
@@ -362,7 +362,7 @@ src_compile() {
src_install() {
git_emake DESTDIR="${D}" install || die "make install failed"
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
fi
diff --git a/dev-vcs/git/git-2.33.1.ebuild b/dev-vcs/git/git-2.33.1.ebuild
index 26673133f9f9..ab8a8a02552e 100644
--- a/dev-vcs/git/git-2.33.1.ebuild
+++ b/dev-vcs/git/git-2.33.1.ebuild
@@ -311,7 +311,7 @@ src_compile() {
git_emake gitweb || die "emake gitweb (cgi) failed"
fi
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
pushd contrib/credential/osxkeychain &>/dev/null || die
git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
|| die "emake credential-osxkeychain"
@@ -358,7 +358,7 @@ src_compile() {
src_install() {
git_emake DESTDIR="${D}" install || die "make install failed"
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
fi
diff --git a/dev-vcs/git/git-2.34.1-r1.ebuild b/dev-vcs/git/git-2.34.1-r1.ebuild
index c77551019c67..075208f7ce0d 100644
--- a/dev-vcs/git/git-2.34.1-r1.ebuild
+++ b/dev-vcs/git/git-2.34.1-r1.ebuild
@@ -311,7 +311,7 @@ src_compile() {
git_emake gitweb || die "emake gitweb (cgi) failed"
fi
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
pushd contrib/credential/osxkeychain &>/dev/null || die
git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
|| die "emake credential-osxkeychain"
@@ -358,7 +358,7 @@ src_compile() {
src_install() {
git_emake DESTDIR="${D}" install || die "make install failed"
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
fi
diff --git a/dev-vcs/git/git-2.34.1.ebuild b/dev-vcs/git/git-2.34.1.ebuild
index 30f56796419f..99934132cd97 100644
--- a/dev-vcs/git/git-2.34.1.ebuild
+++ b/dev-vcs/git/git-2.34.1.ebuild
@@ -311,7 +311,7 @@ src_compile() {
git_emake gitweb || die "emake gitweb (cgi) failed"
fi
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
pushd contrib/credential/osxkeychain &>/dev/null || die
git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
|| die "emake credential-osxkeychain"
@@ -358,7 +358,7 @@ src_compile() {
src_install() {
git_emake DESTDIR="${D}" install || die "make install failed"
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
fi
diff --git a/dev-vcs/git/git-2.35.0_rc1.ebuild b/dev-vcs/git/git-2.35.0_rc1.ebuild
index c77551019c67..075208f7ce0d 100644
--- a/dev-vcs/git/git-2.35.0_rc1.ebuild
+++ b/dev-vcs/git/git-2.35.0_rc1.ebuild
@@ -311,7 +311,7 @@ src_compile() {
git_emake gitweb || die "emake gitweb (cgi) failed"
fi
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
pushd contrib/credential/osxkeychain &>/dev/null || die
git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
|| die "emake credential-osxkeychain"
@@ -358,7 +358,7 @@ src_compile() {
src_install() {
git_emake DESTDIR="${D}" install || die "make install failed"
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
fi
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index c77551019c67..075208f7ce0d 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -311,7 +311,7 @@ src_compile() {
git_emake gitweb || die "emake gitweb (cgi) failed"
fi
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
pushd contrib/credential/osxkeychain &>/dev/null || die
git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
|| die "emake credential-osxkeychain"
@@ -358,7 +358,7 @@ src_compile() {
src_install() {
git_emake DESTDIR="${D}" install || die "make install failed"
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
fi
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index c77551019c67..075208f7ce0d 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -311,7 +311,7 @@ src_compile() {
git_emake gitweb || die "emake gitweb (cgi) failed"
fi
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
pushd contrib/credential/osxkeychain &>/dev/null || die
git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
|| die "emake credential-osxkeychain"
@@ -358,7 +358,7 @@ src_compile() {
src_install() {
git_emake DESTDIR="${D}" install || die "make install failed"
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
fi
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index c77551019c67..075208f7ce0d 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -311,7 +311,7 @@ src_compile() {
git_emake gitweb || die "emake gitweb (cgi) failed"
fi
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
pushd contrib/credential/osxkeychain &>/dev/null || die
git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
|| die "emake credential-osxkeychain"
@@ -358,7 +358,7 @@ src_compile() {
src_install() {
git_emake DESTDIR="${D}" install || die "make install failed"
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
fi
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index c77551019c67..075208f7ce0d 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -311,7 +311,7 @@ src_compile() {
git_emake gitweb || die "emake gitweb (cgi) failed"
fi
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
pushd contrib/credential/osxkeychain &>/dev/null || die
git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
|| die "emake credential-osxkeychain"
@@ -358,7 +358,7 @@ src_compile() {
src_install() {
git_emake DESTDIR="${D}" install || die "make install failed"
- if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
+ if [[ ${CHOST} == *-darwin* ]] && tc-is-clang ; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
fi