summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-07-29 21:08:15 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2021-07-29 21:08:27 +0200
commit538fc55735dfc94cd16108b7600b6683f9cad84b (patch)
tree2b07bde91a4474a9bc13c01fc55bfbd07d213258
parentnet-mail/fetchmail: drop old (diff)
downloadgentoo-538fc55735dfc94cd16108b7600b6683f9cad84b.tar.gz
gentoo-538fc55735dfc94cd16108b7600b6683f9cad84b.tar.bz2
gentoo-538fc55735dfc94cd16108b7600b6683f9cad84b.zip
net-mail/fetchmail: 6.4.20 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--net-mail/fetchmail/Manifest1
-rw-r--r--net-mail/fetchmail/fetchmail-6.4.20.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/net-mail/fetchmail/Manifest b/net-mail/fetchmail/Manifest
index f7e70bd4bcfd..75539071b65d 100644
--- a/net-mail/fetchmail/Manifest
+++ b/net-mail/fetchmail/Manifest
@@ -1,2 +1,3 @@
DIST fetchmail-6.4.19.tar.xz 1316672 BLAKE2B 679d2c49698dd368d32439a8276412e3f32c0a0f6f0e7607bc323c0294c987307469451b4b085fe521f2d5dd4869d59b4841762b6a57b3c654b992e9de8ba87c SHA512 b10f0ac5b3b22f8b1d86367990fc96ea5c49dc21c873890c732c254c34503bd6ab9348c5ef88b99ba0f83f065fa9f9aead55de9721b0f296efa14eac0311daaf
+DIST fetchmail-6.4.20.tar.xz 1317204 BLAKE2B 85137bdae2fda05cba6e9bee9056bb9a1ef09b96199dc5f991da9aa5c2073f1c8cbf3fae43999a79de338a95e9d28e474035200758b65ffa9fa18b5a905c1279 SHA512 5b170f51a74b6596020282f5cbb34bf0a9ea8c5b089fd8c6c72df6c7742e16bcd5931d62181d56265779f9c3431c4ddf795a03deee09c5552a3aa0601282bd17
DIST fetchmail-7.0.0-alpha8.tar.xz 1212256 BLAKE2B 1b123921a696e60b9c42ea30a379bc6cf46bb66dd630f50e1f10ceac5066932da9538295954be451c4665e1186b7281523bbae83fb4cdb7ad2d1b7b408a3a38f SHA512 fdb20b6a4723f718958e8c800d5a996ff0bb8d9ffe485e8f8429f28953a5a691fd8439c29cb4fbbae338d64c1e9cd1f5f9ed6d89261d0ca582f6345cacb696fe
diff --git a/net-mail/fetchmail/fetchmail-6.4.20.ebuild b/net-mail/fetchmail/fetchmail-6.4.20.ebuild
new file mode 100644
index 000000000000..9a15f59666e2
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.4.20.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_REQ_USE="tk"
+
+inherit autotools python-single-r1 systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="https://www.fetchmail.info/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ssl nls kerberos tk socks"
+REQUIRED_USE="tk? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="acct-user/fetchmail
+ ssl? (
+ >=dev-libs/openssl-1.1.1:=
+ )
+ kerberos? (
+ virtual/krb5
+ >=dev-libs/openssl-1.0.2:=
+ )
+ nls? ( virtual/libintl )
+ !elibc_glibc? ( sys-libs/e2fsprogs-libs )
+ socks? ( net-proxy/dante )
+ tk? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_USEDEP}]
+ ')
+ )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+DOCS="FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO"
+HTML_DOCS="*.html"
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.3.26-python-optional.patch
+)
+S=${WORKDIR}/${P/_/.}
+
+pkg_setup() {
+ use tk && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ # don't compile during src_install
+ use tk && : > "${S}"/py-compile
+ eautoreconf
+}
+
+src_configure() {
+ use tk || export PYTHON=:
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with ssl ssl "${EPREFIX}/usr") \
+ $(use kerberos && echo "--with-ssl=${EPREFIX}/usr") \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ --without-hesiod \
+ $(use_with socks)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/fetchmail.initd fetchmail
+ newconfd "${FILESDIR}"/fetchmail.confd fetchmail
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_newunit "${FILESDIR}"/${PN}_at.service "${PN}@.service"
+ dotmpfiles "${FILESDIR}"/${PN}.conf
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+
+ use tk && python_optimize
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+ fi
+}