summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-06-13 12:01:50 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-06-14 10:59:21 -0400
commit53db1425bce36548ea3e530367e5bff21da18537 (patch)
tree0b6e881fb6de137a874bd15a0dc74c8d257dca30
parentapp-crypt/keybase: Version bump (diff)
downloadgentoo-53db1425bce36548ea3e530367e5bff21da18537.tar.gz
gentoo-53db1425bce36548ea3e530367e5bff21da18537.tar.bz2
gentoo-53db1425bce36548ea3e530367e5bff21da18537.zip
games-engines/scummvm: version bump
Package-Manager: portage-2.2.28
-rw-r--r--games-engines/scummvm/Manifest1
-rw-r--r--games-engines/scummvm/scummvm-1.8.1.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/games-engines/scummvm/Manifest b/games-engines/scummvm/Manifest
index e334089cc4f3..5fea61a60c0a 100644
--- a/games-engines/scummvm/Manifest
+++ b/games-engines/scummvm/Manifest
@@ -1,2 +1,3 @@
DIST scummvm-1.7.0.tar.bz2 20018016 SHA256 d9ff0e8cf911afa466d5456d28fef692a17d47ddecfd428bf2fef591237c2e66 SHA512 0133feb2df58461fb0e42b1e84cfb309bd964dad239f7ca0c7529edd4f4716895a45491e31597ec6f6d17361b0ce8f73c317399db07a1249b2ab570e4829000e WHIRLPOOL 077eb74cf46dfb15eaa2d473b627d953bc8e13bd0ae87a4fdc16282e468cf237bd9173b761cc9f89b9d6a13ce76db40aa67d5092e2e77eba2a0c6dab097b0fb4
DIST scummvm-1.8.0.tar.xz 17385064 SHA256 a85c23a2b1fcb7586a7527ecdbdf6c899a45ecbdcba28b9322057dc27914daa8 SHA512 2fb25467854d6115cf09fd40536728e2c1943c16d8bcb29ebbc3c37fa5dc750a72258e0b0dac6244e5ddcc5f2dfc69af3d7fdff83c98a92a546f8669daa8da27 WHIRLPOOL 55202291d09c86b250dc0ee24fdd3b34dd54924c4b5bb9889d6f2ef84f06db3caebc6bb36a9c1a9ccddd93cfdfaf5feac4982b4b0dc74305819af75031a68524
+DIST scummvm-1.8.1.tar.xz 17807468 SHA256 935f53d7e4c460fbc22c58fee5007d4858891e4961831f53f575a3594b7f612a SHA512 e67ee332668b14432dcd675051384bd4fee2c1a0ddf44f6f8aeaf889d5027a834187e2632d18959583fa258cf03f259a54fd2d88120fa62ef7496232b4e6bdb4 WHIRLPOOL 597e6f4f21c4b80720a86d1f55518ba834d814ea9b9de365e19bdd070b0c8a81ce451d63169597bd54eb6e86876b5506a9f361d8c649c689dce304597b9390af
diff --git a/games-engines/scummvm/scummvm-1.8.1.ebuild b/games-engines/scummvm/scummvm-1.8.1.ebuild
new file mode 100644
index 000000000000..6aff6122f85c
--- /dev/null
+++ b/games-engines/scummvm/scummvm-1.8.1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic gnome2-utils toolchain-funcs games
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="http://scummvm.org/frs/scummvm/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2.1 BSD GPL-3-with-font-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="aac alsa debug flac fluidsynth jpeg mpeg2 mp3 opengl png theora truetype unsupported vorbis zlib"
+RESTRICT="test" # it only looks like there's a test there #77507
+
+RDEPEND=">=media-libs/libsdl-1.2.2[sound,joystick,video]
+ zlib? ( sys-libs/zlib )
+ jpeg? ( virtual/jpeg:0 )
+ png? ( media-libs/libpng:0 )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ theora? ( media-libs/libtheora )
+ aac? ( media-libs/faad2 )
+ alsa? ( media-libs/alsa-lib )
+ mp3? ( media-libs/libmad )
+ mpeg2? ( media-libs/libmpeg2 )
+ flac? ( media-libs/flac )
+ opengl? ( virtual/opengl )
+ truetype? ( media-libs/freetype:2 )
+ fluidsynth? ( media-sound/fluidsynth )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ x86? ( dev-lang/nasm )"
+
+S=${WORKDIR}/${P/_/}
+
+src_prepare() {
+ # -g isn't needed for nasm here
+ sed -i \
+ -e '/NASMFLAGS/ s/-g//' \
+ configure || die
+ sed -i \
+ -e '/INSTALL.*doc/d' \
+ -e '/INSTALL.*\/pixmaps/d' \
+ -e 's/-s //' \
+ ports.mk || die
+}
+
+src_configure() {
+ local myconf
+
+ # bug #137547
+ use fluidsynth || myconf="${myconf} --disable-fluidsynth"
+
+ use x86 && append-ldflags -Wl,-z,noexecstack
+
+ # NOT AN AUTOCONF SCRIPT SO DONT CALL ECONF
+ ./configure \
+ --backend=sdl \
+ --host=$CHOST \
+ --enable-verbose-build \
+ --prefix=/usr \
+ --bindir="${GAMES_BINDIR}" \
+ --datadir="${GAMES_DATADIR}"/${PN} \
+ --libdir="${GAMES_LIBDIR}" \
+ --enable-zlib \
+ $(use_enable debug) \
+ $(use_enable !debug release-mode) \
+ $(use_enable zlib) \
+ $(use_enable aac faad) \
+ $(use_enable alsa) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable mp3 mad) \
+ $(use_enable mpeg2) \
+ $(use_enable flac) \
+ $(use_enable opengl) \
+ $(use_enable vorbis) \
+ $(use_enable theora theoradec) \
+ $(use_enable truetype freetype2) \
+ $(use_enable x86 nasm) \
+ $(use unsupported && echo --enable-all-engines) \
+ ${myconf} ${EXTRA_ECONF} || die
+}
+
+src_compile() {
+ emake AR="$(tc-getAR) cru" RANLIB=$(tc-getRANLIB)
+}
+
+src_install() {
+ default
+ doicon -s scalable icons/scummvm.svg
+ make_desktop_entry scummvm ScummVM scummvm "Game;AdventureGame"
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}