summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-07 09:54:58 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-07 11:33:41 +0200
commit540ea4bfb7a67552198e56170e0fbcaca5f89d26 (patch)
treeee9f5b3d54b39f729da690601bc8238947a110d7
parentdev-python/dns-lexicon: Remove old (diff)
downloadgentoo-540ea4bfb7a67552198e56170e0fbcaca5f89d26.tar.gz
gentoo-540ea4bfb7a67552198e56170e0fbcaca5f89d26.tar.bz2
gentoo-540ea4bfb7a67552198e56170e0fbcaca5f89d26.zip
dev-python/dns-lexicon: Bump to 3.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dns-lexicon/Manifest1
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.11.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/dns-lexicon/Manifest b/dev-python/dns-lexicon/Manifest
index aed724407025..9b6e0de76263 100644
--- a/dev-python/dns-lexicon/Manifest
+++ b/dev-python/dns-lexicon/Manifest
@@ -1 +1,2 @@
DIST dns-lexicon-3.10.0.tar.gz 8394918 BLAKE2B 26e7b7f95b1daf5cd66536993f350301574765f4568a9b3dda4d5e555a3a1ca6a329566f8f5a57ae209d26dd092c851ab524df0488b6ca4f81cdc94011458d88 SHA512 76ede1b55ad388b8d6726d531a4346db5972e79c434db529fa54838b0f40c909cb67a544f3e74e67311c981b8acd4766ec51c67452143989daa9be39176f940a
+DIST dns-lexicon-3.11.0.tar.gz 8467979 BLAKE2B f0ee1b5977d373ad911d71283f64a946269e725616c40f93b9160cccae8c5993f5bd6fa0c5b0616fbde4e91e06be846f1df020c03d19f37b73d59145f06530f5 SHA512 dcf231908ca2869c0e729b114632ce9f53c7b8d524ea072533403e2f8428d8fda9763a4c73e822a2034abd78f46897009127e9e653fb71e0bc712a72a80da075
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.11.0.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.11.0.ebuild
new file mode 100644
index 000000000000..bd75f1201713
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.11.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="https://pypi.org/project/dns-lexicon/"
+SRC_URI="
+ https://github.com/AnalogJ/lexicon/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/lexicon-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ lexicon/tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ lexicon/tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ lexicon/tests/providers/test_transip.py
+ # Requires the "oci" module
+ lexicon/tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ lexicon/tests/providers/test_auto.py
+ # All recordings seem to be broken
+ lexicon/tests/providers/test_namecheap.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}