summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-07 03:19:11 +0000
committerSam James <sam@gentoo.org>2021-01-07 03:19:11 +0000
commit5458af5f9efaca5a968acbdc71dddfe240da70d4 (patch)
treeb5f0babdbe8a1b231e78a548fa881020458cc797
parentnet-misc/socat: add extra HOMEPAGE (diff)
downloadgentoo-5458af5f9efaca5a968acbdc71dddfe240da70d4.tar.gz
gentoo-5458af5f9efaca5a968acbdc71dddfe240da70d4.tar.bz2
gentoo-5458af5f9efaca5a968acbdc71dddfe240da70d4.zip
net-misc/socat: unify style
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/socat/socat-1.7.3.4.ebuild19
-rw-r--r--net-misc/socat/socat-2.0.0_beta9.ebuild18
2 files changed, 22 insertions, 15 deletions
diff --git a/net-misc/socat/socat-1.7.3.4.ebuild b/net-misc/socat/socat-1.7.3.4.ebuild
index ea696ac13e65..3eba54db2ef8 100644
--- a/net-misc/socat/socat-1.7.3.4.ebuild
+++ b/net-misc/socat/socat-1.7.3.4.ebuild
@@ -2,13 +2,14 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit flag-o-matic toolchain-funcs
+MY_P=${P/_beta/-b}
DESCRIPTION="Multipurpose relay (SOcket CAT)"
HOMEPAGE="http://www.dest-unreach.org/socat/ https://repo.or.cz/socat.git"
-MY_P=${P/_beta/-b}
-S="${WORKDIR}/${MY_P}"
SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
@@ -23,16 +24,17 @@ DEPEND="
readline? ( sys-libs/readline:= )
tcpd? ( sys-apps/tcp-wrappers )
"
-RDEPEND="
- ${DEPEND}
-"
+RDEPEND="${DEPEND}"
+
+# Tests are a large bash script
+# Hard to disable individual tests needing network or privileges
RESTRICT="
test
ssl? ( readline? ( bindist ) )
"
-DOCS=(
- BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY
-)
+
+DOCS=( BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY )
+
PATCHES=(
"${FILESDIR}"/${PN}-1.7.3.4-fno-common.patch
)
@@ -49,6 +51,7 @@ pkg_setup() {
src_configure() {
filter-flags '-Wno-error*' #293324
tc-export AR
+
econf \
$(use_enable ssl openssl) \
$(use_enable readline) \
diff --git a/net-misc/socat/socat-2.0.0_beta9.ebuild b/net-misc/socat/socat-2.0.0_beta9.ebuild
index 3745b7704e20..0f00e1445827 100644
--- a/net-misc/socat/socat-2.0.0_beta9.ebuild
+++ b/net-misc/socat/socat-2.0.0_beta9.ebuild
@@ -2,13 +2,14 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools flag-o-matic toolchain-funcs
+MY_P=${P/_beta/-b}
DESCRIPTION="Multipurpose relay (SOcket CAT)"
HOMEPAGE="http://www.dest-unreach.org/socat/ https://repo.or.cz/socat.git"
-MY_P=${P/_beta/-b}
-S="${WORKDIR}/${MY_P}"
SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
@@ -25,12 +26,14 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-RESTRICT="test
- ssl? ( readline? ( bindist ) )"
+# Tests are a large bash script
+# Hard to disable individual tests needing network or privileges
+RESTRICT="
+ test
+ ssl? ( readline? ( bindist ) )
+"
-DOCS=(
- BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY
-)
+DOCS=( BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY )
PATCHES=(
"${FILESDIR}"/${PN}-1.7.3.0-filan-build.patch
@@ -59,6 +62,7 @@ src_prepare() {
src_configure() {
filter-flags -Wall '-Wno-error*' #293324
tc-export AR
+
econf \
$(use_enable ssl openssl) \
$(use_enable readline) \