summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-07-06 03:08:07 -0600
committerTim Harder <radhermit@gentoo.org>2019-07-06 03:13:18 -0600
commit55022e896471a4566be12f44387b9caf90422364 (patch)
tree4227e9140cd91b69411dc95de50d7e667bac2a70
parentnet-analyzer/barnyard2: Add USE=sguil, drop USE=static (diff)
downloadgentoo-55022e896471a4566be12f44387b9caf90422364.tar.gz
gentoo-55022e896471a4566be12f44387b9caf90422364.tar.bz2
gentoo-55022e896471a4566be12f44387b9caf90422364.zip
net-mail/mpop: version bump to 1.4.4
Closes: https://bugs.gentoo.org/682530 Signed-off-by: Tim Harder <radhermit@gentoo.org>
-rw-r--r--net-mail/mpop/Manifest1
-rw-r--r--net-mail/mpop/mpop-1.4.4.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/net-mail/mpop/Manifest b/net-mail/mpop/Manifest
index 8758b93201b8..a5b064646edb 100644
--- a/net-mail/mpop/Manifest
+++ b/net-mail/mpop/Manifest
@@ -1,2 +1,3 @@
DIST mpop-1.2.8.tar.xz 272632 BLAKE2B aebea78c44103284929d7819e00377c8d64d0de1c7cd877e8d63ea4e3481ccf05d9d27ec5b5f7433bf723bdd421a7fe8ed54a2e44ede9dbb3a6447a98e5596cd SHA512 34039d6a4b3b316679cb646ed0db6b0a11f47554576e9aad35402388718c3c7787e3854c144cec921cab0aea22e0484a1f71c2283bc1d0a37e6e69a0f6530602
DIST mpop-1.4.1.tar.xz 296968 BLAKE2B 89304b7c63882dd394ff6797d87ceca1aa8af3efa4198fc0adeeba5b5704b57459ee466319f59657d65dfac2a3b8531a4515e51391e7f5030008589e689a0a92 SHA512 66b2ad8fab2d4a8262eb3689b094ac19cc961ef9fd5fd51c2c72b14c9f759194b906d2450b7c6cbeddb78e871198a2be8b336bc1fc7d6990a2b8b9d66068a2e5
+DIST mpop-1.4.4.tar.xz 319372 BLAKE2B acf5bdb62479126ae212bb008878872d16efba1eb9a077bf4697ba22ff512977fcd5affad090bc952fb01cf07a607a4dce91b873128c43f087c34dca6d6bae81 SHA512 1ed89108d35d7bbd6bcbd6de956f51cfcfaefd808f6aa7135b168d789f8cbe7070be9db676d1222dce5b6fe8b6692616d6b7adec9c23df11ac3de112897924da
diff --git a/net-mail/mpop/mpop-1.4.4.ebuild b/net-mail/mpop/mpop-1.4.4.ebuild
new file mode 100644
index 000000000000..df58c65aef22
--- /dev/null
+++ b/net-mail/mpop/mpop-1.4.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A small, fast, and portable POP3 client"
+HOMEPAGE="https://marlam.de/mpop/"
+SRC_URI="https://marlam.de/mpop/releases/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gnutls idn libressl gnome-keyring nls sasl ssl vim-syntax"
+
+RDEPEND="
+ idn? ( net-dns/libidn2 )
+ gnome-keyring? ( app-crypt/libsecret )
+ nls? ( virtual/libintl )
+ sasl? ( virtual/gsasl )
+ ssl? (
+ gnutls? ( net-libs/gnutls:0=[idn?] )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+REQUIRED_USE="gnutls? ( ssl )"
+
+DOCS="AUTHORS ChangeLog NEWS NOTES README THANKS"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with ssl tls $(usex gnutls "gnutls" "openssl")) \
+ $(use_with sasl libgsasl) \
+ $(use_with idn libidn) \
+ $(use_with gnome-keyring libsecret)
+}
+
+src_install() {
+ default
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins scripts/vim/mpop.vim
+ fi
+}