summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-15 08:08:38 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-15 08:12:22 +0300
commit55752d04af0e514d9dd0416ea6e2bb6df1708ebf (patch)
treeb6d2458385dd1490fd89f78286e2c9c5f633f4f1
parentdev-python/pytest-toolbox: initial import (diff)
downloadgentoo-55752d04af0e514d9dd0416ea6e2bb6df1708ebf.tar.gz
gentoo-55752d04af0e514d9dd0416ea6e2bb6df1708ebf.tar.bz2
gentoo-55752d04af0e514d9dd0416ea6e2bb6df1708ebf.zip
dev-python/pytest-sugar: initial import
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pytest-sugar/Manifest1
-rw-r--r--dev-python/pytest-sugar/metadata.xml13
-rw-r--r--dev-python/pytest-sugar/pytest-sugar-0.9.4.ebuild29
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-sugar/Manifest b/dev-python/pytest-sugar/Manifest
new file mode 100644
index 000000000000..69354e873cf4
--- /dev/null
+++ b/dev-python/pytest-sugar/Manifest
@@ -0,0 +1 @@
+DIST pytest-sugar-0.9.4.tar.gz 12727 BLAKE2B 898692fc4083871d707fad44c7dd0c1298c28c190d705ef4525d4ba68d77bd37bb2634e43795ea553041317dc2f014d9be8ef52cfe40383ee75af36e5780cb98 SHA512 bbe375f0ae934d132457d698c9e09994a9a96a31860397f1b5e50b32139e5018f0137ddc0d3dd84bec29fc2b4c16592f59a38933c53fb8acec714c64689c4c76
diff --git a/dev-python/pytest-sugar/metadata.xml b/dev-python/pytest-sugar/metadata.xml
new file mode 100644
index 000000000000..03f2581dac21
--- /dev/null
+++ b/dev-python/pytest-sugar/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arthurzam@gentoo.org</email>
+ <name>Arthur Zamarin</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">Teemu/pytest-sugar</remote-id>
+ <remote-id type="pypi">pytest-sugar</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-sugar/pytest-sugar-0.9.4.ebuild b/dev-python/pytest-sugar/pytest-sugar-0.9.4.ebuild
new file mode 100644
index 000000000000..8c9c3ebc520e
--- /dev/null
+++ b/dev-python/pytest-sugar/pytest-sugar-0.9.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin that changes the default look and feel of py.test"
+HOMEPAGE="https://github.com/Teemu/pytest-sugar https://pypi.org/project/pytest-sugar/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest