summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-27 12:14:04 +0000
committerSam James <sam@gentoo.org>2022-12-27 12:14:50 +0000
commit55d06687a5a2e82ddf8502d7d36dfa0721849aca (patch)
treeacc972f1a242f9f71a5c25a11105d547886bc8ce
parentapp-emulation/xtrs: drop 4.9d-r5 (diff)
downloadgentoo-55d06687a5a2e82ddf8502d7d36dfa0721849aca.tar.gz
gentoo-55d06687a5a2e82ddf8502d7d36dfa0721849aca.tar.bz2
gentoo-55d06687a5a2e82ddf8502d7d36dfa0721849aca.zip
app-misc/unfoo: adapt to app-alternatives/{bzip2,gzip}
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-misc/unfoo/unfoo-1.0.8-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/unfoo/unfoo-1.0.8-r1.ebuild b/app-misc/unfoo/unfoo-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..14b1f01e3574
--- /dev/null
+++ b/app-misc/unfoo/unfoo-1.0.8-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A simple bash driven frontend to simplify decompression of files"
+HOMEPAGE="http://obsoleet.org/code/unfoo"
+SRC_URI="https://github.com/jlec/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~s390 x86 ~amd64-linux ~x86-linux"
+IUSE="+minimal test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPS="
+ app-alternatives/bzip2
+ app-alternatives/gzip
+ app-arch/p7zip
+ || (
+ app-arch/rar
+ app-arch/unrar
+ )
+ app-arch/unace
+ app-arch/unzip
+ app-arch/xz-utils"
+RDEPEND="!minimal? ( ${COMMON_DEPS} )"
+DEPEND="test? ( ${COMMON_DEPS} )"
+
+src_compile() { :; }
+
+src_install() {
+ dodoc README*
+ dobin ${PN}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ echo
+ elog "unfoo can handle far more than just .tar*, but it requires some"
+ elog "optional packages to do so. For a list, either consult the source"
+ elog "(less /usr/bin/unfoo), or see http://obsoleet.org/code/unfoo"
+ elog "To get full support please use USE=-minimal"
+ fi
+}