summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-06-02 21:53:30 +0200
committerUlrich Müller <ulm@gentoo.org>2018-06-02 22:02:40 +0200
commit56671a0fe3a07439c1b7690a5e6f4b8ab78bffdc (patch)
tree3d8daffee59105b3f1960a4098c4adb39d823119
parentapp-emacs/yasnippet: Remove old. (diff)
downloadgentoo-56671a0fe3a07439c1b7690a5e6f4b8ab78bffdc.tar.gz
gentoo-56671a0fe3a07439c1b7690a5e6f4b8ab78bffdc.tar.bz2
gentoo-56671a0fe3a07439c1b7690a5e6f4b8ab78bffdc.zip
app-emacs/yasnippet: Version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--app-emacs/yasnippet/Manifest1
-rw-r--r--app-emacs/yasnippet/files/50yasnippet-gentoo-0.13.0.el4
-rw-r--r--app-emacs/yasnippet/metadata.xml3
-rw-r--r--app-emacs/yasnippet/yasnippet-0.13.0.ebuild36
4 files changed, 42 insertions, 2 deletions
diff --git a/app-emacs/yasnippet/Manifest b/app-emacs/yasnippet/Manifest
index c29b73a3b3f1..730ee2c486e7 100644
--- a/app-emacs/yasnippet/Manifest
+++ b/app-emacs/yasnippet/Manifest
@@ -1,2 +1,3 @@
+DIST yasnippet-0.13.0.tar.gz 577330 BLAKE2B 21830c0a2e99d7669093c16f527debb4921e96aad006887ec1c7e35da58745721658417f1aec96ea78ba4dc5f3951c857848fce67e6d2ff7f255d4aea5687ab9 SHA512 73b111f72e98c4183764cef08ddfaa861dba49f171f96026b074bf62a7aa5e2d8529f616805ba386dd4157b675da953784d5bcd832d6015ce1b72e9c240988c5
DIST yasnippet-0.6.1c.tar.bz2 47493 BLAKE2B d3bb0d1c343c05f9bc212a0fc114d3c816c02d8de685c55c0f3407a02ee6d1c1e6c24681872dc66e67af773e0e98a78a0366bbfe72ebfd543c5174d2e2f994b0 SHA512 ea4c5850ae80e4db9a188788654a099eddc43e29371ef0cb6367e1a39d3ee9f3e9dab7201178955ae47c92bcecbb5120e0b817e47e9c88c5bcef9e561636a603
DIST yasnippet-doc-0.6.1c.tar.bz2 490738 BLAKE2B e312481c7693094d62eb0aec465412ea1c894ca5132df9c2beba49c3c78daaec90ca80d17fc9404edbdd8cea1fce63804a102cbe9b7d3d7b23f0761b8a0ea552 SHA512 c96955cac11f319107e0ea907c92860049598cbfd47b6a2e3211dc2b030face77b03aa9495d7e9d78171be87083f77268e90c6c86b0cc467a96a5bd724daf8f1
diff --git a/app-emacs/yasnippet/files/50yasnippet-gentoo-0.13.0.el b/app-emacs/yasnippet/files/50yasnippet-gentoo-0.13.0.el
new file mode 100644
index 000000000000..e58ee2b29cf3
--- /dev/null
+++ b/app-emacs/yasnippet/files/50yasnippet-gentoo-0.13.0.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'yas-minor-mode "yasnippet" "Toggle YASnippet mode." t)
+(autoload 'yas-global-mode "yasnippet" nil t)
+(autoload 'snippet-mode "yasnippet" "A mode for editing yasnippets" t)
diff --git a/app-emacs/yasnippet/metadata.xml b/app-emacs/yasnippet/metadata.xml
index 3ae6c22024b9..1f59a55f0dcf 100644
--- a/app-emacs/yasnippet/metadata.xml
+++ b/app-emacs/yasnippet/metadata.xml
@@ -10,7 +10,6 @@
cleaner and more powerful than smart-snippet.
</longdescription>
<upstream>
- <remote-id type="google-code">yasnippet</remote-id>
- <remote-id type="github">capitaomorte/yasnippet</remote-id>
+ <remote-id type="github">joaotavora/yasnippet</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-emacs/yasnippet/yasnippet-0.13.0.ebuild b/app-emacs/yasnippet/yasnippet-0.13.0.ebuild
new file mode 100644
index 000000000000..e6ba47b23dc4
--- /dev/null
+++ b/app-emacs/yasnippet/yasnippet-0.13.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Yet another snippet extension for Emacs"
+HOMEPAGE="http://joaotavora.github.com/yasnippet/"
+SRC_URI="https://github.com/joaotavora/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+SITEFILE="50${PN}-gentoo-${PV}.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l yasnippet-tests \
+ -f ert-run-tests-batch-and-exit
+}
+
+src_install() {
+ elisp-install ${PN} yasnippet.el{,c} yasnippet-debug.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc CONTRIBUTING.md NEWS README.mdown
+ use doc && dodoc -r doc/*
+
+ DOC_CONTENTS="Add the following to your ~/.emacs to use YASnippet:
+ \n\t(require 'yasnippet)
+ \n\t(yas-global-mode 1)
+ \n\nYASnippet no longer bundles snippets directly. Install the package
+ app-emacs/yasnippet-snippets for a collection of snippets."
+ readme.gentoo_create_doc
+}