summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-25 00:18:20 +0000
committerSam James <sam@gentoo.org>2021-10-25 00:36:46 +0000
commit574a1371700e5dbea2d7de65954e56e298f49789 (patch)
tree2e63578983e5f55607c99837501fd06484ad98b7
parentsci-geosciences/qgis: add 3.22.0 (diff)
downloadgentoo-574a1371700e5dbea2d7de65954e56e298f49789.tar.gz
gentoo-574a1371700e5dbea2d7de65954e56e298f49789.tar.bz2
gentoo-574a1371700e5dbea2d7de65954e56e298f49789.zip
sci-libs/geos: add 3.10.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-libs/geos/Manifest1
-rw-r--r--sci-libs/geos/geos-3.10.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sci-libs/geos/Manifest b/sci-libs/geos/Manifest
index 2c13200ecfac..e05d89eaa6b9 100644
--- a/sci-libs/geos/Manifest
+++ b/sci-libs/geos/Manifest
@@ -1,3 +1,4 @@
+DIST geos-3.10.0.tar.bz2 6799370 BLAKE2B dd1490318fccda8ccaf5152f8521ab98ef5e4b143e12e861d02124421985a8b2c966bca6f966aa167fb60f703d25c132b8c7ee4d61e382a449bce5eb40d4cb89 SHA512 12657c6649bfbf6efa3232a054969c6229bb23fc16a7c72d6ca5fdb662e0d08e14bbcaa6944a17de8972b6c236608d94c870ead0b04fada2d2af3d42c238058e
DIST geos-3.8.1.tar.bz2 2505407 BLAKE2B 43053ea9e29d190f41c37d5d382b689ef477e0256cfd5705f4f2f316cac21a1674660bcf0900c51db72909c41d46be7a41d297958de48e108ae6d6bd1ca9d247 SHA512 1d8d8b3ece70eb388ea128f4135c7455899f01828223b23890ad3a2401e27104efce03987676794273a9b9d4907c0add2be381ff14b8420aaa9a858cc5941056
DIST geos-3.9.0-r1.tar.bz2 4710957 BLAKE2B dab0f4e0bfb1bd244c2faf5ee6149b65d142eea78e87490025f90b672eee0d25d4ba9bc4c3b223e78ea0c9d34625b4750c7ba03852e5ea9540ad5c479d84b995 SHA512 1081f2aa20e671450953f7bb53b17c703804a1c9f4987c9da0987ff24339af5811b2c8b79c8e438d04ca38e4d06164dc5a4206f266f7efc19af3f9d9ea8f71f8
DIST geos-3.9.1-r1.tar.bz2 4761372 BLAKE2B af1597d9372b18a2f280d82941949518cd8edb9296e9647aa3949c9e10fdd1b6ef500298471ec469d711ab0569eabd8fc3fb0a8f7e9bd48f91150cfdcaea65a8 SHA512 7ea131685cd110ec5e0cb7c214b52b75397371e75f011e1410b6770b6a48ca492a02337d86a7be35c852ef94604fe9d6f49634c79d4946df611aaa4f5cbaee28
diff --git a/sci-libs/geos/geos-3.10.0.ebuild b/sci-libs/geos/geos-3.10.0.ebuild
new file mode 100644
index 000000000000..28033433e149
--- /dev/null
+++ b/sci-libs/geos/geos-3.10.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="https://trac.osgeo.org/geos/"
+SRC_URI="https://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+
+ # bug #709368
+ $(usex arm '-DDISABLE_GEOS_INLINE=ON' '')
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile docs
+}
+
+src_install() {
+ cmake_src_install
+
+ if use doc ; then
+ HTML_DOCS=( "${BUILD_DIR}"/doc/doxygen_docs/html/. )
+ einstalldocs
+ fi
+}