summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2024-09-27 21:35:42 -0500
committerErik Mackdanz <stasibear@gentoo.org>2024-09-27 21:35:42 -0500
commit57862311248969f2fd7dc61642cfb9fc146f3549 (patch)
treef99c6368c82f93b3866547bd28562e19b2519ecb
parentnet-libs/libupnpp: add 0.26.7 (diff)
downloadgentoo-57862311248969f2fd7dc61642cfb9fc146f3549.tar.gz
gentoo-57862311248969f2fd7dc61642cfb9fc146f3549.tar.bz2
gentoo-57862311248969f2fd7dc61642cfb9fc146f3549.zip
media-sound/upmpdcli: add 1.8.17
Signed-off-by: Erik Mackdanz <stasibear@gentoo.org>
-rw-r--r--media-sound/upmpdcli/Manifest1
-rw-r--r--media-sound/upmpdcli/upmpdcli-1.8.17.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/upmpdcli/Manifest b/media-sound/upmpdcli/Manifest
index 4e904fe4b220..e9c66936f36c 100644
--- a/media-sound/upmpdcli/Manifest
+++ b/media-sound/upmpdcli/Manifest
@@ -1 +1,2 @@
DIST upmpdcli-1.8.11.tar.gz 629053 BLAKE2B 42b8fa8f69bc0feab8dbeee8be48ec120c7c5084da1ddf64902b26845cecf7b50652260f1e56b9297a632d5b3c143390fbcef9212b0128b8f1b12c05aeb02979 SHA512 86badc49d3a6adef1d5283c38776cc8ab8dce6ce516ce6a87af76d00f4a681747eb5d4415640dfa191929ef5b77865a57bc72c7e10bc37e59c66d44119e7749c
+DIST upmpdcli-1.8.17.tar.gz 706974 BLAKE2B 833aa9cbee6e725d15551409babdab8140721c02048427d6de7b5ddb49ce76f99c7af8c9de4925482f819c636a5fe74037bc096548b79a69afdb828b90aa3e5c SHA512 de11076176d50021103089b202bd7d7b1bb364482eeb5a671038c20b24eead5f64c80ed4873dbd70dae037a8b12fbee6de522f3a484d1b67d77723e26211a4af
diff --git a/media-sound/upmpdcli/upmpdcli-1.8.17.ebuild b/media-sound/upmpdcli/upmpdcli-1.8.17.ebuild
new file mode 100644
index 000000000000..c929aea886e6
--- /dev/null
+++ b/media-sound/upmpdcli/upmpdcli-1.8.17.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd
+
+DESCRIPTION="UPnP Media Renderer front-end for MPD, the Music Player Daemon"
+HOMEPAGE="https://www.lesbonscomptes.com/upmpdcli/index.html"
+
+SRC_URI="https://www.lesbonscomptes.com/upmpdcli/downloads/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="thirdparty"
+
+DEPEND="
+ net-misc/curl
+ dev-libs/jsoncpp
+ media-libs/libmpdclient
+ net-libs/libmicrohttpd:=
+ >net-libs/libupnpp-0.26.4
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/upmpdcli
+ acct-user/upmpdcli
+ app-misc/recoll
+ thirdparty? ( dev-python/requests )
+"
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ systemd_dounit systemd/upmpdcli.service
+}