summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2022-09-15 14:45:31 +0800
committerYixun Lan <dlan@gentoo.org>2022-09-15 14:46:03 +0800
commit579c15bf47edaa901471077693563d9a900cde82 (patch)
treec6516ecdec265f616d3725827b93e10e7610d84a
parentmedia-libs/opencv: Stabilize 4.6.0-r2 x86, #865239 (diff)
downloadgentoo-579c15bf47edaa901471077693563d9a900cde82.tar.gz
gentoo-579c15bf47edaa901471077693563d9a900cde82.tar.bz2
gentoo-579c15bf47edaa901471077693563d9a900cde82.zip
dev-libs/libfilezilla: add 0.39.1
Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--dev-libs/libfilezilla/Manifest1
-rw-r--r--dev-libs/libfilezilla/libfilezilla-0.39.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/libfilezilla/Manifest b/dev-libs/libfilezilla/Manifest
index 22961aa6d8f4..954c1e24885a 100644
--- a/dev-libs/libfilezilla/Manifest
+++ b/dev-libs/libfilezilla/Manifest
@@ -1,2 +1,3 @@
DIST libfilezilla-0.37.2.tar.bz2 609128 BLAKE2B 8ff4bee0c007c2c527d172bef8a6efd4e3238e9a265d75d5a8bcc50a204e0fcef09876f112d7eacd4df4f4cf6551361e99646dd7729ab09774a7416440c5ee06 SHA512 a8902977bae5f442045faa8a68c2f85e667a2371b1e643fde49e592fa9544b0a672c476246b01b2ba7b52390b37b0f1f33e5196be4499eddf5783f225091c93a
DIST libfilezilla-0.38.1.tar.bz2 621099 BLAKE2B f998fda61907edeaa62d29f686a2dfa2ef34f35866010720c4a6d8a7e16ffa7b079d0ed2098ec7df24a3921bf437362fde48d7cd53af9eca2fefd326441e65bd SHA512 486aa4934f3fde4684c134ac7648edd0dfbd2dd2082909cd8ecafcccf9e3e9a86874c250773bc28ad25a8c40c8d34f242008636efdf4d311764682cf89b6fe39
+DIST libfilezilla-0.39.1.tar.bz2 622574 BLAKE2B 2845f0309f8a9036f42930203b89d503ffe5897dbb819cc9249b3179deb24f5c562843471712702d7a302df0b3c7dead1bc108de9dd5dd4b1cb1501cd3ef9ba1 SHA512 b5c4dcaef146ea3e249a4972e66aa441187693bea148f0ead0c08568ecf1856a78c7455cbc70737d82b9c33c2af5d6abe79dd4cb2dfbb65bdcefd6765016dfb6
diff --git a/dev-libs/libfilezilla/libfilezilla-0.39.1.ebuild b/dev-libs/libfilezilla/libfilezilla-0.39.1.ebuild
new file mode 100644
index 000000000000..fa9b18b48316
--- /dev/null
+++ b/dev-libs/libfilezilla/libfilezilla-0.39.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit flag-o-matic
+
+DESCRIPTION="C++ library offering some basic functionality for platform-independent programs"
+HOMEPAGE="https://lib.filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/29" # libfilezilla.so version
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/nettle:0=
+ >=net-libs/gnutls-3.5.7:=
+ virtual/libcrypt:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cppunit )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.37.1-pthread.patch )
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}
+
+src_configure() {
+ if use ppc || use arm || use hppa; then
+ # bug 727652
+ append-libs -latomic
+ fi
+
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}