summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-04 05:01:20 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-04 05:50:27 +0100
commit57faf9330189ff31ef5f119bcad1424e7f0ec431 (patch)
tree609812279e3133b21bf884882fccfee0f27e86d1
parentmedia-sound/strawberry: fix automagic ICU dep (diff)
downloadgentoo-57faf9330189ff31ef5f119bcad1424e7f0ec431.tar.gz
gentoo-57faf9330189ff31ef5f119bcad1424e7f0ec431.tar.bz2
gentoo-57faf9330189ff31ef5f119bcad1424e7f0ec431.zip
dev-python/botocore: Bump to 1.29.84
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.84.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index e45d3fb25f25..a5cb4a2f7fc4 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.29.80.gh.tar.gz 11197756 BLAKE2B 62f70c71f6b5892ff4daaede65389c7
DIST botocore-1.29.81.gh.tar.gz 11211684 BLAKE2B c89f683ab6fd238f975af4a30eea6191d1a6c2a8cf5ec1ac640a34de801bc289545dc2a98e9a76824afdb650b9d173751b23af3a3f3e9438f8cd1cdeb0fb64e3 SHA512 91b0d34652f68a3f41e768ff35d342c50868fb9e6f9da2b97a64cf08cac03e959395ac499b9fea7cf5997273700b06499f0d870661b9104709fead4a87c0a1ee
DIST botocore-1.29.82.gh.tar.gz 11213502 BLAKE2B 8038e8a97e7c8795b9f273e6d7a87f42d764c7996ebc9c6ba831720db9104ead2e11b8a30e660b1112ca2e5ce2582f7135b0db79c56bf6c615f9a7e242b9ef8e SHA512 4492b8bed66736f446e3dd76bf0bde56e2402093630f38246941d17e388f62ca2d0e069b08c7a39cd12e719d062c85c0981636b72362118a8d689581e492ad06
DIST botocore-1.29.83.gh.tar.gz 11216449 BLAKE2B a1eaa0710317c257291045fb1514ffaaff07f5ce8e8c37652e60658020273cb5ff4ec1af15a678b0f0249def13e793ee6ed4e8902ce8af4c6b6a48c2767703a7 SHA512 acaabf7c225fa5ae9b3428bdad3a28ffb41ff5a2b637b52c7a1829de0c50ed2d99118d77abcef9e333ffb25de09c5e37a9b817739512dafa8e75ca370a956cc1
+DIST botocore-1.29.84.gh.tar.gz 11220100 BLAKE2B 588efd08ec38eee7e319ea6e1d41af3f8d96c8e71fa090e5d3e8c836d60be957c47b556a9ce18684d53cb415446a360006714501dfbfc77204b2822247e7bf35 SHA512 cee6066735b324d550b736224ce4a4cff207cb7494d14e599ff9606b7a530d3887636054b3d0457269234d83ec0078950e03f916cd834cf910680e7ca650167b
diff --git a/dev-python/botocore/botocore-1.29.84.ebuild b/dev-python/botocore/botocore-1.29.84.ebuild
new file mode 100644
index 000000000000..0f4daaa48e81
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.84.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}