summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-05 12:10:59 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-05 15:34:14 +0100
commit5815878851b1b7f99d343846865c76d0749f1a60 (patch)
tree566a2188e29826e1aac42ff830f615236659f0ee
parentdev-python/pytest-sugar: Remove old (diff)
downloadgentoo-5815878851b1b7f99d343846865c76d0749f1a60.tar.gz
gentoo-5815878851b1b7f99d343846865c76d0749f1a60.tar.bz2
gentoo-5815878851b1b7f99d343846865c76d0749f1a60.zip
dev-python/pytest-sugar: Bump to 0.9.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-sugar/Manifest1
-rw-r--r--dev-python/pytest-sugar/pytest-sugar-0.9.6.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-sugar/Manifest b/dev-python/pytest-sugar/Manifest
index 6565d3386b56..09ec95b84218 100644
--- a/dev-python/pytest-sugar/Manifest
+++ b/dev-python/pytest-sugar/Manifest
@@ -1 +1,2 @@
DIST pytest-sugar-0.9.5.tar.gz 13545 BLAKE2B 37c5241b951b3167c73537ca7bbb93f679673e57c84a13b74caacfcb8d5510b5e5ad215aa4aa33f722efffa54d30ff73d521bce412214857d11c25c255596bdc SHA512 4451d09181b6130591c504b2825a86777f5daa6972a6be7f2bc51139cf3ef2e57dfc1b8ea1972220a1c84866ed2584c684cc83c8052cb9105c0c3a9ea19922fe
+DIST pytest-sugar-0.9.6.tar.gz 13702 BLAKE2B 72a48d501ba5bd597ec2561817179cd50213d1de80a3281823033d9d1a1c62f37367353885d805a6e212380ddaa934b1e0887814742e26cd1b809b4ef629cf19 SHA512 955e28478854c6751e7470b49f130bce2904c1f74d46caa2a6e212c132e3f1f0565f2f31ac360a32d2d9c4999f4dcdd19e7373508660bfd7da530981aef9cd62
diff --git a/dev-python/pytest-sugar/pytest-sugar-0.9.6.ebuild b/dev-python/pytest-sugar/pytest-sugar-0.9.6.ebuild
new file mode 100644
index 000000000000..edf438421a2e
--- /dev/null
+++ b/dev-python/pytest-sugar/pytest-sugar-0.9.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin that changes the default look and feel of pytest"
+HOMEPAGE="
+ https://github.com/Teemu/pytest-sugar/
+ https://pypi.org/project/pytest-sugar/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest