summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Vasquez <fearedbliss@gentoo.org>2020-07-18 12:34:13 -0400
committerJonathan Vasquez <fearedbliss@gentoo.org>2020-07-18 12:34:13 -0400
commit58d360eb145b1c975f46b66333e5d6bbf6a07ba9 (patch)
tree7a98b1febf77728d509576a727a23ef1da905ca9
parentsys-kernel/bliss-initramfs: Added 8.1.0-r1 (diff)
downloadgentoo-58d360eb145b1c975f46b66333e5d6bbf6a07ba9.tar.gz
gentoo-58d360eb145b1c975f46b66333e5d6bbf6a07ba9.tar.bz2
gentoo-58d360eb145b1c975f46b66333e5d6bbf6a07ba9.zip
sys-kernel/bliss-initramfs: stabilizing 8.1.0-r1
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Jonathan Vasquez <fearedbliss@gentoo.org>
-rw-r--r--sys-kernel/bliss-initramfs/bliss-initramfs-8.1.0-r1.ebuild2
-rw-r--r--sys-kernel/bliss-initramfs/bliss-initramfs-8.1.0.ebuild56
2 files changed, 1 insertions, 57 deletions
diff --git a/sys-kernel/bliss-initramfs/bliss-initramfs-8.1.0-r1.ebuild b/sys-kernel/bliss-initramfs/bliss-initramfs-8.1.0-r1.ebuild
index a25ff54ad643..5223e32f61f1 100644
--- a/sys-kernel/bliss-initramfs/bliss-initramfs-8.1.0-r1.ebuild
+++ b/sys-kernel/bliss-initramfs/bliss-initramfs-8.1.0-r1.ebuild
@@ -14,7 +14,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="strip"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="-* ~amd64"
+KEYWORDS="-* amd64"
RDEPEND="
${PYTHON_DEPS}
diff --git a/sys-kernel/bliss-initramfs/bliss-initramfs-8.1.0.ebuild b/sys-kernel/bliss-initramfs/bliss-initramfs-8.1.0.ebuild
deleted file mode 100644
index ef11f110a78a..000000000000
--- a/sys-kernel/bliss-initramfs/bliss-initramfs-8.1.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit python-single-r1
-
-DESCRIPTION="Boot your system's rootfs from OpenZFS/LUKS"
-HOMEPAGE="https://github.com/fearedbliss/bliss-initramfs"
-SRC_URI="https://github.com/fearedbliss/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RESTRICT="strip"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="-* amd64"
-
-RDEPEND="
- ${PYTHON_DEPS}
- app-arch/cpio
- virtual/udev"
-
-S="${WORKDIR}/${PN}-${PV}"
-
-CONFIG_FILE="/etc/bliss-initramfs/settings.json"
-
-src_install() {
- # Copy the main executable
- local executable="mkinitrd.py"
- exeinto "/opt/${PN}"
- doexe "${executable}"
-
- # Copy the libraries required by this executable
- cp -r "${S}/files" "${D}/opt/${PN}" || die
- cp -r "${S}/pkg" "${D}/opt/${PN}" || die
-
- # Copy documentation files
- dodoc README.md README-MORE USAGE_AND_OPTIONS
-
- # Copy the configuration file for the user
- dodir "/etc/${PN}"
- cp "${S}/files/default-settings.json" "${D}${CONFIG_FILE}"
-
- # Make a relative symbolic link: /sbin/bliss-initramfs
- dosym "../opt/${PN}/${executable}" "/sbin/${PN}"
-}
-
-pkg_postinst() {
- elog "As of version 8.1.0, ${PN} has a new centralized configuration architecture."
- elog "Any customizations you want to provide to ${PN} should be done by modifying"
- elog "${CONFIG_FILE}. You can use the \"-c/--config\" option to provide"
- elog "an alternate configuration path.\n"
- elog "For a full list of changes, please read the release info located here:"
- elog "https://github.com/fearedbliss/bliss-initramfs/releases/tag/8.1.0"
-}