summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-01-23 22:20:06 -0800
committerMatt Turner <mattst88@gentoo.org>2022-01-23 22:20:06 -0800
commit590b469039598aee756198bfa6bc296c12d6ccde (patch)
tree41fecb64838f81391ab8193fbe376d052bace0fc
parentsys-power/powertop: Drop old versions (diff)
downloadgentoo-590b469039598aee756198bfa6bc296c12d6ccde.tar.gz
gentoo-590b469039598aee756198bfa6bc296c12d6ccde.tar.bz2
gentoo-590b469039598aee756198bfa6bc296c12d6ccde.zip
www-client/epiphany: Version bump to 41.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-41.3.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 325ceb613c26..b0887074edb2 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,2 +1,3 @@
DIST epiphany-40.5.tar.xz 5380340 BLAKE2B 60dcdacd8fc199e68d2009c841e5d80e54c6246b9f39f9d6523fb8dcd837dba4a949911643c634abb5c53e08473e92b5bde90709ec8650cc23c4aceaeac14edd SHA512 939fc749723c87457a73b90fadb37e8c6db0996ada73d5c859ff3f9b8a2401bca369a8145336542a169b006a9c0e02f6642a1a39b3770654d30cb28b55e69972
DIST epiphany-40.6.tar.xz 5380620 BLAKE2B 43a0ba03ebab5af074785beecacbf7279f0ee44c7f12467441fc026d8e48c16a1d3391080d2960d6b72027995b9fc203c15cbfa17db35cbf010edfa9d472422c SHA512 92805afe14323547c816beb43da104c05b62c59b64d7e3dc194f8e89be3abf309261310da11ff5c5ba99809794b796de9911316d77663a7c51b3a79b63fe4e1f
+DIST epiphany-41.3.tar.xz 6153540 BLAKE2B bd95f643be4947818ebfafb1316a03c7c6cf118a45583f07e9fde60e32dabd63edf173673b86e454d9af066769950276cf77ea50fac8dd204fcae06c6ad04126 SHA512 1effef22291687c8ff2252eced24274db3b1f4afacfc3053a33cae85112759918f80d824bb02b7e17d95364eec0062cb3459a6079783d9c900874cc150ea98ba
diff --git a/www-client/epiphany/epiphany-41.3.ebuild b/www-client/epiphany/epiphany-41.3.ebuild
new file mode 100644
index 000000000000..f64e9c5a230e
--- /dev/null
+++ b/www-client/epiphany/epiphany-41.3.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.67.1:2
+ >=x11-libs/gtk+-3.24.0:3
+ >=dev-libs/nettle-3.4:=
+ >=net-libs/webkit-gtk-2.33.2:4=
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.5.5:=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ gnome-base/gsettings-desktop-schemas
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.6
+ app-arch/libarchive:=
+ >=dev-libs/libdazzle-3.37.1
+ >=gui-libs/libhandy-1.1.0:1=
+ >=app-crypt/libsecret-0.19
+ >=net-libs/libsoup-2.48.0:2.4
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-db/sqlite-3.22:3
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Allow /var/tmp prefixed recursive delete (due to package manager setting TMPDIR)
+ "${FILESDIR}"/var-tmp-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ -Dlibportal=disabled
+ # maybe enable later if network-sandbox is off, but in 3.32.4 the network test
+ # is commented out upstream anyway
+ -Dnetwork_tests=disabled
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ -Dsoup2=enabled
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}