summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-09 13:46:12 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-09 15:39:54 +0200
commit5982879d8591fef65d15dd424468d89e3979f4f7 (patch)
treed11c66621c0648d36c56a9628c502d879f7692a2
parentapp-text/libspectre: Drop old (diff)
downloadgentoo-5982879d8591fef65d15dd424468d89e3979f4f7.tar.gz
gentoo-5982879d8591fef65d15dd424468d89e3979f4f7.tar.bz2
gentoo-5982879d8591fef65d15dd424468d89e3979f4f7.zip
app-text/libspectre: Version bump
Package-Manager: portage-2.3.0
-rw-r--r--app-text/libspectre/Manifest1
-rw-r--r--app-text/libspectre/libspectre-0.2.8.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/libspectre/Manifest b/app-text/libspectre/Manifest
index e7a3d5aba094..bb24b107549f 100644
--- a/app-text/libspectre/Manifest
+++ b/app-text/libspectre/Manifest
@@ -1 +1,2 @@
DIST libspectre-0.2.7.tar.gz 387947 SHA256 e81b822a106beed14cf0fec70f1b890c690c2ffa150fa2eee41dc26518a6c3ec SHA512 2e60905f7eeed9ac6ec3b5f8b47a7dad85178c8c35a63ba097ef6088dd334f7fde5797ecb05cf67532b759d07a65006427914d2cd6b09107ecc90620c9541794 WHIRLPOOL b59a1fea4ebd0cac13d4b5c7e76247de214761929bd71cf7879832acc4779786d764ddf2d38c5dea070f6e05c41f0d8460b8a8b11a51c35492827228740fb604
+DIST libspectre-0.2.8.tar.gz 421791 SHA256 65256af389823bbc4ee4d25bfd1cc19023ffc29ae9f9677f2d200fa6e98bc7a8 SHA512 ebbe7f6adcbc7f7d6af61f24e23b114116c878755dbe90f1163546c1284a005b4d539be01986c1f940611e84141ca19768b8effc2abf1013606da7c93547da86 WHIRLPOOL 6e454fe6d16d8f01b45e82424b62a333876edfe44772fafafa1915caefdcbf857975814fd3d14294c5abebe3d1a80842a9ce212e43825bf144ebef96a60af32e
diff --git a/app-text/libspectre/libspectre-0.2.8.ebuild b/app-text/libspectre/libspectre-0.2.8.ebuild
new file mode 100644
index 000000000000..4b52741f1275
--- /dev/null
+++ b/app-text/libspectre/libspectre-0.2.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="A library for rendering Postscript documents"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libspectre"
+SRC_URI="https://libspectre.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="debug doc static-libs"
+
+RDEPEND=">=app-text/ghostscript-gpl-8.62"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+# does not actually test anything, see bug 362557
+RESTRICT="test"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${PN}-0.2.0-interix.patch
+ eautoreconf # need new libtool for interix
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug asserts) \
+ $(use_enable debug checks) \
+ $(use_enable static-libs static) \
+ --disable-test
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_install() {
+ default
+ use doc && dohtml -r doc/html/*
+ prune_libtool_files
+}