summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-02-25 17:35:04 -0500
committerMike Frysinger <vapier@gentoo.org>2016-02-25 17:35:09 -0500
commit59a71a42313bb4e38dfcc759f2e44c038004b7fe (patch)
tree27c79690ba8b0150fc441f1600d0662f0a96dfc2
parentmedia-sound/snd: version bump to 16.3 (diff)
downloadgentoo-59a71a42313bb4e38dfcc759f2e44c038004b7fe.tar.gz
gentoo-59a71a42313bb4e38dfcc759f2e44c038004b7fe.tar.bz2
gentoo-59a71a42313bb4e38dfcc759f2e44c038004b7fe.zip
app-editors/nano: version bump to 2.5.3
-rw-r--r--app-editors/nano/Manifest1
-rw-r--r--app-editors/nano/nano-2.5.3.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index 0fd52b0589eb..e94f741d82e4 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -1,3 +1,4 @@
DIST nano-2.4.3.tar.gz 1878096 SHA256 32d627072b6026678e4f4095c047adec92ac7ec542dd6d91cf27f49b601768f2 SHA512 53c9f93b0f001a3d6c292a6995d66b6bcca033407b6b69995c62b9e9f721fd5566fbd0e22ece1b2561a47e56ef19c3f1ee196e23edfe832289704e0ebef45de9 WHIRLPOOL cd2e4d7175521835c71f0338a2115d2d9fec4da1d4eb2abbb633cfef907fde69fb12acd5e0db343d1f90945f05d60abb85daa5a045d9b97ef8cd19fb9b226607
DIST nano-2.5.0.tar.gz 1909625 SHA256 ff323e6fef74caf0a924304841c07ac65ec30db99dc5c1f8272b4c536a5c89ee SHA512 f05f1afa6a79ff6b87359c46fbdaf6161eacdc265ac6be155a0173e3ab5a17023e205d0b9667a942e754556182a9007fe4438f337a830d20b9546aad9d522ba6 WHIRLPOOL 29fbb67ce561da8255dca70d7554d604094a21e89e39ce94fadb67bc3236550ea1ee3f08838616deed8a4e37657df0ef6d320c701cc77a086d8d1ce2dae43d1d
DIST nano-2.5.2.tar.gz 1964016 SHA256 89bd6ac5120880d2a95431d8bad22bf92c7ccbf10b8f1716d4ea062f3faeeb41 SHA512 ec4e35cfb23494dd09c23b195556dfb36b9329007d61bdfe6a25a43c9914e432160969c92ed991bb2221ea5facd5ae1c1e9aef0029dfa259d827b7ea4943a1d3 WHIRLPOOL 3963ed7fad9296ea0d85300dc7ad518a33e2b793d9b94e98056a4c82c9b7984ef187dfa10653f787b262755521321c1e2c37562c1f95cfd338927329c6d0aa97
+DIST nano-2.5.3.tar.gz 1967760 SHA256 b2b060129b9feff2d4870d803a441178c96531de9aed144ec0b83bd63ccb12ee SHA512 1d859f0bd88b9d907cfcaa84edc212bcaea4335c203922eb5b7378c2b45d88dffe1f3e4cb499a824d33781485834ef564997c58cf1fd92610d08f6ce8dcb67d5 WHIRLPOOL a2ca1c41d3cb26756cc9aba5b5fa0aeaea220626b98d0abfa1c5c4d4d57c3a5ef688d5edf00a6a00849ee25a67b2bbab93c4d454f6eb5a204b10fa01de3e298f
diff --git a/app-editors/nano/nano-2.5.3.ebuild b/app-editors/nano/nano-2.5.3.ebuild
new file mode 100644
index 000000000000..4e03e23d6714
--- /dev/null
+++ b/app-editors/nano/nano-2.5.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils flag-o-matic
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="svn://svn.savannah.gnu.org/nano/trunk/nano"
+ inherit subversion autotools
+else
+ MY_P=${PN}-${PV/_}
+ SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="http://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
+
+LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
+ sys-libs/ncurses:0=[static-libs(+)]
+ magic? ( sys-apps/file[static-libs(+)] )
+ nls? ( virtual/libintl )
+ !ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+ static? ( ${LIB_DEPEND} )"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+ epatch_user
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ local myconf=()
+ case ${CHOST} in
+ *-gnu*|*-uclibc*) myconf+=( "--with-wordbounds" ) ;; #467848
+ esac
+ econf \
+ --bindir="${EPREFIX}"/bin \
+ --htmldir=/trash \
+ $(use_enable !minimal color) \
+ $(use_enable !minimal multibuffer) \
+ $(use_enable !minimal nanorc) \
+ --disable-wrapping-as-root \
+ $(use_enable magic libmagic) \
+ $(use_enable spell speller) \
+ $(use_enable justify) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable unicode utf8) \
+ $(use_enable minimal tiny) \
+ $(usex ncurses --without-slang $(use_with slang)) \
+ "${myconf[@]}"
+}
+
+src_install() {
+ default
+ rm -rf "${D}"/trash
+
+ dodoc doc/nanorc.sample
+ dohtml doc/faq.html
+ insinto /etc
+ newins doc/nanorc.sample nanorc
+ if ! use minimal ; then
+ # Enable colorization by default.
+ sed -i \
+ -e '/^# include /s:# *::' \
+ "${ED}"/etc/nanorc || die
+ fi
+
+ dodir /usr/bin
+ dosym /bin/nano /usr/bin/nano
+}