summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-19 04:25:42 +0000
committerSam James <sam@gentoo.org>2022-11-24 03:08:13 +0000
commit59aefbdbc113f8093239729eaef56b44ccef035e (patch)
tree28608c7569e0b140366c419ae6345c04d8d0dfee
parentgnome-base/nautilus: Keyword 43.0 riscv, #882511 (diff)
downloadgentoo-59aefbdbc113f8093239729eaef56b44ccef035e.tar.gz
gentoo-59aefbdbc113f8093239729eaef56b44ccef035e.tar.bz2
gentoo-59aefbdbc113f8093239729eaef56b44ccef035e.zip
dev-libs/gjs: drop 1.64.5
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/gjs/Manifest1
-rw-r--r--dev-libs/gjs/files/gjs-1.64.5-gcc-11-support.patch129
-rw-r--r--dev-libs/gjs/gjs-1.64.5.ebuild51
3 files changed, 0 insertions, 181 deletions
diff --git a/dev-libs/gjs/Manifest b/dev-libs/gjs/Manifest
index 8e7789c777d4..968140abcd22 100644
--- a/dev-libs/gjs/Manifest
+++ b/dev-libs/gjs/Manifest
@@ -1,4 +1,3 @@
-DIST gjs-1.64.5.tar.xz 422548 BLAKE2B dcc0b7327cbc6a1108be031c8807e61ebd3c8392916750078aaa0d82cb3bf9f7ff0e1876c250e5ddf6e9d7bb6a17d9d1fe34c1c77ff534b7ec1dd54fa05a2d1b SHA512 41a3c79888792674b2bccbf254507ed02497eb571c8ca7f47aab406d2ee29b73c98b1c7d59c33ed33bad90c6989df944d78b86d2f7e9824d598b62e29769b6dc
DIST gjs-1.72.2.tar.xz 620380 BLAKE2B 5ea15bdf25c36fa0236f03adea5b2261db3923190005754119eacd070830e7baedfa842ab273219055f67f7af535d31d5844c76eddfb03a8ec1cab57297ec258 SHA512 0dd10f40e8811bbb79c541cf3dc4e3759c0e025485e4b8ad2870dc30ac8030573300bc178c78bf2d396b86733e36b33210bfbdeead6a314e592d5b3c250a16a2
DIST gjs-1.74.0.tar.xz 638064 BLAKE2B d44f323aef9b696c7dab53fb46d6bbf142f83636bff81fe68bd30f1f897a778836d7a388c946cb86e84df15b3908d8ff14f0d994854eb2dce7af2c4e54da299b SHA512 a17947664a2bb83363ec564dcb5e619f241d0b547512042f2c0e49fbbc8ca4217b90e6b22bc2e4004e8f27e013f8520674a493f7cf3b808437b855eee3eb0408
DIST gjs-1.74.1.tar.xz 638536 BLAKE2B 375abcaa20a538cfa271f7dcf6f3715e4324ff5a4a9482ce0dd7f78213598a715ebc034f701fe458876f841f72802db4ae2aabf0abc04dc4ac5bb39c917741fd SHA512 346667accb589df0e6a045e30782017eab928115f263d36d521b61b0af38fd268bc518b8ab5ec78e5d25e0194b744a2ee59e65668da679e138b2122858ce0614
diff --git a/dev-libs/gjs/files/gjs-1.64.5-gcc-11-support.patch b/dev-libs/gjs/files/gjs-1.64.5-gcc-11-support.patch
deleted file mode 100644
index 3808b6d7862b..000000000000
--- a/dev-libs/gjs/files/gjs-1.64.5-gcc-11-support.patch
+++ /dev/null
@@ -1,129 +0,0 @@
-From 757d42d87e8a3b52a0782bc9cbd33c788ecc34e4 Mon Sep 17 00:00:00 2001
-From: Philip Chimento <philip.chimento@gmail.com>
-Date: Mon, 15 Feb 2021 20:40:43 -0800
-Subject: [PATCH 1/2] GjsPrivate: Remove volatile from g_once_init_enter flag
-
-On platforms where g_once_init_enter() is defined to use C11 atomic
-builtins, passing a pointer to a volatile value will generate a warning
-in GCC 11 and later.
-
-More info about the GCC change:
-https://gcc.gnu.org/bugzilla/show_bug.cgi?id=95378
-https://gcc.gnu.org/pipermail/gcc-patches/2020-June/548283.html
-
-More info about changes made in GLib:
-https://gitlab.gnome.org/GNOME/glib/-/issues/600
-
-See: #376
-(cherry picked from commit 989ac9ac723dc1c8b6b8961292f236c558f5c0f0)
----
- libgjs-private/gjs-util.c | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/libgjs-private/gjs-util.c b/libgjs-private/gjs-util.c
-index 20a732d5..f7f3189a 100644
---- a/libgjs-private/gjs-util.c
-+++ b/libgjs-private/gjs-util.c
-@@ -57,8 +57,8 @@ gjs_format_int_alternative_output(int n)
- GType
- gjs_locale_category_get_type(void)
- {
-- static volatile size_t g_define_type_id__volatile = 0;
-- if (g_once_init_enter(&g_define_type_id__volatile)) {
-+ static size_t gjs_locale_category_get_type = 0;
-+ if (g_once_init_enter(&gjs_locale_category_get_type)) {
- static const GEnumValue v[] = {
- { GJS_LOCALE_CATEGORY_ALL, "GJS_LOCALE_CATEGORY_ALL", "all" },
- { GJS_LOCALE_CATEGORY_COLLATE, "GJS_LOCALE_CATEGORY_COLLATE", "collate" },
-@@ -72,9 +72,9 @@ gjs_locale_category_get_type(void)
- GType g_define_type_id =
- g_enum_register_static(g_intern_static_string("GjsLocaleCategory"), v);
-
-- g_once_init_leave(&g_define_type_id__volatile, g_define_type_id);
-+ g_once_init_leave(&gjs_locale_category_get_type, g_define_type_id);
- }
-- return g_define_type_id__volatile;
-+ return gjs_locale_category_get_type;
- }
-
- /**
---
-2.35.1
-
-From dade6ee66e07a1865dc380060abe921eaeeae763 Mon Sep 17 00:00:00 2001
-From: Philip Chimento <philip.chimento@gmail.com>
-Date: Sun, 14 Feb 2021 12:20:09 -0800
-Subject: [PATCH 2/2] maint: Avoid g_once_init_enter error in GCC 11
-
-On platforms where g_once_init_enter() is defined to use C11 atomic
-builtins, passing a pointer to a volatile value is an error in GCC 11 and
-later, in C++.
-
-More info about the GCC change:
-https://gcc.gnu.org/bugzilla/show_bug.cgi?id=95378
-https://gcc.gnu.org/pipermail/gcc-patches/2020-June/548283.html
-
-However, it's my understanding that in modern C++ there is no longer a
-need to guard the initialization of these variables. Since C++11, static
-local variables in a function are guaranteed to be initialized only once,
-the first time control passes through that function. So we can just remove
-the g_once_init_enter guard.
-
-More info:
-https://en.cppreference.com/w/cpp/language/storage_duration#Static_local_variables
-
-Stack Overflow answers with quotations from the C++ standard:
-https://stackoverflow.com/a/58804/172999
-https://stackoverflow.com/a/8102145/172999
-
-Closes: #376
-(cherry picked from commit f02eaf3a9d3465915eb849428c2d9615e2184a4c)
----
- gjs/error-types.cpp | 32 +++++++++++++-------------------
- 1 file changed, 13 insertions(+), 19 deletions(-)
-
-diff --git a/gjs/error-types.cpp b/gjs/error-types.cpp
-index 86cb8789..5eba61b2 100644
---- a/gjs/error-types.cpp
-+++ b/gjs/error-types.cpp
-@@ -31,24 +31,18 @@ G_DEFINE_QUARK(gjs-js-error-quark, gjs_js_error)
- // clang-format on
-
- GType gjs_js_error_get_type(void) {
-- static volatile GType g_type_id;
--
-- if (g_once_init_enter(&g_type_id)) {
-- static GEnumValue errors[] = {
-- { GJS_JS_ERROR_ERROR, "Error", "error" },
-- { GJS_JS_ERROR_EVAL_ERROR, "EvalError", "eval-error" },
-- { GJS_JS_ERROR_INTERNAL_ERROR, "InternalError", "internal-error" },
-- { GJS_JS_ERROR_RANGE_ERROR, "RangeError", "range-error" },
-- { GJS_JS_ERROR_REFERENCE_ERROR, "ReferenceError", "reference-error" },
-- { GJS_JS_ERROR_STOP_ITERATION, "StopIteration", "stop-iteration" },
-- { GJS_JS_ERROR_SYNTAX_ERROR, "SyntaxError", "syntax-error" },
-- { GJS_JS_ERROR_TYPE_ERROR, "TypeError", "type-error" },
-- { GJS_JS_ERROR_URI_ERROR, "URIError", "uri-error" },
-- { 0, nullptr, nullptr }
-- };
--
-- g_type_id = g_enum_register_static("GjsJSError", errors);
-- }
--
-+ static const GEnumValue errors[] = {
-+ {GJS_JS_ERROR_ERROR, "Error", "error"},
-+ {GJS_JS_ERROR_EVAL_ERROR, "EvalError", "eval-error"},
-+ {GJS_JS_ERROR_INTERNAL_ERROR, "InternalError", "internal-error"},
-+ {GJS_JS_ERROR_RANGE_ERROR, "RangeError", "range-error"},
-+ {GJS_JS_ERROR_REFERENCE_ERROR, "ReferenceError", "reference-error"},
-+ {GJS_JS_ERROR_STOP_ITERATION, "StopIteration", "stop-iteration"},
-+ {GJS_JS_ERROR_SYNTAX_ERROR, "SyntaxError", "syntax-error"},
-+ {GJS_JS_ERROR_TYPE_ERROR, "TypeError", "type-error"},
-+ {GJS_JS_ERROR_URI_ERROR, "URIError", "uri-error"},
-+ {0, nullptr, nullptr}};
-+ // Initialization of static local variable guaranteed only once in C++11
-+ static GType g_type_id = g_enum_register_static("GjsJSError", errors);
- return g_type_id;
- }
---
-2.35.1
-
diff --git a/dev-libs/gjs/gjs-1.64.5.ebuild b/dev-libs/gjs/gjs-1.64.5.ebuild
deleted file mode 100644
index c9acc67c8466..000000000000
--- a/dev-libs/gjs/gjs-1.64.5.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit gnome.org meson virtualx
-
-DESCRIPTION="Javascript bindings for GNOME"
-HOMEPAGE="https://wiki.gnome.org/Projects/Gjs"
-
-LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
-SLOT="0"
-IUSE="+cairo examples readline +sysprof test"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~loong ppc ppc64 sparc x86"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/glib-2.58.0
- dev-libs/libffi:=
- >=dev-libs/gobject-introspection-1.61.2:=
- dev-lang/spidermonkey:68
- cairo? ( x11-libs/cairo[X] )
- readline? ( sys-libs/readline:0= )
-"
-DEPEND="${RDEPEND}
- sysprof? ( >=dev-util/sysprof-capture-3.33.2:3 )
- virtual/pkgconfig
- test? ( sys-apps/dbus
- >=x11-libs/gtk+-3.20:3[introspection] )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gcc-11-support.patch
-)
-
-src_configure() {
- # FIXME: add systemtap/dtrace support, like in glib:2
- local emesonargs=(
- $(meson_feature cairo)
- $(meson_feature readline)
- $(meson_feature sysprof profiler)
- -Dinstalled_tests=false
- $(meson_use !test skip_dbus_tests)
- $(meson_use !test skip_gtk_tests)
- )
- meson_src_configure
-}
-
-src_test() {
- virtx meson_src_test
-}