summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-13 17:08:44 +0000
committerSam James <sam@gentoo.org>2021-06-13 17:13:53 +0000
commit59b7de1af8fc3b52a49b2f1601b2abd0bca30673 (patch)
tree34b161f3243f280247424b12ee8bdfba73696fe5
parentsci-visualization/paraview: fix build for GCC 11 (diff)
downloadgentoo-59b7de1af8fc3b52a49b2f1601b2abd0bca30673.tar.gz
gentoo-59b7de1af8fc3b52a49b2f1601b2abd0bca30673.tar.bz2
gentoo-59b7de1af8fc3b52a49b2f1601b2abd0bca30673.zip
mail-filter/spamprobe: update EAPI 6 -> 7, fix gcc 11 build
Closes: https://bugs.gentoo.org/787311 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--mail-filter/spamprobe/files/spamprobe-1.4d-gcc11-const-comp.patch13
-rw-r--r--mail-filter/spamprobe/spamprobe-1.4d-r2.ebuild4
2 files changed, 16 insertions, 1 deletions
diff --git a/mail-filter/spamprobe/files/spamprobe-1.4d-gcc11-const-comp.patch b/mail-filter/spamprobe/files/spamprobe-1.4d-gcc11-const-comp.patch
new file mode 100644
index 000000000000..1eec9cc6ee02
--- /dev/null
+++ b/mail-filter/spamprobe/files/spamprobe-1.4d-gcc11-const-comp.patch
@@ -0,0 +1,13 @@
+diff --git a/src/includes/LRUCache.h b/src/includes/LRUCache.h
+index cf7df30..50467d5 100644
+--- a/src/includes/LRUCache.h
++++ b/src/includes/LRUCache.h
+@@ -60,7 +60,7 @@ public:
+ {
+ public:
+ bool operator()(const NodeType *a,
+- const NodeType *b)
++ const NodeType *b) const
+ {
+ return a->key < b->key;
+ }
diff --git a/mail-filter/spamprobe/spamprobe-1.4d-r2.ebuild b/mail-filter/spamprobe/spamprobe-1.4d-r2.ebuild
index dfe97b87b27f..8ff7226aac12 100644
--- a/mail-filter/spamprobe/spamprobe-1.4d-r2.ebuild
+++ b/mail-filter/spamprobe/spamprobe-1.4d-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="Fast, intelligent, automatic spam detector using Bayesian analysis"
HOMEPAGE="http://spamprobe.sourceforge.net/"
@@ -26,6 +26,7 @@ PATCHES=(
"${FILESDIR}"/${P}+db-5.0.patch
"${FILESDIR}"/${P}-gcc47.patch
"${FILESDIR}"/${P}-giflib5.patch
+ "${FILESDIR}"/${P}-gcc11-const-comp.patch
)
src_configure() {
@@ -37,6 +38,7 @@ src_configure() {
src_install() {
default
+
insinto /usr/share/${PN}/contrib
doins contrib/*
}