summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2018-02-19 10:56:58 +0100
committerAgostino Sarubbo <ago@gentoo.org>2018-02-19 10:57:24 +0100
commit59f7803cce04a57f627501bf0bb838797c1e2c77 (patch)
tree1582077b936dc65ec81972bc2d20789c793cda2a
parentapp-admin/puppet: drop webrick patch for newer rubies (diff)
downloadgentoo-59f7803cce04a57f627501bf0bb838797c1e2c77.tar.gz
gentoo-59f7803cce04a57f627501bf0bb838797c1e2c77.tar.bz2
gentoo-59f7803cce04a57f627501bf0bb838797c1e2c77.zip
sys-kernel/git-sources: Automated version bump to 4.16_rc2.
Signed-off-by: Agostino Sarubbo <ago@gentoo.org> Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.16_rc2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index f0cac231e0c9..1bf5194cae7d 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,2 +1,3 @@
DIST linux-4.15.tar.xz 102181404 BLAKE2B 5fd831356c2174d2779ab31033caec6929b2f47857f0bb82ef43ad1140c639d0dc5553e64d062f67486eeff780d5df8d971051fd5a626b51bed170067fea11e0 SHA512 c00d92659df815a53dcac7dde145b742b1f20867d380c07cb09ddb3295d6ff10f8931b21ef0b09d7156923a3957b39d74d87c883300173b2e20690d2b4ec35ea
DIST patch-4.16-rc1.patch 165143143 BLAKE2B 9c373b51ffb514eca21c01dad33d2b236ca0b38e70cd2059afdc39a1a39cd70112ba975f3632da788f58e4bcc6951229f0a7121eedfa4b0d70d07b011a4e7c1c SHA512 fc2e21bd93e0364bf06f5b8fd7512704bffec214a8448e028f72e1037d35f521adf5ca421e38a77fb6481a52df4b3b4e56a77be210600abae6c4730edb759b09
+DIST patch-4.16-rc2.patch 165456194 BLAKE2B c62bd783fda3305d455d8b40d27dee82bee3d6cc6ec4eb58c82e78094c3813bc37677fe69c6843464d939a21502abbc42d5f370b68b9c5ea22d09a37eedb498a SHA512 36af7d64f4ab716b8ab1d21e77e0f4d78d2fb06d3792dac62d998b3889c9d25231182919142be2309fca96963631a815da748ff24e21faf706c37429a2acb7a4
diff --git a/sys-kernel/git-sources/git-sources-4.16_rc2.ebuild b/sys-kernel/git-sources/git-sources-4.16_rc2.ebuild
new file mode 100644
index 000000000000..de404a4af084
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.16_rc2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.15"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}