summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-22 23:20:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-23 10:26:57 +0200
commit5a0fe893c03264f1b77b02bd6c5113d1dba9e525 (patch)
treee7c799b05f142c1eb954abb0a59690b221fc7a5c
parentmultilib.eclass: populate AR, NM, RANLIB, OBJDUMP, STRIP, bug #724558 (diff)
downloadgentoo-5a0fe893c03264f1b77b02bd6c5113d1dba9e525.tar.gz
gentoo-5a0fe893c03264f1b77b02bd6c5113d1dba9e525.tar.bz2
gentoo-5a0fe893c03264f1b77b02bd6c5113d1dba9e525.zip
app-i18n/uim: Drop 1.8.6-r1 and 1.8.6-r2
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-i18n/uim/Manifest1
-rw-r--r--app-i18n/uim/files/uim-1.8.6-gentoo.patch28
-rw-r--r--app-i18n/uim/files/uim-1.8.6-libressl.patch79
-rw-r--r--app-i18n/uim/files/uim-1.8.6-qt.patch16
-rw-r--r--app-i18n/uim/files/uim-1.8.6-tinfo.patch65
-rw-r--r--app-i18n/uim/uim-1.8.6-r1.ebuild209
-rw-r--r--app-i18n/uim/uim-1.8.6-r2.ebuild213
7 files changed, 0 insertions, 611 deletions
diff --git a/app-i18n/uim/Manifest b/app-i18n/uim/Manifest
index 0e626d08dac..593def9c836 100644
--- a/app-i18n/uim/Manifest
+++ b/app-i18n/uim/Manifest
@@ -1,2 +1 @@
-DIST uim-1.8.6.tar.bz2 6500739 BLAKE2B 78623c015cafafa1fbaf32542535de1f0207f8452a422d929a15f4421e4c9926192d0d3b761a7865a38affdf616dc5477e083c0fd8655261ff80ca817fd37029 SHA512 26a95d3b51ef7a99108234b9af30ee7b74141cb3af13d092d4cdbf0749f630934cfd67f74b09dacc3adcdce4a390104489d68a4e2419ec07418645a9b4e5715b
DIST uim-1.8.8.tar.bz2 6228743 BLAKE2B 8fc44b61239f766ba3d9ebf3201c11471b3a844e082237f5ec97dd0fa6fbb04a0a588df5c0479a0aa4bcb4d9c4edcc93c36ec68618701c8aa88fa30732fdce28 SHA512 2257ae48f4f2b79039a5f6be0fc740e218d5609e004dad9a5a1aa5d4066587ee59d0be06bc23c7d567a48901466227fedc4778b480f7184d84b0b3b4dddac9a3
diff --git a/app-i18n/uim/files/uim-1.8.6-gentoo.patch b/app-i18n/uim/files/uim-1.8.6-gentoo.patch
deleted file mode 100644
index 0feee5a7099..00000000000
--- a/app-i18n/uim/files/uim-1.8.6-gentoo.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -36,6 +36,7 @@
- AC_PATH_PROGS(SHA1, sha1 sha1sum)
- AC_PATH_PROGS(SED, sed gsed)
- AX_PATH_QMAKE4
-+PKG_PROG_PKG_CONFIG
-
- AM_MAINTAINER_MODE
-
-@@ -1792,7 +1793,7 @@
- fi
- AX_LANG_WNOERROR # end AC_LANG_WERROR
-
-- QT_CONFIG_OPTS="debug"
-+ QT_CONFIG_OPTS="debug nostrip"
- else
- CFLAGS="$CFLAGS -DNDEBUG"
- CXXFLAGS="$CXXFLAGS -DNDEBUG"
-@@ -1810,7 +1811,7 @@
- AX_CFLAGS_GCC_OPTION([-Wno-unused-variable], [SCIM_CFLAGS])
- AX_LANG_WNOERROR # end AC_LANG_WERROR
-
-- QT_CONFIG_OPTS="release"
-+ QT_CONFIG_OPTS="release nostrip"
- fi
-
- AC_ARG_ENABLE(warnings-into-error,
diff --git a/app-i18n/uim/files/uim-1.8.6-libressl.patch b/app-i18n/uim/files/uim-1.8.6-libressl.patch
deleted file mode 100644
index b14de58433a..00000000000
--- a/app-i18n/uim/files/uim-1.8.6-libressl.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-From 7a281b1131399f04627986e6f9a54499b08e239d Mon Sep 17 00:00:00 2001
-From: Felix Janda <felix.janda@posteo.de>
-Date: Thu, 21 Apr 2016 23:12:10 +0200
-Subject: [PATCH] Make openssl SSLv2 and SSLv3 support optional
-
-Fixes compilation with libressl
----
- uim/openssl.c | 30 ++++++++++++++++++++++++++++++
- 1 file changed, 30 insertions(+)
-
-diff --git a/uim/openssl.c b/uim/openssl.c
-index ba1b238..35ca1ca 100644
---- a/uim/openssl.c
-+++ b/uim/openssl.c
-@@ -208,34 +208,64 @@ c_SSL_write(uim_lisp s_, uim_lisp buf_)
- static uim_lisp
- c_SSLv2_method(void)
- {
-+#ifndef OPENSSL_NO_SSL2
- return MAKE_PTR(SSLv2_method());
-+#else
-+ uim_notify_fatal(N_("uim-openssl: SSLv2_method() is not supported on this system"));
-+ return uim_scm_f();
-+#endif
- }
- static uim_lisp
- c_SSLv2_server_method(void)
- {
-+#ifndef OPENSSL_NO_SSL2
- return MAKE_PTR(SSLv2_server_method());
-+#else
-+ uim_notify_fatal(N_("uim-openssl: SSLv2_server_method() is not supported on this system"));
-+ return uim_scm_f();
-+#endif
- }
- static uim_lisp
- c_SSLv2_client_method(void)
- {
-+#ifndef OPENSSL_NO_SSL2
- return MAKE_PTR(SSLv2_client_method());
-+#else
-+ uim_notify_fatal(N_("uim-openssl: SSLv2_client_method() is not supported on this system"));
-+ return uim_scm_f();
-+#endif
- }
-
- /* SSLv3 */
- static uim_lisp
- c_SSLv3_method(void)
- {
-+#ifndef OPENSSL_NO_SSL3
- return MAKE_PTR(SSLv3_method());
-+#else
-+ uim_notify_fatal(N_("uim-openssl: SSLv3_method() is not supported on this system"));
-+ return uim_scm_f();
-+#endif
- }
- static uim_lisp
- c_SSLv3_server_method(void)
- {
-+#ifndef OPENSSL_NO_SSL3
- return MAKE_PTR(SSLv3_server_method());
-+#else
-+ uim_notify_fatal(N_("uim-openssl: SSLv3_server_method() is not supported on this system"));
-+ return uim_scm_f();
-+#endif
- }
- static uim_lisp
- c_SSLv3_client_method(void)
- {
-+#ifndef OPENSSL_NO_SSL3
- return MAKE_PTR(SSLv3_client_method());
-+#else
-+ uim_notify_fatal(N_("uim-openssl: SSLv3_client_method() is not supported on this system"));
-+ return uim_scm_f();
-+#endif
- }
-
- /* SSLv3 but can rollback to v2 */
diff --git a/app-i18n/uim/files/uim-1.8.6-qt.patch b/app-i18n/uim/files/uim-1.8.6-qt.patch
deleted file mode 100644
index 6c0cb7eee66..00000000000
--- a/app-i18n/uim/files/uim-1.8.6-qt.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/m4/ax_path_qmake4.m4
-+++ b/m4/ax_path_qmake4.m4
-@@ -23,10 +23,10 @@
- # the copyright notice and this notice are preserved.
-
- AC_DEFUN([AX_PATH_QMAKE4], [
-- ax_guessed_qt4_dirs="/usr/lib/qt4/bin:/usr/local/lib/qt4/bin:/usr/qt4/bin:/usr/local/qt4/bin:${QT4DIR}/bin:${QTDIR}/bin"
-+ ax_guessed_qt4_dirs="${QT4DIR}/bin:${QTDIR}/bin"
- AC_PROG_EGREP
-- AC_PATH_PROGS(_QMAKE4, [qmake-qt4 qmake4], [], ["$PATH:$ax_guessed_qt4_dirs"])
-- AC_PATH_PROGS(_QMAKE, [qmake], [], ["$PATH:$ax_guessed_qt4_dirs"])
-+ AC_PATH_PROGS(_QMAKE4, [qmake-qt4 qmake4], [], ["$ax_guessed_qt4_dirs:$PATH"])
-+ AC_PATH_PROGS(_QMAKE, [qmake], [], ["$ax_guessed_qt4_dirs:$PATH"])
-
- AC_CACHE_CHECK([for Qt4 version of qmake], ax_cv_path_QMAKE4, [
- ax_cv_path_QMAKE4=no
diff --git a/app-i18n/uim/files/uim-1.8.6-tinfo.patch b/app-i18n/uim/files/uim-1.8.6-tinfo.patch
deleted file mode 100644
index 51105c909f5..00000000000
--- a/app-i18n/uim/files/uim-1.8.6-tinfo.patch
+++ /dev/null
@@ -1,65 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -1058,27 +1058,25 @@
- ;;
- yes|*)
- use_uim_fep="yes"
-- AC_CHECK_LIB(curses, setupterm, FEP_LIBADD="-lcurses $FEP_LIBADD",
-- [AC_CHECK_LIB(ncurses, setupterm, FEP_LIBADD="-lncurses $FEP_LIBADD",
-- AC_MSG_WARN([fep needs setupterm in libcurses or libncurses. disabled...]);use_uim_fep="no")])
-- AC_CHECK_FUNCS(forkpty)
-- if test $ac_cv_func_forkpty = no; then
-- AC_CHECK_LIB(util, forkpty, [AC_DEFINE(HAVE_FORKPTY) FEP_LIBADD="-lutil $FEP_LIBADD"])
-- fi
-- AC_SUBST(FEP_LIBADD)
- ;;
- esac
- ],
-- [ use_uim_fep="yes"
-- AC_CHECK_LIB(curses, setupterm, FEP_LIBADD="-lcurses $FEP_LIBADD",
-- [AC_CHECK_LIB(ncurses, setupterm, FEP_LIBADD="-lncurses $FEP_LIBADD",
-- AC_MSG_WARN([fep needs setupterm in libcurses or libncurses. disabled...]);use_uim_fep="no")])
-- AC_CHECK_FUNCS(forkpty)
-- if test $ac_cv_func_forkpty = no; then
-- AC_CHECK_LIB(util, forkpty, [AC_DEFINE(HAVE_FORKPTY) FEP_LIBADD="-lutil $FEP_LIBADD"])
-- fi
-- AC_SUBST(FEP_LIBADD)
-- ])
-+ [use_uim_fep="yes"])
-+
-+if test "x$use_uim_fep" != "xno"; then
-+ PKG_CHECK_MODULES(CURSES, ncurses,
-+ [FEP_LIBADD="$CURSES_LIBS $FEP_LIBADD"],
-+ [
-+ AC_CHECK_LIB(curses, setupterm, FEP_LIBADD="-lcurses $FEP_LIBADD",
-+ [AC_CHECK_LIB(ncurses, setupterm, FEP_LIBADD="-lncurses $FEP_LIBADD",
-+ AC_MSG_WARN([fep needs setupterm in libcurses or libncurses. disabled...]);use_uim_fep="no")])
-+ ])
-+ AC_CHECK_FUNCS(forkpty)
-+ if test $ac_cv_func_forkpty = no; then
-+ AC_CHECK_LIB(util, forkpty, [AC_DEFINE(HAVE_FORKPTY) FEP_LIBADD="-lutil $FEP_LIBADD"])
-+ fi
-+ AC_SUBST(FEP_LIBADD)
-+fi
-
- AC_ARG_ENABLE(emacs,
- AC_HELP_STRING([--disable-emacs],
-@@ -1210,10 +1208,14 @@
- saved_LDFLAGS=$LDFLAGS
- CPPFLAGS="${CPPFLAGS} -I$libedit_path/include"
- LDFLAGS="${LDFLAGS} -L$libedit_path/lib"
-- AC_CHECK_LIB(curses, tgetent, LIBEDIT_LIBS="-lcurses",
-- [AC_CHECK_LIB(ncurses, tgetent, LIBEDIT_LIBS="-lncurses",
-- AC_MSG_WARN("libedit needs libcurses or libncurses. disabled...")
-- use_libedit="no")])
-+ PKG_CHECK_MODULES(CURSES, ncurses,
-+ [LIBEDIT_LIBS="$CURSES_LIBS"],
-+ [
-+ AC_CHECK_LIB(curses, tgetent, LIBEDIT_LIBS="-lcurses",
-+ [AC_CHECK_LIB(ncurses, tgetent, LIBEDIT_LIBS="-lncurses",
-+ AC_MSG_WARN("libedit needs libcurses or libncurses. disabled...")
-+ use_libedit="no")])
-+ ])
- if test "x$use_libedit" != "xno"; then
- AC_CHECK_LIB(edit, el_init,
- [LIBEDIT_LIBS="-ledit $LIBEDIT_LIBS -L$libedit_path/lib"
diff --git a/app-i18n/uim/uim-1.8.6-r1.ebuild b/app-i18n/uim/uim-1.8.6-r1.ebuild
deleted file mode 100644
index 5b032d6a9ea..00000000000
--- a/app-i18n/uim/uim-1.8.6-r1.ebuild
+++ /dev/null
@@ -1,209 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit autotools elisp-common gnome2-utils qmake-utils
-
-DESCRIPTION="A multilingual input method framework"
-HOMEPAGE="https://github.com/uim/uim"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.bz2"
-
-LICENSE="BSD GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~hppa ppc ppc64 x86"
-IUSE="X +anthy canna curl eb emacs expat libffi gtk gtk2 l10n_ja l10n_ko l10n_zh-CN l10n_zh-TW libedit libnotify m17n-lib ncurses nls skk sqlite ssl static-libs xft"
-RESTRICT="test"
-REQUIRED_USE="gtk? ( X )
- gtk2? ( X )
- xft? ( X )"
-
-CDEPEND="!dev-scheme/sigscheme
- X? (
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXft
- x11-libs/libXrender
- x11-libs/libXt
- )
- anthy? ( app-i18n/anthy )
- canna? ( app-i18n/canna )
- curl? ( net-misc/curl )
- eb? ( dev-libs/eb )
- emacs? ( >=app-editors/emacs-23.1:* )
- expat? ( dev-libs/expat )
- libffi? ( virtual/libffi )
- gtk? ( x11-libs/gtk+:3 )
- gtk2? ( x11-libs/gtk+:2 )
- libedit? ( dev-libs/libedit )
- libnotify? ( x11-libs/libnotify )
- m17n-lib? ( dev-libs/m17n-lib )
- ncurses? ( sys-libs/ncurses:0= )
- nls? ( virtual/libintl )
- skk? ( app-i18n/skk-jisyo )
- sqlite? ( dev-db/sqlite:3 )
- ssl? ( dev-libs/openssl:0 )"
-DEPEND="${CDEPEND}
- dev-util/intltool
- sys-devel/gettext
- virtual/pkgconfig
- X? ( x11-base/xorg-proto )"
-RDEPEND="${CDEPEND}
- X? (
- media-fonts/font-sony-misc
- l10n_ja? (
- || (
- media-fonts/font-jis-misc
- media-fonts/intlfonts
- )
- )
- l10n_ko? (
- || (
- media-fonts/font-daewoo-misc
- media-fonts/intlfonts
- )
- )
- l10n_zh-CN? (
- || (
- media-fonts/font-isas-misc
- media-fonts/intlfonts
- )
- )
- l10n_zh-TW? ( media-fonts/intlfonts )
- )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gentoo.patch
- "${FILESDIR}"/${P}-qt.patch
- "${FILESDIR}"/${P}-tinfo.patch
- "${FILESDIR}"/${PN}-zh-TW.patch
-)
-DOCS=( AUTHORS NEWS README RELNOTE )
-
-AT_NO_RECURSIVE="yes"
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- default
- sed -i "s:\$libedit_path/lib:/$(get_libdir):g" configure.ac
-
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- $(use_with X x)
- $(use_with anthy anthy-utf8)
- $(use_with canna)
- $(use_with curl)
- $(use_with eb)
- $(use_enable emacs)
- $(use_with emacs lispdir "${SITELISP}")
- $(use_with expat)
- $(use_with libedit)
- $(use_with libffi ffi)
- $(use_with gtk gtk3)
- $(use_with gtk2)
- $(use_with m17n-lib m17nlib)
- $(use_enable ncurses fep)
- $(use_enable nls)
- --without-qt4
- --without-qt4-immodule
- --disable-qt4-qt3support
- $(use_with skk)
- $(use_with sqlite sqlite3)
- $(use_enable ssl openssl)
- $(use_enable static-libs static)
- $(use_with xft)
- --without-anthy
- --enable-default-toolkit=$(usex gtk gtk3 $(usex gtk2 gtk))
- --disable-gnome-applet
- --disable-gnome3-applet
- --disable-kde-applet
- --disable-kde4-applet
- --without-mana
- --without-prime
- )
-
- if (use gtk || use gtk2) && (use anthy || use canna); then
- myconf+=( --enable-dict )
- else
- myconf+=( --disable-dict )
- fi
-
- if use libnotify; then
- myconf+=( --enable-notify=libnotify )
- fi
-
- if use gtk || use gtk2; then
- myconf+=( --enable-pref )
- else
- myconf+=( --disable-pref )
- fi
-
- econf "${myconf[@]}"
-}
-
-src_compile() {
- default
-
- if use emacs; then
- cd emacs
- elisp-compile *.el || die
- fi
-}
-
-src_install() {
- # bug #222677
- emake -j1 DESTDIR="${D}" install
- einstalldocs
-
- find "${ED}"/usr/$(get_libdir)/${PN} -name '*.la' -delete || die
- use static-libs || find "${ED}" -name '*.la' -delete || die
-
- insinto /etc/X11/xinit/xinput.d
- sed \
- -e "s:@EPREFIX@:${EPREFIX}:g" \
- "${FILESDIR}"/xinput-${PN} > "${T}"/${PN}.conf
- doins "${T}"/${PN}.conf
-
- if use emacs; then
- elisp-install ${PN}-el emacs/*.el{,c}
- elisp-site-file-install "${FILESDIR}"/${SITEFILE} ${PN}-el
- fi
-}
-
-pkg_postinst() {
- elog "New input method switcher has been introduced. You need to set"
- elog
- elog "% GTK_IM_MODULE=uim ; export GTK_IM_MODULE"
- elog "% QT_IM_MODULE=uim ; export QT_IM_MODULE"
- elog "% XMODIFIERS=@im=uim ; export XMODIFIERS"
- elog
- elog "If you would like to use uim-anthy as default input method, put"
- elog "(define default-im-name 'anthy)"
- elog "to your ~/.uim."
- elog
- elog "All input methods can be found by running uim-im-switcher-gtk, "
- elog "uim-im-switcher-gtk3."
-
- if use emacs; then
- elisp-site-regen
- echo
- elog "uim is autoloaded with Emacs with a minimal set of features:"
- elog "There is no keybinding defined to call it directly, so please"
- elog "create one yourself and choose an input method."
- elog "Integration with LEIM is not done with this ebuild, please have"
- elog "a look at the documentation how to achieve this."
- fi
- use gtk && gnome2_query_immodules_gtk3
- use gtk2 && gnome2_query_immodules_gtk2
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- use gtk && gnome2_query_immodules_gtk3
- use gtk2 && gnome2_query_immodules_gtk2
-}
diff --git a/app-i18n/uim/uim-1.8.6-r2.ebuild b/app-i18n/uim/uim-1.8.6-r2.ebuild
deleted file mode 100644
index 153a4f27242..00000000000
--- a/app-i18n/uim/uim-1.8.6-r2.ebuild
+++ /dev/null
@@ -1,213 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit autotools elisp-common gnome2-utils qmake-utils
-
-DESCRIPTION="A multilingual input method framework"
-HOMEPAGE="https://github.com/uim/uim"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.bz2"
-
-LICENSE="BSD GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
-IUSE="X +anthy canna curl eb emacs expat libffi gtk gtk2 l10n_ja l10n_ko l10n_zh-CN l10n_zh-TW libedit libnotify libressl m17n-lib ncurses nls skk sqlite ssl static-libs xft"
-RESTRICT="test"
-REQUIRED_USE="gtk? ( X )
- gtk2? ( X )
- xft? ( X )"
-
-CDEPEND="!dev-scheme/sigscheme
- X? (
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXft
- x11-libs/libXrender
- x11-libs/libXt
- )
- anthy? ( app-i18n/anthy )
- canna? ( app-i18n/canna )
- curl? ( net-misc/curl )
- eb? ( dev-libs/eb )
- emacs? ( >=app-editors/emacs-23.1:* )
- expat? ( dev-libs/expat )
- libffi? ( virtual/libffi )
- gtk? ( x11-libs/gtk+:3 )
- gtk2? ( x11-libs/gtk+:2 )
- libedit? ( dev-libs/libedit )
- libnotify? ( x11-libs/libnotify )
- m17n-lib? ( dev-libs/m17n-lib )
- ncurses? ( sys-libs/ncurses:0= )
- nls? ( virtual/libintl )
- skk? ( app-i18n/skk-jisyo )
- sqlite? ( dev-db/sqlite:3 )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )"
-DEPEND="${CDEPEND}
- dev-util/intltool
- sys-devel/gettext
- virtual/pkgconfig
- X? ( x11-base/xorg-proto )"
-RDEPEND="${CDEPEND}
- X? (
- media-fonts/font-sony-misc
- l10n_ja? (
- || (
- media-fonts/font-jis-misc
- media-fonts/intlfonts
- )
- )
- l10n_ko? (
- || (
- media-fonts/font-daewoo-misc
- media-fonts/intlfonts
- )
- )
- l10n_zh-CN? (
- || (
- media-fonts/font-isas-misc
- media-fonts/intlfonts
- )
- )
- l10n_zh-TW? ( media-fonts/intlfonts )
- )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gentoo.patch
- "${FILESDIR}"/${P}-libressl.patch
- "${FILESDIR}"/${P}-qt.patch
- "${FILESDIR}"/${P}-tinfo.patch
- "${FILESDIR}"/${PN}-zh-TW.patch
-)
-DOCS=( AUTHORS NEWS README RELNOTE )
-
-AT_NO_RECURSIVE="yes"
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- default
- sed -i "s:\$libedit_path/lib:/$(get_libdir):g" configure.ac
-
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- $(use_with X x)
- $(use_with anthy anthy-utf8)
- $(use_with canna)
- $(use_with curl)
- $(use_with eb)
- $(use_enable emacs)
- $(use_with emacs lispdir "${SITELISP}")
- $(use_with expat)
- $(use_with libedit)
- $(use_with libffi ffi)
- $(use_with gtk gtk3)
- $(use_with gtk2)
- $(use_with m17n-lib m17nlib)
- $(use_enable ncurses fep)
- $(use_enable nls)
- --without-qt4
- --without-qt4-immodule
- --disable-qt4-qt3support
- $(use_with skk)
- $(use_with sqlite sqlite3)
- $(use_enable ssl openssl)
- $(use_enable static-libs static)
- $(use_with xft)
- --without-anthy
- --enable-default-toolkit=$(usex gtk gtk3 $(usex gtk2 gtk))
- --disable-gnome-applet
- --disable-gnome3-applet
- --disable-kde-applet
- --disable-kde4-applet
- --without-mana
- --without-prime
- )
-
- if (use gtk || use gtk2) && (use anthy || use canna); then
- myconf+=( --enable-dict )
- else
- myconf+=( --disable-dict )
- fi
-
- if use libnotify; then
- myconf+=( --enable-notify=libnotify )
- fi
-
- if use gtk || use gtk2; then
- myconf+=( --enable-pref )
- else
- myconf+=( --disable-pref )
- fi
-
- econf "${myconf[@]}"
-}
-
-src_compile() {
- default
-
- if use emacs; then
- cd emacs
- elisp-compile *.el || die
- fi
-}
-
-src_install() {
- # bug #222677
- emake -j1 DESTDIR="${D}" install
- einstalldocs
-
- find "${ED}"/usr/$(get_libdir)/${PN} -name '*.la' -delete || die
- use static-libs || find "${ED}" -name '*.la' -delete || die
-
- insinto /etc/X11/xinit/xinput.d
- sed \
- -e "s:@EPREFIX@:${EPREFIX}:g" \
- "${FILESDIR}"/xinput-${PN} > "${T}"/${PN}.conf
- doins "${T}"/${PN}.conf
-
- if use emacs; then
- elisp-install ${PN}-el emacs/*.el{,c}
- elisp-site-file-install "${FILESDIR}"/${SITEFILE} ${PN}-el
- fi
-}
-
-pkg_postinst() {
- elog "New input method switcher has been introduced. You need to set"
- elog
- elog "% GTK_IM_MODULE=uim ; export GTK_IM_MODULE"
- elog "% QT_IM_MODULE=uim ; export QT_IM_MODULE"
- elog "% XMODIFIERS=@im=uim ; export XMODIFIERS"
- elog
- elog "If you would like to use uim-anthy as default input method, put"
- elog "(define default-im-name 'anthy)"
- elog "to your ~/.uim."
- elog
- elog "All input methods can be found by running uim-im-switcher-gtk, "
- elog "uim-im-switcher-gtk3."
-
- if use emacs; then
- elisp-site-regen
- echo
- elog "uim is autoloaded with Emacs with a minimal set of features:"
- elog "There is no keybinding defined to call it directly, so please"
- elog "create one yourself and choose an input method."
- elog "Integration with LEIM is not done with this ebuild, please have"
- elog "a look at the documentation how to achieve this."
- fi
- use gtk && gnome2_query_immodules_gtk3
- use gtk2 && gnome2_query_immodules_gtk2
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- use gtk && gnome2_query_immodules_gtk3
- use gtk2 && gnome2_query_immodules_gtk2
-}