summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-27 18:46:00 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-27 19:13:11 +0200
commit5a598bfbb86452374601403ebbddaddbed623797 (patch)
treef2e034c16d52ef16490c206a66f838f5cdec68e3
parentdev-python/setuptools: Remove SETUPTOOLS_USE_DISTUTILS=stdlib hack (diff)
downloadgentoo-5a598bfbb86452374601403ebbddaddbed623797.tar.gz
gentoo-5a598bfbb86452374601403ebbddaddbed623797.tar.bz2
gentoo-5a598bfbb86452374601403ebbddaddbed623797.zip
dev-python/virtualenv: Enable py3.12 on 20.22.0 because ~loong
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/virtualenv/virtualenv-20.22.0.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/virtualenv/virtualenv-20.22.0.ebuild b/dev-python/virtualenv/virtualenv-20.22.0.ebuild
index 3d4999549c4e..ded73646ae95 100644
--- a/dev-python/virtualenv/virtualenv-20.22.0.ebuild
+++ b/dev-python/virtualenv/virtualenv-20.22.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 pypi
@@ -89,12 +89,15 @@ python_test() {
'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3-64-bin-]'
'tests/unit/discovery/py_info/test_py_info_exe_based_of.py::test_discover_ok[python-3--bin-]'
)
- [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ [[ ${EPYTHON} == python3.1[12] ]] && EPYTEST_DESELECT+=(
# TODO
tests/unit/discovery/py_info/test_py_info.py::test_py_info_setuptools
tests/unit/discovery/py_info/test_py_info.py::test_custom_venv_install_scheme_is_prefered
tests/unit/discovery/py_info/test_py_info.py::test_fallback_existent_system_executable
)
+ [[ ${EPYTHON} == python3.12 ]] && EPYTEST_DESELECT+=(
+ tests/unit/create/via_global_ref/test_build_c_ext.py
+ )
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest -p flaky -p freezegun -p pytest_mock