summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-07-04 15:14:27 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-07-04 16:11:55 -0700
commit5b075422250d1ced0c6d4346ffe32412b5f4ed05 (patch)
tree99b8e954eddea979a96b1b63fd4ae54e2460cf20
parentapp-emulation/wine-staging: Drop old (diff)
downloadgentoo-5b075422250d1ced0c6d4346ffe32412b5f4ed05.tar.gz
gentoo-5b075422250d1ced0c6d4346ffe32412b5f4ed05.tar.bz2
gentoo-5b075422250d1ced0c6d4346ffe32412b5f4ed05.zip
sys-fs/zfs: update live ebuild, add pam useflag
for controlling installation of pam_zfs_key module requires manual configuration, pam files are not provided this time Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--sys-fs/zfs/metadata.xml1
-rw-r--r--sys-fs/zfs/zfs-9999.ebuild8
2 files changed, 7 insertions, 2 deletions
diff --git a/sys-fs/zfs/metadata.xml b/sys-fs/zfs/metadata.xml
index 0b1da3a015bf..85d50d081aff 100644
--- a/sys-fs/zfs/metadata.xml
+++ b/sys-fs/zfs/metadata.xml
@@ -11,6 +11,7 @@
</maintainer>
<use>
<flag name="kernel-builtin">Disable dependency on sys-fs/zfs-kmod under the assumption that ZFS is part of the kernel source tree</flag>
+ <flag name="pam">Install zfs_key pam module, for automatically loading zfs encryption keys for home datasets</flag>
<flag name="rootfs">Enable dependencies required for booting off a pool containing a rootfs</flag>
<flag name="test-suite">Install regression test suite</flag>
</use>
diff --git a/sys-fs/zfs/zfs-9999.ebuild b/sys-fs/zfs/zfs-9999.ebuild
index c7cc180b9ea0..b388cd53e3a0 100644
--- a/sys-fs/zfs/zfs-9999.ebuild
+++ b/sys-fs/zfs/zfs-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=7
DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python3_{6,7} )
-inherit autotools bash-completion-r1 flag-o-matic linux-info distutils-r1 systemd toolchain-funcs udev usr-ldscript
+inherit autotools bash-completion-r1 distutils-r1 flag-o-matic linux-info pam systemd toolchain-funcs udev usr-ldscript
DESCRIPTION="Userland utilities for ZFS Linux kernel module"
HOMEPAGE="https://github.com/openzfs/zfs"
@@ -21,7 +21,7 @@ fi
LICENSE="BSD-2 CDDL MIT"
SLOT="0"
-IUSE="custom-cflags debug kernel-builtin libressl python +rootfs test-suite static-libs"
+IUSE="custom-cflags debug kernel-builtin libressl pam python +rootfs test-suite static-libs"
DEPEND="
${PYTHON_DEPS}
@@ -32,6 +32,7 @@ DEPEND="
virtual/libudev[static-libs(-)?]
libressl? ( dev-libs/libressl:0=[static-libs?] )
!libressl? ( dev-libs/openssl:0=[static-libs?] )
+ pam? ( sys-libs/pam[static-libs?] )
python? (
virtual/python-cffi[${PYTHON_USEDEP}]
)
@@ -129,10 +130,13 @@ src_configure() {
--with-linux="${KV_DIR}"
--with-linux-obj="${KV_OUT_DIR}"
--with-udevdir="$(get_udevdir)"
+ --with-pamconfigsdir=/dev/null # debian configs
+ --with-pammoduledir="$(getpam_mod_dir)"
--with-python="${EPYTHON}"
--with-systemdunitdir="$(systemd_get_systemunitdir)"
--with-systemdpresetdir="${EPREFIX}/lib/systemd/system-preset"
$(use_enable debug)
+ $(use_enable pam)
$(use_enable python pyzfs)
$(use_enable static-libs static)
)