summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-20 17:17:51 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-20 17:27:38 +0200
commit5b0d5d2fccfb4b99e668aaa0b6a1f9e28c0d6534 (patch)
tree845fa8e80671d0f7b045bca695decc89b5a61cff
parentdev-ros/rqt_dep: bump to 0.4.9 (diff)
downloadgentoo-5b0d5d2fccfb4b99e668aaa0b6a1f9e28c0d6534.tar.gz
gentoo-5b0d5d2fccfb4b99e668aaa0b6a1f9e28c0d6534.tar.bz2
gentoo-5b0d5d2fccfb4b99e668aaa0b6a1f9e28c0d6534.zip
dev-ros/rospack: bump to 2.5.1
Package-Manager: Portage-2.3.43, Repoman-2.3.10
-rw-r--r--dev-ros/rospack/Manifest1
-rw-r--r--dev-ros/rospack/rospack-2.5.1.ebuild33
-rw-r--r--dev-ros/rospack/rospack-9999.ebuild2
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/rospack/Manifest b/dev-ros/rospack/Manifest
index 7c5ab380bb95..6ff3968e4a2e 100644
--- a/dev-ros/rospack/Manifest
+++ b/dev-ros/rospack/Manifest
@@ -1,2 +1,3 @@
DIST rospack-2.4.3.tar.gz 72327 BLAKE2B b154ce307ed95403382030c0fe14bd6296174289333fea83356a4f77add0fe2a1e48c8e2b6ee037def2e823f61a7b6df4ea62fd9a6f84433f12247003823f86f SHA512 4396ef24d0bd826235d7ac0da8a0b502557ecc0086eadcda96d44779ed5d8134e9a53cd861ee135a4b1da53074bdcf906dc4cb6ea0c36798326c17788ee1e2be
DIST rospack-2.5.0.tar.gz 72447 BLAKE2B 820e893544b38464bfc63b516697fac9e5875bfffb0922aa0da4b572af5e47a0f4a63134786131fd0ae97751916748b0a1e6af6ca29897ef72759b601bffb551 SHA512 8c9ed4566aa1456b2dd3c4249f7023121d21ee99427d0ef78a7237fbe418f333859091b66870572d5a80995ebda9d5208643ae92213827af40c63b49be4a2560
+DIST rospack-2.5.1.tar.gz 72488 BLAKE2B 3e05ce597bbe39bffbafb898e1cbcd02e1a45d23cddec47f0bda2504937f2a288658ae41d7b6a30514064534417ff26fc919af4567c5aca62ae33752c26f56e8 SHA512 696060afe914f786ee1ef2960ef7608b52df90712936c86d4f4ebe380c23ca21b6f1a283e5903e851ed7c903c457ad0432e50e8f759f4d536dd6970b77b8183a
diff --git a/dev-ros/rospack/rospack-2.5.1.ebuild b/dev-ros/rospack/rospack-2.5.1.ebuild
new file mode 100644
index 000000000000..69cbb346fe5e
--- /dev/null
+++ b/dev-ros/rospack/rospack-2.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/rospack"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Retrieves information about ROS packages available on the filesystem"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-libs/boost:=
+ >=dev-libs/tinyxml2-5:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ >=dev-ros/cmake_modules-0.4.1
+ test? (
+ dev-cpp/gtest
+ dev-python/nose
+ )"
+RDEPEND="${RDEPEND}
+ dev-ros/ros_environment"
+
+PATCHES=(
+ "${FILESDIR}/gentoo.patch"
+)
diff --git a/dev-ros/rospack/rospack-9999.ebuild b/dev-ros/rospack/rospack-9999.ebuild
index cf86c350e8c7..69cbb346fe5e 100644
--- a/dev-ros/rospack/rospack-9999.ebuild
+++ b/dev-ros/rospack/rospack-9999.ebuild
@@ -25,6 +25,8 @@ DEPEND="${RDEPEND}
dev-cpp/gtest
dev-python/nose
)"
+RDEPEND="${RDEPEND}
+ dev-ros/ros_environment"
PATCHES=(
"${FILESDIR}/gentoo.patch"