summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2017-11-06 21:20:57 +0000
committerUltrabug <ultrabug@gentoo.org>2017-11-21 22:15:48 +0100
commit5b48124d95a4b6ef85c525a9958ccb801db7fddc (patch)
treefd1c9e384493e6411c2f24dc876b954aed0264df
parentdev-db/mongodb: require <dev-util/scons-3 (diff)
downloadgentoo-5b48124d95a4b6ef85c525a9958ccb801db7fddc.tar.gz
gentoo-5b48124d95a4b6ef85c525a9958ccb801db7fddc.tar.bz2
gentoo-5b48124d95a4b6ef85c525a9958ccb801db7fddc.zip
app-admin/mongo-tools: bump to 3.2.17
-rw-r--r--app-admin/mongo-tools/Manifest1
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.2.17.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index e9b196bcdb74..e9f2d2ba0ae9 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -3,4 +3,5 @@ DIST mongo-tools-3.0.15.tar.gz 2413131 SHA256 9e1a936b42eff999a83afc3885faee0c64
DIST mongo-tools-3.2.12.tar.gz 2712079 SHA256 cda5e869b9233d591e91cac0b4c709a2e71dcabd9ac6bcc8b33d906ce3b13afd SHA512 66f7beb85a83ad6a217e65bba97ace6ad0bf84688f40e598e5fb1cf4bbe481b4069e1247d6829f8d06c8230d33c3e0c8bd8465a975576cad584065c361b6fb72 WHIRLPOOL 46123dc3c97fdf20ff94ac373e774932bd30aca677047fe3366653aaab269bf6d7e59cb420cf1e5716558fa959cb3649ee359cc27932bac276e6d24d2eea43b1
DIST mongo-tools-3.2.13.tar.gz 2712076 SHA256 a855eb0141445e34ff3b01807b016467519c390fce79f3566000b5aaecb65d72 SHA512 caa0ba0f1452a16921c187cb407258326324b7222af91b1cd1b870ee2c9e6909d4fa94087a6da148a807f75b40f0bb97808a85804134d53cdab7970d8adf59f8 WHIRLPOOL e2fb38cc8a35ab7c9461f680a2bf0647b5cb5d1225978b7321e6c4227b02ae3cae93e5f2a105f188f3329b0f0f8741e9a0c5439f37196ca875b049d3a91836d3
DIST mongo-tools-3.2.16.tar.gz 2720003 SHA256 1cd699f0e45b0b3afb0cfc7014258fb69e93c98e254ef9ef1605cd2de0b56d4c SHA512 61c8cfd04a36e329c3573b73945d20a5623e1aa0a3430b309530e85e4289a27a46a850ec48ede7f04e66e67e23745ef26f5f4ddcf68ffeb647128e3d2526a724 WHIRLPOOL 2d2855f578f15e9afd133f6b24b23bd5d6a20516c96f665581223ca1c9a472ead6634749db46b55a1351a8b63923531046ab83a262ec54f439ccf008cb854f9e
+DIST mongo-tools-3.2.17.tar.gz 2719970 SHA256 51eb688b294ada69e8aad09c81d338705196d5e1ece7e10409e9da032d3ce3de SHA512 62c2540027e07b8276621e08d13657864d16021030e3c8f9bc0d351454319d448f889cf6a48b8467ea3270365376ed0c3beb42ceae3f28357910148c6b4054b2 WHIRLPOOL 7d8ee216aca92013b56012bab1f619408edfefe2b32c78ec21b378b07aa0c7366fe4f0150eb6116be0d8ba33ec2e60b627480d889187e927dc9e4eb37671719d
DIST mongo-tools-3.4.10.tar.gz 4719399 SHA256 adaff068b7f340866dcd2085222ee4f879b26cd98a3010652fea4d53ffb8e0c7 SHA512 b861bb3fb1a32c3aa2efefcf6a13bb6d4783ac1a9b006c477fd04deb338cbf6b7adc3944bc6919513b92bd96b8500813ff4af49c9dec0719ebd2fdaa99bc39a5 WHIRLPOOL e484cec2036b1d9d88c3fa3b8142a681e0ba1d96f9a8d772fb7c7035033dac6d4e40fe154042dc8016b3a31ed09dce0081c7bc9b7d2c9f420cc2286eb47ccd2e
diff --git a/app-admin/mongo-tools/mongo-tools-3.2.17.ebuild b/app-admin/mongo-tools/mongo-tools-3.2.17.ebuild
new file mode 100644
index 000000000000..1da373e5820b
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-3.2.17.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.org"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sasl ssl"
+
+RDEPEND="!<dev-db/mongodb-3.0.0"
+DEPEND="${RDEPEND}
+ dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl:0= )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # do not substitute version because it uses git
+ sed -i '/^sed/,+3d' build.sh || die
+ sed -i '/^mv/d' build.sh || die
+
+ # build pie to avoid text relocations wrt #582854
+ # skip on ppc64 wrt #610984
+ if ! use ppc64; then
+ sed -i 's/\(go build\)/\1 -buildmode=pie/g' build.sh || die
+ fi
+
+ # ensure we use bash wrt #582906
+ sed -i 's@/bin/sh@/bin/bash@g' build.sh || die
+
+ default
+}
+
+src_compile() {
+ local myconf=()
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ ./build.sh ${myconf[@]} || die "build failed"
+}
+
+src_install() {
+ dobin bin/*
+}