summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2020-10-25 15:02:10 +0100
committerCédric Krier <cedk@gentoo.org>2020-10-25 15:02:10 +0100
commit5b507d16be20dd336748a03d14ba30cb1c15dcb4 (patch)
treeea5f161121d87eb54b79a593cd501b8063759067
parentpackage.mask: =sys-apps/opentmpfiles-0.3 mask. (diff)
downloadgentoo-5b507d16be20dd336748a03d14ba30cb1c15dcb4.tar.gz
gentoo-5b507d16be20dd336748a03d14ba30cb1c15dcb4.tar.bz2
gentoo-5b507d16be20dd336748a03d14ba30cb1c15dcb4.zip
dev-util/cookiecutter: Set DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/748900 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Cédric Krier <cedk@gentoo.org>
-rw-r--r--dev-util/cookiecutter/cookiecutter-1.7.2-r1.ebuild4
-rw-r--r--dev-util/cookiecutter/cookiecutter-1.7.2.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/dev-util/cookiecutter/cookiecutter-1.7.2-r1.ebuild b/dev-util/cookiecutter/cookiecutter-1.7.2-r1.ebuild
index a5047470128..8babf1fe7ba 100644
--- a/dev-util/cookiecutter/cookiecutter-1.7.2-r1.ebuild
+++ b/dev-util/cookiecutter/cookiecutter-1.7.2-r1.ebuild
@@ -4,6 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6..8} )
+DISTUTILS_USE_SETUPTOOLS="rdepend"
inherit distutils-r1
@@ -27,8 +28,7 @@ RDEPEND=">=dev-python/binaryornot-0.4.4[${PYTHON_USEDEP}]
>=dev-python/python-slugify-4.0.0[${PYTHON_USEDEP}]
>=dev-python/requests-2.23.0[${PYTHON_USEDEP}]
>=dev-python/six-1.10[${PYTHON_USEDEP}]
- <dev-python/markupsafe-2.0.0[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ <dev-python/markupsafe-2.0.0[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? (
diff --git a/dev-util/cookiecutter/cookiecutter-1.7.2.ebuild b/dev-util/cookiecutter/cookiecutter-1.7.2.ebuild
index e8a6a081c8b..f5576d37acd 100644
--- a/dev-util/cookiecutter/cookiecutter-1.7.2.ebuild
+++ b/dev-util/cookiecutter/cookiecutter-1.7.2.ebuild
@@ -4,6 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6..8} )
+DISTUTILS_USE_SETUPTOOLS="rdepend"
inherit distutils-r1
@@ -27,8 +28,7 @@ RDEPEND=">=dev-python/binaryornot-0.4.4[${PYTHON_USEDEP}]
dev-python/python-slugify[${PYTHON_USEDEP}]
>=dev-python/requests-2.23.0[${PYTHON_USEDEP}]
>=dev-python/six-1.10[${PYTHON_USEDEP}]
- <dev-python/markupsafe-2.0.0[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ <dev-python/markupsafe-2.0.0[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? (