summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-19 12:46:08 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-19 12:48:08 +0200
commit5b5328170828df598035b475b4ce4d6e87eed1da (patch)
tree3b84440b416d97f51455f9e08217ce48ed7c1e12
parentapp-dicts/libydpdict: Version 1.0.4 (diff)
downloadgentoo-5b5328170828df598035b475b4ce4d6e87eed1da.tar.gz
gentoo-5b5328170828df598035b475b4ce4d6e87eed1da.tar.bz2
gentoo-5b5328170828df598035b475b4ce4d6e87eed1da.zip
app-dicts/ydpdict: Version 1.0.3
Package-Manager: Portage-3.0.3, Repoman-3.0.0 Closes: https://bugs.gentoo.org/show_bug.cgi?id=690938 Closes: https://bugs.gentoo.org/show_bug.cgi?id=707730 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--app-dicts/ydpdict/Manifest1
-rw-r--r--app-dicts/ydpdict/files/ydpdict-1.0.3-tinfo.patch10
-rw-r--r--app-dicts/ydpdict/ydpdict-1.0.3.ebuild58
3 files changed, 69 insertions, 0 deletions
diff --git a/app-dicts/ydpdict/Manifest b/app-dicts/ydpdict/Manifest
index 2961d2c49020..b47f149e45df 100644
--- a/app-dicts/ydpdict/Manifest
+++ b/app-dicts/ydpdict/Manifest
@@ -1 +1,2 @@
DIST ydpdict-1.0.2.tar.gz 363774 BLAKE2B 0ca86e0180af559f9440f8a598672e5e321d84f37725f0233ba0d666119f20308c0229fd1dd0197a8c86733af17f1cce53b990c63b260673871ab6658d88a5c5 SHA512 b2395d88e289171daae3aa47d9c70a2ca1c7b3a3998c1a9751c56e1dc8d17138bc38a172581edcad02c35d5252041c6942a3c416a632def6121072650bcb7e61
+DIST ydpdict-1.0.3.tar.gz 185721 BLAKE2B 1db80dc20dd6d71c4b7fed2051bbfae1021fd1ea15ca1f993e8e095912fbcc8d599d8f480143d185fd11c6a1414d7f29ae67a9f5cffda624b434d198cddc5c68 SHA512 ca50c485f10aa4c4691a27a474a5ae814be3bb183b4927728f14de67af1e11a281e5272fc5777d6573e69dd00d3da2223b78d729132764338c92489f20eb17e8
diff --git a/app-dicts/ydpdict/files/ydpdict-1.0.3-tinfo.patch b/app-dicts/ydpdict/files/ydpdict-1.0.3-tinfo.patch
new file mode 100644
index 000000000000..30c5ddedfdd3
--- /dev/null
+++ b/app-dicts/ydpdict/files/ydpdict-1.0.3-tinfo.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -24,6 +24,7 @@
+ AC_CHECK_HEADER([ncursesw/ncurses.h], [have_ncursesw_ncurses_h=yes])
+ AC_CHECK_HEADER([curses.h], [have_curses_h=yes])
+ AC_CHECK_LIB([ncursesw], [initscr], [have_libncursesw=yes])
++AC_SEARCH_LIBS([keypad],[tinfow])
+
+ AC_MSG_CHECKING([for Unicode-aware ncurses])
+
diff --git a/app-dicts/ydpdict/ydpdict-1.0.3.ebuild b/app-dicts/ydpdict/ydpdict-1.0.3.ebuild
new file mode 100644
index 000000000000..edd45d3eab31
--- /dev/null
+++ b/app-dicts/ydpdict/ydpdict-1.0.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Interface for the Collins Dictionary"
+HOMEPAGE="https://github.com/wojtekka/ydpdict"
+SRC_URI="https://github.com/wojtekka/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ao"
+
+RDEPEND="
+ app-dicts/libydpdict
+ sys-libs/ncurses[unicode]
+ ao? ( media-libs/libao )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+DOCS=(
+ README.md
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.3-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with ao libao)
+}
+
+src_install() {
+ dodir "/etc"
+ default
+}
+
+pkg_postinst() {
+ echo
+ elog "Note that to use this program you'll need the original Collins Dictionary"
+ elog "datafiles (dict100.*, dict101.*). These can be found in the Dabasase/"
+ elog "directory of the Windows version of the Collins dictionary. Once you obtain"
+ elog "the files, put them into /usr/share/ydpdict"
+ elog
+ elog "Some configuration options can be set in /etc/ydpdict.conf"
+ echo
+}