summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Norris <briannorris@chromium.org>2019-06-10 17:18:40 -0700
committerRick Farina <zerochaos@gentoo.org>2019-06-10 21:18:14 -0400
commit5b6759c261091a763379979a40fc9cedae86bf92 (patch)
tree0d2839956eb99bef46737f62cf6bddad578a90c7
parentdev-util/bazel: Bump to version 0.26.1 (diff)
downloadgentoo-5b6759c261091a763379979a40fc9cedae86bf92.tar.gz
gentoo-5b6759c261091a763379979a40fc9cedae86bf92.tar.bz2
gentoo-5b6759c261091a763379979a40fc9cedae86bf92.zip
net-wireless/wpa_supplicant: support USE="-smartcard -ap -wps"
These are enabled in the defconfig and need to be forced off here. Bug: https://bugs.gentoo.org/687838 Signed-off-by: Brian Norris <briannorris@chromium.org> Signed-off-by: Rick Farina <zerochaos@gentoo.org>
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-2.8-r1.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-2.8-r1.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-2.8-r1.ebuild
index 52bb7374068..b1b3a219ec3 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-2.8-r1.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-2.8-r1.ebuild
@@ -237,6 +237,8 @@ src_configure() {
if use smartcard ; then
Kconfig_style_config SMARTCARD
+ else
+ Kconfig_style_config SMARTCARD n
fi
if use tdls ; then
@@ -281,6 +283,8 @@ src_configure() {
Kconfig_style_config WPS_UPNP
# Near Field Communication
Kconfig_style_config WPS_NFC
+ else
+ Kconfig_style_config WPS n
fi
# Wi-Fi Direct (WiDi)
@@ -292,6 +296,8 @@ src_configure() {
# Access Point Mode
if use ap ; then
Kconfig_style_config AP
+ else
+ Kconfig_style_config AP n
fi
# Enable essentials for AP/P2P