summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-18 23:19:02 +0000
committerSam James <sam@gentoo.org>2020-09-18 23:25:00 +0000
commit5bffd74cd9fafa37de16fe2e30090b80b677b575 (patch)
tree27f92bc89c47205a0a9f447769f621d5ec24dda6
parentnet-analyzer/ettercap: stable 0.8.3.1 for sparc (diff)
downloadgentoo-5bffd74cd9fafa37de16fe2e30090b80b677b575.tar.gz
gentoo-5bffd74cd9fafa37de16fe2e30090b80b677b575.tar.bz2
gentoo-5bffd74cd9fafa37de16fe2e30090b80b677b575.zip
sci-libs/openblas: bump to 0.3.10
Closes: https://bugs.gentoo.org/727944 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-libs/openblas/Manifest1
-rw-r--r--sci-libs/openblas/files/openblas-0.3.10-dont-clobber-fflags.patch26
-rw-r--r--sci-libs/openblas/openblas-0.3.10.ebuild143
3 files changed, 170 insertions, 0 deletions
diff --git a/sci-libs/openblas/Manifest b/sci-libs/openblas/Manifest
index 25f4e19af1a4..e9163333248e 100644
--- a/sci-libs/openblas/Manifest
+++ b/sci-libs/openblas/Manifest
@@ -1 +1,2 @@
+DIST openblas-0.3.10.tar.gz 12246979 BLAKE2B 507aa3f058b841f477720cff98480afda5c3e236b688fb1a12ff45ce20c42c6e84c786d62a5db7e6de6d133d40286e58777fcb51d6542b7030629d55ba12086f SHA512 64a5f983b2f6e02cdb6e0f14433498cc5daa1ccfb49246f7a2dcd38f9982fa608f2abea069fe0e35012af8c1441c43d1f6418eaccd40795f5002fed1c36ce05d
DIST openblas-0.3.9.tar.gz 12189745 BLAKE2B 3cc4c6a403d6a52845cf4ff8cef254f57587e17e3d09bfb6ed7c02ad06a6002e50b340177c73a944c2a621c12b7f494c516025751c194d019662c0b4db17f4dc SHA512 c6b8ee465f1cf53b37f21ec3ff9a28d5cafe20fec59d8c1bff5923a9e1989dfa5ae8c032a5d43988fe7722ed08c64c7957a3d30e6ae917e2e7aa2977a91e67a3
diff --git a/sci-libs/openblas/files/openblas-0.3.10-dont-clobber-fflags.patch b/sci-libs/openblas/files/openblas-0.3.10-dont-clobber-fflags.patch
new file mode 100644
index 000000000000..4890b7377ab5
--- /dev/null
+++ b/sci-libs/openblas/files/openblas-0.3.10-dont-clobber-fflags.patch
@@ -0,0 +1,26 @@
+Rebased version of previous patch below.
+----
+From 05c96dad9b26cc1f00831661dc55139dcc9d5680 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Thu, 11 Jun 2020 18:32:17 -0400
+Subject: [PATCH 1/1] Makefile: don't clobber fortran flags while building
+ lapack.
+
+When a user has the FFLAGS environment variable set, it clobbers the
+flags used to compile lapack. This can lead to "rare and hard to
+reproduce crashes" or test failures, as we have observed in Gentoo.
+
+Issue: https://github.com/xianyi/OpenBLAS/issues/2657
+diff --git a/Makefile b/Makefile
+index e113026..dd8b655 100644
+--- a/Makefile
++++ b/Makefile
+@@ -263,7 +263,7 @@ prof_lapack : lapack_prebuild
+ lapack_prebuild :
+ ifeq ($(NOFORTRAN), $(filter 0,$(NOFORTRAN)))
+ -@echo "FC = $(FC)" > $(NETLIB_LAPACK_DIR)/make.inc
+- -@echo "FFLAGS = $(LAPACK_FFLAGS)" >> $(NETLIB_LAPACK_DIR)/make.inc
++ -@echo "override FFLAGS = $(LAPACK_FFLAGS)" >> $(NETLIB_LAPACK_DIR)/make.inc
+ -@echo "FFLAGS_DRV = $(LAPACK_FFLAGS)" >> $(NETLIB_LAPACK_DIR)/make.inc
+ -@echo "POPTS = $(LAPACK_FPFLAGS)" >> $(NETLIB_LAPACK_DIR)/make.inc
+ -@echo "FFLAGS_NOOPT = -O0 $(LAPACK_NOOPT)" >> $(NETLIB_LAPACK_DIR)/make.inc
diff --git a/sci-libs/openblas/openblas-0.3.10.ebuild b/sci-libs/openblas/openblas-0.3.10.ebuild
new file mode 100644
index 000000000000..9d96c6fa9fd0
--- /dev/null
+++ b/sci-libs/openblas/openblas-0.3.10.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic fortran-2 toolchain-funcs
+
+DESCRIPTION="Optimized BLAS library based on GotoBLAS2"
+HOMEPAGE="http://xianyi.github.com/OpenBLAS/"
+SRC_URI="https://github.com/xianyi/OpenBLAS/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="dynamic eselect-ldso index-64bit openmp pthread test"
+REQUIRED_USE="?? ( openmp pthread )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ eselect-ldso? ( >=app-eselect/eselect-blas-0.2
+ !app-eselect/eselect-cblas
+ >=app-eselect/eselect-lapack-0.2 )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/shared-blas-lapack.patch"
+ "${FILESDIR}/${PN}-0.3.10-dont-clobber-fflags.patch"
+)
+
+pkg_setup() {
+ fortran-2_pkg_setup
+ use openmp && tc-check-openmp
+
+ # We need to filter these while building the library, and not just
+ # while building the test suite. Will hopefully get fixed upstream:
+ # https://github.com/xianyi/OpenBLAS/issues/2657
+ use test && filter-flags "-fbounds-check" "-fcheck=bounds" "-fcheck=all"
+
+ export CC=$(tc-getCC) FC=$(tc-getFC)
+
+ use dynamic && \
+ export DYNAMIC_ARCH=1 TARGET=GENERIC NUM_THREADS=64 NO_AFFINITY=1
+
+ # disable submake with -j
+ export MAKE_NB_JOBS=-1
+
+ # Set these to "nothing" to prevent the default optimization flags
+ # from being added in Makefile.system.
+ export COMMON_OPT=" " FCOMMON_OPT=" "
+
+ USE_THREAD=0
+ if use openmp; then
+ USE_THREAD=1; USE_OPENMP=1;
+ elif use pthread; then
+ USE_THREAD=1; USE_OPENMP=0;
+ fi
+ export USE_THREAD USE_OPENMP
+
+ export PREFIX="${EPREFIX}/usr"
+}
+
+src_unpack() {
+ default
+
+ mv "${WORKDIR}"/*OpenBLAS* "${S}" || die
+
+ if use index-64bit; then
+ cp -aL "${S}" "${S}-index-64bit" || die
+ fi
+}
+
+src_compile() {
+ # We have to try extra hard to override AR for now.
+ # https://github.com/xianyi/OpenBLAS/issues/2654
+ emake AR="$(tc-getAR)"
+ emake AR="$(tc-getAR)" -Cinterface shared-blas-lapack
+ if use index-64bit; then
+ emake -C"${S}-index-64bit" INTERFACE64=1 LIBPREFIX=libopenblas64
+ fi
+}
+
+src_test() {
+ emake tests
+}
+
+src_install() {
+ emake install DESTDIR="${ED}" OPENBLAS_INCLUDE_DIR='$(PREFIX)'/include/${PN} \
+ OPENBLAS_LIBRARY_DIR='$(PREFIX)'/$(get_libdir)
+ dodoc GotoBLAS_*.txt *.md Changelog.txt
+
+ if use eselect-ldso; then
+ insinto /usr/$(get_libdir)/blas/openblas/
+ doins interface/libblas.so.3
+ dosym libblas.so.3 usr/$(get_libdir)/blas/openblas/libblas.so
+ doins interface/libcblas.so.3
+ dosym libcblas.so.3 usr/$(get_libdir)/blas/openblas/libcblas.so
+
+ insinto /usr/$(get_libdir)/lapack/openblas/
+ doins interface/liblapack.so.3
+ dosym liblapack.so.3 usr/$(get_libdir)/lapack/openblas/liblapack.so
+ fi
+
+ if use index-64bit; then
+ insinto /usr/$(get_libdir)/
+ dolib.so "${S}-index-64bit"/libopenblas64*.so*
+ fi
+}
+
+pkg_postinst() {
+ use eselect-ldso || return
+ local libdir=$(get_libdir) me="openblas"
+
+ # check blas
+ eselect blas add ${libdir} "${EROOT}"/usr/${libdir}/blas/${me} ${me}
+ local current_blas=$(eselect blas show ${libdir} | cut -d' ' -f2)
+ if [[ ${current_blas} == "${me}" || -z ${current_blas} ]]; then
+ eselect blas set ${libdir} ${me}
+ elog "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
+ else
+ elog "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
+ elog "To use blas [${me}] implementation, you have to issue (as root):"
+ elog "\t eselect blas set ${libdir} ${me}"
+ fi
+
+ # check lapack
+ eselect lapack add ${libdir} "${EROOT}"/usr/${libdir}/lapack/${me} ${me}
+ local current_lapack=$(eselect lapack show ${libdir} | cut -d' ' -f2)
+ if [[ ${current_lapack} == "${me}" || -z ${current_lapack} ]]; then
+ eselect lapack set ${libdir} ${me}
+ elog "Current eselect: LAPACK ($libdir) -> [${current_lapack}]."
+ else
+ elog "Current eselect: LAPACK ($libdir) -> [${current_lapack}]."
+ elog "To use lapack [${me}] implementation, you have to issue (as root):"
+ elog "\t eselect lapack set ${libdir} ${me}"
+ fi
+}
+
+pkg_postrm() {
+ if use eselect-ldso; then
+ eselect blas validate
+ eselect lapack validate
+ fi
+}